Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

18/02/2011 #1


regulacion voltage circuito
Buenos dias a todos,estoy intentando modificar un circuito que regula el voltage de salida por un pic,lo que estoy intentando es suprimir este pic por dos potenciometros para ajustar la salida a 5vdc y 24vdc,la corriente de entrada es de 50vdc,adjunto imagen



de este circuito e cogido solo la parte de control de potencia o a mi entender es la parte que gestiona la corriente de salida,esta es la parte que e copiado y montado



e modificado la resistencia de entrada del 2n5551 por una resistencia variable para ajustar el voltage que de entrada hay 5vdc,esto lo monte en el simulador y funcionaba bien pero aqui no me regula nada,siempre me da 34vdc de salida sin poder ajustarlo

que estoy haciendo mal o que parte del circuito e interpretado mal

saudos y gracias por todo
18/02/2011 #2

Avatar de Black Tiger1954

Sip, hay algo que estás haciendo mal.
Poné una resistencia de 3K3 en serie con la base Q3. Luego, el potenciómetro una punta a +5, la otra a tierra y el punto medio a la resistencia de 3K3.
PD: no saqué cálculos, pero supongo que esa R de 3K3 ya venía en el circuito.
18/02/2011 #3


buenas tardes,si la resistencia de 3.3k viene con el circuito,yo la quite y la substitui por una variable de 100k,puedo probar de dejar la de 3.3k y colcor la resistencia de 100k a ver si tengo suerte.Si se le ocurre algo mas a alguien es de agradecer, puebo esto cuando llege a asa y os lo comento a ver que tal fue.
saludos
18/02/2011 #4


pues nada lo mismo,sigue dando 33v a la salida pongas como pongas la resistencia de 100k y con las de 3.3k colocada en serie como esta en el esquema,incluso desconectando la base sigue dando los 33v,alguna cosa mas que me deje?

saludos y gracias
18/02/2011 #5

Avatar de Black Tiger1954

Poné la base de Q3 a masa y contá que pasa.
18/02/2011 #6


buenas ,con la base a masa se queda con 31v,e mirado mas cosas sobre las puertas RA3, RB7 Y RB6 que gestionava el pic antes y estas son las mediciones sin nada metalico en el iman RA3 - 0V , RB7 - 2.07V , RB6 - 0V . Poniendo algo metalico queda en RA3 - 5V , RB7 - 1.50V , RB6 - 0.30V . a ver si lo que gestiona todo el circuito va a ser RB7 y no los demas, puede ser esto que digo?

saludos
18/02/2011 #7

Avatar de Black Tiger1954

No. Si en la base de Q3 no hay tensión, no puede conducir. Fijate bien si conectaste todo correctamente, si los transistores de salida son PNP, etc.
18/02/2011 #8


lo unico diferente del esquema son estos componentes que en principio son compatibles

D7 6A1 = P600D
D9 FR32 = BY255
los demas son identicos
19/02/2011 #9


buenos dias a todos,haciendo mas pruebas resulta que tenia el Tip36c petado,lo cambie y ahora sin corriente en la base del 2n5551 no pasa corriente por el tip36c,a la que pongo tension en la base 5v o menos del 2n5551 automaticamente me rompe el tip36c comunicando C - E,repase el circuito y todo lo veo bien,alguna idea de por donde puede venir el fallo?

saludos y gracias
19/02/2011 #10

Avatar de Black Tiger1954

Que tipo de carga le estás poniendo?
19/02/2011 #11


buenas,la misma carga que tenia el circuito viejo,son 70v con el tester y el electroiman en el otro extremo
19/02/2011 #12

Avatar de Black Tiger1954

Entonces es probable que el circuito esté trabajando como PWM, no regula tensión si no el ancho de los pulsos, de ahí que se queme. No lo vas a poder manejar de forma tan simple, vas a tener que fabricar un generador de pulsos de ancho variable y frecuencia fija.
19/02/2011 #13


pues que putada,a ver yo lo que necesito es que de esos 50v que tengo de entrada necesito dos salidas una de 24v y otra de 5v,no se si sera mas facil bajar la corriente de esos 50v a 24v y 5v que no tener que montar un tren de impulsos,no se si es viable mi idea,si lo es no tendrias algun esquema para poder montar ese regulador de voltage y que aguante 3-4 amperios que es el fusible que tiene en el cable del electroiman?

saludos y gracias de nuevo
19/02/2011 #14

Avatar de Black Tiger1954

Esa tensión está siempre presente?
Es de un Pinball?
No hay disponible en otro lado 5 volts, como por ejemplo en la alimentación del PIC?
19/02/2011 #15


si,es de un pinball tengo 5v voltios y 24v que alimentan un motor,pero no se si con el consumo del electroiman puede provocar algun fallo en la maquina,el pinball es un goldeneye aqui esta el manual de la maquina

http://www.ipdb.org/machine.cgi?gid=3792

si lo puedes mirar y ves que puedo coger la alimentacion de estos voltages problema resuelto


saludos y gracias
19/02/2011 #16

Avatar de Black Tiger1954

Lo que no me contestaste es si ese motor tiene que estar funcionando constantemente o está controlado por algo.
Los 5 volts extra que necesitás, a cuanta corriente?

PD: probaste alimentar con una fuente externa ese motor? Cuanto consume realmente?
19/02/2011 #17


perdona no te entendi,el motor solo funciona en un determinado tipo de juego y no todo el rato,suele ser en la ultima bola del juego si haces una combinacion de switch se activa luego el electroiman que queda justo en el centro de un satelite para sujetar la bola dentro,supongo que tendra consumo ya que tiene que mantener la bola sujeta en el electroiman,la funciona del pic que tenia antes era que al lanzar la bola al electroiman este tenia 24v durante 2-3 segundos para captar la bola y una vez se cogia y el pic lo detectava bajava a 5v para mantenerse cogida,una vez finaliza el juego o si la bola no llega a cogerse al electroiman se para todo el circuito,no se si te respondido a lo que me preguntas

gracias
19/02/2011 #18

Avatar de Black Tiger1954

Sip, me respondiste lo que preguntaba, el problema, es que con esa respuesta, me quedan muuuuuchas más dudas
Vos tenés todas las señales de control? O sea, hay algo que cambie de estado en el momento en que debe activarse cada cosa? Son señales lógicas?
Y si entendí bien, la idea es que en un momento tenga 24 volts y luego 5?
19/02/2011 #19


si,tengo una señal de 0v - 5v cuando tiene que activarse o desactivarse el electroiman,para los 3 segundos cogere la señal de una bobina que queda activa 3 segundos,con un rele are el cambio de 24v - 5v con la señal de la bobina y activar o apagar el todo el circuito con la señal de 5v que me manda la cpu de la maquina

saludos
19/02/2011 #20

Avatar de Black Tiger1954

Okis, otra pregunta más, porqué no usás el PIC original? No tenés la programación interna?
Sea como sea, si la máquina fuera mía, no me molestaría en bajar la tensión que tenés y para que no haya problemas, un transformador de 220 (o 110 dependiendo de la tensión de línea) a 18 volts, un puente rectificador un diodo, y todo eso sin regular, se puede activar por relé o transistor. Y los 5 volts, no creo que sea mucho problema. Podes medir la resistencia en Ohms que tiene ese electroimán?
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.