Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/11/2008 #1


Sensor de proximidad usando el Sharp GP1U52X (problema)
hola amigos de www.forosdeelectronica.com antes que nada les doy un cordial saludo desde el bello estado de Hidalgo Mexico.

Soy nuevo en el foro como se daran cuenta es mi primer tema o comentario!

bueno pues la verdad queria solicitar su ayuda para hacer funcionar un sensor de proximidad infrarrojos usando como receptor el modulo Sharp GP1U52X, he mirado el DataSheet del receptor para informaciónrmarme de como es su diagrama de conexiones! y he usado como emisor un circuito que utiliza el CI 555 como ocsilador a 40kHz! les adjunto la imagen (cabe mensionar que ese diagrama no tiene la conexion a VCC se la he puesto en el circuito fisico)

ahora el verdadero problema es que cuando paso algun objeto para que rebote el haz de luz si prende el led que esta conectado al Vout del modulo receptor pero solo por un momento, hago pasar el objeto muchas veces y prende las veces que lo paso pero como les repito es solo por un momento si dejo el objeto rebotando el haz de luz prende y se apaga, y pues ahi esta el problema segun yo no deberia de pasar eso, se deberia mantener prendido el led si esta rebontando el haz de luz el objeto a sensar! hasta que deje de rebotar la luz! si estoy mal les ruego por favor me digan!

digo que algo esta mal porque me arme el sensor de proximidad que hay en el foro con el LM567 y funciona de maravilla, me refiero aque si detecta el objeto sensado hasta que ya no esta!

no se si me puedan ayudar con el modulo o con una solucion a mi problema, deseo que funcione como el del LM567!
De antemano gracias a www.forosdeelectronica.com y miembros!

nota: les adjunto los diagramas circuitales para que les sea mas facil ayudarme!
Saludos!

Espero aver posteado en el lugar correcto el tema si no pues alguien que lo mueva al lugar indicado!
25/11/2008 #2

Avatar de Eduardo

El GP1U52X tiene un filtro pasabanda bastante estrecho, se recomienda usar 40kHz +/-2kHz.

Si los 40kHz los mediste con el tester, algunos no son muy confiables y el problema seria por estar ligeramente corrido en frecuencia.
Para corregirlo (si el problema es este) no hace falta medir, directamente los enfrentas y moves el preset del 555 hasta que te quede 'centrado' , despues los alejas y repetis el ajuste.
25/11/2008 #3


gracias por la respuesta eduardo!

lo que estaba pensando es usar el 555 con la configuracion mono estable y calcular las R y el C a 40KHz como ves tambien seria una posible solucion?

saludos!
25/11/2008 #4

Avatar de Eduardo

Calcular el valor de los componentes te para 'estar en rango'. No te olvides que las resistencias comunes son al del 5 a 10% de tolerancia, los condensadores de 10 a 20% y encima estas redondeando a valores comerciales --> Que la frecuencia final resulte dentro de los 40 +-2 kHz (5%) seria casualidad.
Siempre vas a tener que usar un preset para dejarlo centrado en frecuencia.

Si de entrada no esta muy seguro de la frecuencia de oscilacion no es problema --> Empeza con un preset de 10K o agregale una R en serie y giralo hasta que funcione.
25/11/2008 #5


lo puedo checar el el osciloscopio hasta k tenga los 40khz con el preset!

bueno lo intentare mañana y posteo como me fue! espero k no siga el problema gracias saludos!
26/11/2008 #6


hola otra ves estoy molestando!
me he creado el circuito ocislador con el 555 a 40khz lo medi en el osciloscopio y pues me sigue haceindo lo mismo! ayuda porfas!
saludos!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.