Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

14/12/2011 #181


Hola, el LM35, si no me equivoco te da una salida de 0 a 5V. Por lo que si queres que tu salida sea de 0 a 10V tenes que amplificar por 2. Para esto, en tu ecuacion Vo=Vi(1+R1/R2), Vo = 2 lo lo que ta un grado de libertad en R1 o R2. Lo que tenés que hacer es elegir una de las dos resistencias al valor que quieras, del orden de los 10K por ejemplo y ahi obtengas el valor de la otra.
Lo mismo ocn el divisor resistivo, tenes un grado de libertad por lo que podes elegir una de las resistencias como quieras.
Saludos
14/12/2011 #182


Muchas gracias Koropatula por la respuesta me voy a poner simular a ver k mesale. Un saludo

---------- Actualizado después de 32 minutos ----------

aaa se me olvidaba el LM 35 te da 10mV por grado centigrado y va desde -0.55V para -55ºC hasta los 1.5V para 150ºC yo kiero trabajar en rango de temperaturas de 10ºC a 70ºC pero vamos la duda de las R me ha quedado resuelta. Seguire currando en ello. Muchas gracias y un saludo.
15/12/2011 #183

Avatar de edbeco

krash88 dijo: Ver Mensaje
Muchas gracias Koropatula por la respuesta me voy a poner simular a ver k mesale. Un saludo

---------- Actualizado después de 32 minutos ----------

aaa se me olvidaba el LM 35 te da 10mV por grado centigrado y va desde -0.55V para -55ºC hasta los 1.5V para 150ºC yo kiero trabajar en rango de temperaturas de 10ºC a 70ºC pero vamos la duda de las R me ha quedado resuelta. Seguire currando en ello. Muchas gracias y un saludo.
kuropatula dijo: Ver Mensaje
Por nada, segui el mismo procedimiento que hice antes, ahora para los datos que te sirven a vos.
Saludos!
Bueno yo tambien quiero hacer algo similar, tengo un LM35 el cual me bota 10mV por grado y, trabaja desde -55º - 150º c.

He usado un amplificador no inversor solo con fuente positiva, con esto logro que no me amplifique los milivoltios negativos que me pueda entregar el sensor, teniendo en la salida un rango de voltaje de 0-15 voltios, ya que el máximo voltaje que vota el sensor es 1.5v para 150ºc, 1.5v x 10 = 15v. Yo quiero que el rango de salida sea solo desde 0-10 voltios...
Cómo haría para obtenerlo?

El pot. de 2k es para calibrar la salida.
Uso una fuente de 24v, ya que quiero implementarlo con un PLC.

15/12/2011 #184


Te sirve si le pones un divisor resistivo a la salida del operacional?
15/12/2011 #185


Hola Zofim, tio yo estoy investigando el tema y tengo un circutillo por ahi que acondiciona la señall del lm35 de 0 a 5V lo busco y te lo paso..pero tengo el mismo problema; como diablos hago el escalado?????? si averiguas algo comentamelo porfa, un saludo.
15/12/2011 #186

Avatar de edbeco

krash88 dijo: Ver Mensaje
Hola Zofim, tio yo estoy investigando el tema y tengo un circutillo por ahi que acondiciona la señall del lm35 de 0 a 5V lo busco y te lo paso..pero tengo el mismo problema; como diablos hago el escalado?????? si averiguas algo comentamelo porfa, un saludo.
Oye algo que también podemos hacer es calcular una ganancia de tal manera que nos arroje como máximo un voltaje de 10v.

10v/1.5v = 6.66... es decir que nuestro amplificador no inversor tiene que tener una ganancia de 6.67x aproximadamente y no de 10x como pensamos en un inicio. De esta manera para una tº de 150ºc tendremos 10v en la salida.

Bueno yo pienso usarlo con un PLC 1200 SIEMENS. Considerando la resolución del módulo analógico, no debería tener problema alguno para reconocer los distintos valores de tensión que me arroje el operacional... Uhm... sólo tendré que probarlo para ver cómo responde...espero funcione bien.

En el circuito he agregado un pot. de 1k de tal manera que pueda tener una mejor calibración cuando este probando el circuito con el PLC.

Este es el circuito, de todas formas me interesa el diseño del que hablas para ver cómo trabaja y si se pude modificar a nuestra convención.

Saludos!



Aquí otra captura, LM35 arrojando el máximo valor en voltaje 1.5v y salida como máximo en 10v.
15/12/2011 #187


Madre mia tenia un cacao con lo de ganancia impresionante y acabo de verlo en tu circuito. No se que calculos hacia yo que se me iba de baras...solucionado!!
Ok, he visto por ahi que es recomendable poner un seguidor de tension a la salida del lm35 para aislar el sensor y obtener mayor precision en la medida al no haber perdidas, o caidas de tension o cualquier circuntancia que pudiera falsear la salida en circuito amplificador. Y una pregunta no te sobraria un potenciometro en el circuito??
Otra cosa mas no habia caido pero en el datasheet de lm35 vienen configuraciones de circuitos muy intersantes para obtener diferentes resultados.
Voy a ponerme la pila e ire comentado mis progresos por aqui, pero despues del fin de semana que viene calentito. Un saludo a todos y buen fin de semana...
19/12/2011 #188


-DarkNess- dijo: Ver Mensaje
Hola que tal ya hice ese circutio para una practica lo hice con comparadores y compuertas logicas ya que no tube otra eleccion y no encontre nada en internet entre un cuate y yo hemos diseñado este circuito y espero que te sea de utilidad si quieres mas información dilo suerte
el circuito que vos posteaste me serviria para armar un termostato para controlar una resistencia calefactora de 50 watt porque el hecho es que yo quiero calentar algo y poder ajustar un temperatura tope y tenia pensado con un lm34 y jugar con las resistencias conectandolas en serie con un selector es decir poner una escala termica de 20 a 36 ºc ycalcular las resistencias para cada temperatura poniendolas a la entrada de una compuerta and y que con las resistencias me caiga la tension lo suficiente para tener una señal baja y no alta como cuando quiero que caliente, me podrias ayudar ¿?
03/01/2012 #189


bravegabriel dijo: Ver Mensaje
que tal:
pues dejame decirte que yo hice este circuito tal y como esta sin alterar nada en lo absoluto y me funciono a la perfeccion puedes encontrar muchos en internet pero este es el unico que te puede servir por que eh probado otros y ninguno funciono y este no tiene ninguna complicacion solo conecta adecuadamente y checa que tus piezas funcionen suerte y un consejo hazlo por etapas poco a poco
Hola amigo bravegabriel,una pregunta y que programa usastes para grabar el pic?Saludos
04/01/2012 #190


Hola mi pregunta es la siguiente:
Tengo que hacer un medidor de temperatura para la máquina de un microbus, recuerden que lo que mido es la temperatura del agua que la rodea, el sistema apenas lo voy a implementar pero necesito saber que tan bueno es usar el LM35, pues tiene que ser un "eficiente" medidor. O será mejor usar un termistor?
Gracias por sus comentarios
11/03/2012 #191


Sensor de temperatura LM35
Buenas tardes a todos, para hacer un proyecto bastante simple que involucra medicion de temperaturas, me compre el famoso LM35.

El problema que tengo para comprobar su correcto funcionamiento es que no se contra que compararlo. Lo unico que tengo es un termometro digital berreta.
Les hago unas preguntas:

1) ¿les parese buena la idea soldarlo a un cable (alimentacion, masa, salida) y luego proteger el sensor con alguna bolsa de naylon hermetica; y meter el conjunto en un vaso con agua y mucho hielo para comprobar que de valores de temperatura den cercanos a cero grado?
La idea seria tambien realizar diferentes mediciones y comparar los resultados con los del otro termometro (termometro diguital comercial medio berreta que tenia de antes).

2) El rango de temperaturas de trabajo de mi circuito va a ser de 0 a 10 grados aprox. Soy nuevo en esto y no se si entendi bien la hojas de datos (LA ADJUNTO AL FINAL), ¿Debo implementar la segunda "typical application" (figura 2 de la primer pagina) ya que la primera y mas simple solo admite un rango de 2 a 150 grados? ¿es correcta mi comprencion?

3) ¿ustedes piensan que el sensor se aguantara trabajar dentro de una heladera? (pregunto por la humedad)


4) Ya que esta les pregunto tambien sobre otra parte del circuito ¿Porque siempre recomiendan usar un integrado comparador especialmente diseñado para eso (que no es otra cosa que operacionales) y no un simple operacional como el 741 conectado como comparador? ¿que tiene de malo un operacional normal para mi fin, si a mi no me interesa que la salida High y Low sean muy presisas (me da lo mismo que Voh valga 5V o 5,2V y que Vol sea 0V o 0.3V)?


Gracias a todos de antemano, saludos!!
Archivos Adjuntos
Tipo de Archivo: pdf LM35.PDF (303,5 KB (Kilobytes), 177 visitas)
11/03/2012 #192


Que tal!, 1) lo de la bolsa es una solucion temporal y no va a haber ningun problema siempre en cuanto tomes las medias para que no le entre agua. Ahora cuando vayas a montarlo si solo vas a trabajar con temperaturas frias puedes derretir silicona (la de las pistolitas) y envolverlo. Yo lo que hice una vez fue colocarlo en un tubo de ensayo, esos de vidrio de laboratorio, luego seyarlo con silicona y en el extremo con masilla "poxilina".

3) No deberias tener problema, siempre esté bien sellado para que la cristalizacion no haga corto entre las patas.

4) Respecto del operacional creo no hace falta, yo utilice cualquiera operacional que encontré por ahi, despues lo calibras con el potenciometro. Nose como es el circuito que pretendes diseñar.

saludos
11/03/2012 #193


Hola Gonzalo, ¿Como andas? en primer lugar muchisimas gracias por tu respuesta!!

"para que la cristalizacion no haga corto"
Pero mira que la heladera no llega a enfriar tanto como para congelar. Es heladera, no congelador. ¿pensas que igual tengo que sellar el sensor?

¿Si en vez del tubo de ensallos (que me parese muy voluminoso), le pongo silicono alrededor solo con la pistola sin nada alrededor? (le pongo primero de un lado espero que se seque y luego le pongo del otro)

¿viste el datasheet? seria importante para mi que me respondieran la pregunta 2) que hice al principio.

Muchas gracias, saludos!!
12/03/2012 #194


Hola si, el sensor si va a trabajar en frios puedes tranquilamente colocarle silicona. Solo envuelvelo y luego lo moldeas con los dedos, mas que todo por los terminales.

Primero fijate que version es:
LM35,LM35A −55˚C to +150˚C
LM35C,LM35CA −40˚C to +110˚C
LM35D 0˚C to +100˚C

El ciercuito 2 es el que tienes que usar, poruqe vas a medir temperaturas frias. Si la entrada es de 12v, colocas una resistencia de 2,2Mohm (rojo,rojo,verde) entre Vout y GND. Para medir su funcionamiento simplemente colocas el voltimetro positivo a la pata Vout del sensor y negativo a GND.

Saludos Espero que te sirva
16/03/2012 #195


Hola Gonzalo, ¿como andas?. Tengo una duda con respecto al sensor.
Ya arme todo, es decir solde los pines del LM35 a unos 80cm de cable blindado (la malla es la tierra) y en al otro extremo del cable le solde alambres como para ponerlo en el protoboard.

Alimente con casi 6 Voltios y obtuve algo que no me gusto mucho.

La temperatura marcada no me convence: da 22,9 grados (229 mv) cuando se muy bien que aca no hace esa temp, pues debe estar haciendo a lo sumo 19...

Esa lectura la hice utilizando la configuracion 1 (segun datasheet) es decir la mas simple.
Luego implemente la conf 2 poniendo a la salida 120K y -6 V (porque 6v/120K = 50 micro ampere) y me da lo mismo.

agarre el sensor entre dos dedos y luego de 2 min me da que tengo 31,5 grados (o sea que estoy medicamente muerto jeje).
Repeti la operacion pero utilizando la configuracion 1 (o sea que desconecte la R de 120K a la salida del sensor) y me da un disparate: Ya que me mori, ahora debo estar en el infierno porque segun el sensor tengo 82 grados y subiendo. Sin soltar el sensor entre los dedos; vuelvo a conectar la R a - 6 V (implemento conf 2) y baja de golpe a temperaturas mas creibles de 35 grados

Tras fastidiarme, solte el sensor y lo deje al aire; y volvi a mirar la pantalla del tester y luego de 5 min me da 23,4 grados y bajando lentamente...
Si conecto la R de vuelta no se altera la medicion...

Estoy confundido; no se si estoy ancioso y no le doy tiempo al sensor a que se "acomode" a la nueva temp (en el datasheet dice que tarda aprox 2 min en estabilizarse, tiempo que le estoy dando!) o si el sensor esta fallando.

Vos que tenes experiencia con este bichito que me recomendas? ¿Supuestamente si meto el sensor en un vaso con o mucho hielo y agua deberia darme 0 grados, no?

Te paso algunas fotos que saque (Como notaras, no soy un experto soldador jeje)

Mañana en el laburo voy a pasarle silicona con la pistola, asi puedo meter el sensor en agua y hacer mas ensayos, pero desde ya creo que algo anda mal..

Saludos y muchas gracias!!

---------- Actualizado después de 2 minutos ----------

De ultima, pienso: Si me tira un "offset" de 5 o 10 grados mas; lo compenso en el circuito comparador; pero me gustaria ver que todo andubiera bien.

Abrazo!
Imágenes Adjuntas
Tipo de Archivo: jpg DSC04899.JPG (23,1 KB (Kilobytes), 57 visitas)
Tipo de Archivo: jpg DSC04898.JPG (69,5 KB (Kilobytes), 65 visitas)
Tipo de Archivo: jpg DSC04900.JPG (72,3 KB (Kilobytes), 58 visitas)
16/03/2012 #196


Sensor LM35 + comparador (Consulta)
Hola a todos,

Quería preguntar sobre algo que me ha ocurrido un tanto extraño. He montado un circuito bastante sencillo. Se trata de un sensor LM35 que va a una de las patas del un operacional configurado como un comparador con histéresis y a la otra pata le conecto un divisor de tensión que hace de referencia. Cuando la temperatura medida por el LM35 es superior a la referencia, la salida del operacional pasa a "estado alto".

Ahora viene el problema: Si alimento el operacional (TL082) entre +12V y -12V va todo perfecto pero si lo conecto entre +12V y GND, el LM35 marca MISTERIOSAMENTE 10ºC más de la temperatura debería leer. En ambos casos el LM35 lo alimento entre +12V y GND tal y como se muestra en su datasheet.

Yo pensaba que debería de funcionar todo correctamente de ambas formas, ¿alguien me podría decir porque me está ocurriendo esto?.

Saludos y gracias.
16/03/2012 #197

Avatar de eL1ct

Hola: si nos pones el diagrama del circuito que estas utilizando, seguro que te podremos ayudar mejor.
16/03/2012 #198


Tienes razón, quizás debería haber empezado por ahí. Os adjunto el circuito que quiero realizar en PDF, la idea es alimentar a 12V y conectar en los terminales CN1 un relé o un pequeño ventilador a 12V.

Tal y como he explicado antes, si monto el circuito tal y como está y mido tensión a la salida del LM35 me marca entre 10 y 20ºC mas de la temperatura real y si alimento el operacional entre +12V y -12V el circuito va perfecto... No entiendo el por qué...
Archivos Adjuntos
Tipo de Archivo: pdf Livewire - Professional Edit.pdf (6,0 KB (Kilobytes), 159 visitas)
16/03/2012 #199

Avatar de phavlo

A la salida del LM35 ponele una R de 100 Ω y después de la R, un C de 100nF en paralelo con la salida.
Como muestra la imagen:
http://www.national.com/mpf/LM/LM35.html#Overview
16/03/2012 #200

Avatar de eL1ct

Hola:

Creo que el principal problema esta en que el operacional no es apropiado para hacerlo trabajar asi, si te fijas en el datasheet del TL082, veras que la entrada esta formada por dos transistores p-channel J-fet las cuales, creo que te estan actuando como diodos ya que, si te vuelves a fijar en el datasheet del TL082, si no me equivoco, estas haciendo trabajar al operacional fuera de su rango de entrada (yo me fijo en "common-mode input voltage range").

Ahora que me fijo, los operacionales mas comunes estan diseñados para que funcionen en un rango de tension de entrada alto, por ejemplo desde Vcc (siendo la tension de alimentacion positiva) hasta Vdd+3v (aproximadamente) (siendo vdd la tension de alimentacion negativa, o en tu caso 0v). Tambien hay otros que funcionan al reves, con un rango de entrada desde Vcc-3v hasta Vdd. Y por ultimo hay otros que los llaman "rail to rail" serian los de "full range". (Supongo que esta es la razon por la que funciona bien entre +12v y -12v).

En tu lugar probaria cambiando el operacional, yo te puedo dar unas referencias de los operacionales que yo utilizo, son solo referencias, puedes buscar otros que te sirvan fijandote en el "common-mode input voltage range".

Los que trabajan con la entrada cerca de la alimentacion negativa:
Lm358 (creo que este te ira bien, de todos modos, no tiene fama de ser un operacional muy bueno para audio, aun asi creo que para esto podria ir bien)
tlc220x (siendo x el numero de operacionales integrados, que yo sepa 1 o 2)
tlc226x, tlc227x (estos son carillos, no los recomiendo para esto)

Tambien conozco uno full rail to rail; con entradas y salidas rail to rail:
LMC7101 (estos los compre un monton a muy buen precio, chiquititos SMD y tabajan desde 2,7v hasta 15v, no es lo mejor que hay, pero los adoro)

un saludo.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.