Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

16/10/2010 #101
Moderador general

Avatar de Fogonazo

Respuesta: Sensor de temperatura con LM35
gustavo calchav dijo: Ver Mensaje
.....conoces algùn regulador de voltaje que me cambie la polaridad, es decir tengo 15V alimentando un circuito impreso.....
No es considerado hacia otros participantes del Foro referir una consulta a una sola persona, existe mucha gente tanto o mas capacitada que yo como para responderte.

Un LM2576 puede hacerlo, si necesitas poca corriente, un LM7660
16/10/2010 #102


Respuesta: Sensor de temperatura con LM35
Gracias por el dato!!!
Por cierto, disculpa; no habìa tomado en cuento acerca del proceso de consultas en el foro...
saludos,
G. Calchav
16/10/2010 #103

Avatar de Ajna

Respuesta: Sensor de temperatura con LM35
gustavo calchav dijo: Ver Mensaje
Hola señores,
tengo una duda...Espero bastante sus sugerencias; estoy programando el ATMEGA8 (que tiene 8 bits en registros)...Cuando obtengo 255 desde el ADC sì puedo transformarlo en su equivalente ascii. El problema està para 256 en adelante,
00000001 00000000 =256
Si hago la transformaciòn ascii obtengo 10, que no es 256. Pues no puedo operar todo ese nùmero, ya que es de 9 bits, lo estoy rompiendo...¿Què me sugieren?.
Saludos cordiales.
G. Calchav.
Pues yo estoy exactamente en el mismo dilema jajaja eso es una conversion de binario a BCD con 9 bits puedes obtener como maximo 512 BCD y con 10Bits pues 1024 BCD, esto lo solucionas dividiendo el valor binario que tienes "para el caso de 9Bits" entre 100 y tienes el primer digito bcd, luego al residuo le apliacas lo mismo pero ahora entre 10 y obtienes segundo digito BCD y el ultimo residuo es el tercer digito bcd

Osea mas o menos asi

int BCD2 = 512 / 100; BCD2 = 5; entero
int aux = (512%100); y te sobran 12
int BCD1 = aux/10; BCD1 = 1; entereo
int BCD0 = (aux%10) BCD0 = 2; entero

Creo no se me lo saque de la manga ahorita ay se ven voy ir a probar, por cierto alguien sabe como hago el tratamiento distinto para cada una de las entradas del ADC en lenguaje C

Ejemplo si convierto usando la entrada ADC0 ejecuto una rutina
Si convierto usando la entrada ADC1 ejecuto otra rutina
y asi esto porque quiero medir 6 temperaturas distintas pero quiero tratarlas de forma distinta

Es cierto no funciona asi como lo pensaba, cuando llega a 0256 salta a todo en ceros 0000 en ves de saltar a 0257 ¿Porque? alguien sabe, o conoce una rutina para convertir un numero binario de 16bits a BCD
18/10/2010 #104


Respuesta: Sensor de temperatura con LM35
Hola,
el problema anterior de conversiòn lo resolvì con divisiones sucesivas (similar al còdigo que sugieres)...Aquì te lo presento en Vmlab:
REST_SUC:

CPI R25,$00
BREQ FINCA
INC R23
SUB R24,R26
SBC R25,R27
RJMP REST_SUC
FINCA:
CPI R24,$64
BRLO FINCA2
INC R23
sub r24,r26
RJMP REST_SUC
FINCA2:
CPI R24,$0A
BRLO FINCA3
INC R22
subi r24,$0a
RJMP REST_SUC
FINCA3:
ADD R24,R21;UNIDAD
ADD R22,R21;DECENA
ADD R23,R21;CENTENA

POP R21
ret

Por cierto,
Por favor, alguno de ustedes ha trabajado con el L7905CV y/o L7915CV; ya que tengo la entrada de 15V (DC) Y NECESITO SALIDAS DE -15 Y -5, PARA ALIMENTAR opamps...lOS HE TRABAJADO EN BASE AL DISEÑO QUE SUGIEREN EN EL DATASHEET DE AMBOS EMPERO no me estàn dando los voltajes deseados y ademàs uno de ellos recalienta demasiado!!!
Què me sugieren???...Tienen un diseño que les halla cumplido esas conversiones???
...saludos,
G. Calchav
23/10/2010 #105


LM35 se calienta demasiado... esto es normal???
Bien buena tarde a todos....

Bueno el problema que tengo es el siguiente estoy haciendo un sensor de temperatura con un lm35 luego lo comparo con un lm324 y luego ese voltaje lo mero a la señal del LM3914 que me indicar por led el valor de la temperatura actual ,pero al conectarlo correctamente el sensor se empieza a calentar demasiado a tal punto
que si lo tocas te quemas... y no se qUE esta pasando si alguien me podria ayudar. Dejo el diagrama para qUE me pueda echar una manita
Imágenes Adjuntas
Tipo de Archivo: jpg iy22id.jpg (193,7 KB (Kilobytes), 114 visitas)
23/10/2010 #106
Moderador general

Avatar de Fogonazo

Respuesta: LM35 se calienta demasiado... esto es normal???
Analiza esto:
Si el LM35 se calentara por si solo, ¿ Que temperatura estaría midiendo ?
¿ La real ? o ¿ La de su propio calentamiento ?

El LM35 NO se calienta, si lo hace, está dañado o mal conectado.
23/10/2010 #107


Respuesta: LM35 se calienta demasiado... esto es normal???
si fijate que revise el Datasheet y lo conecte correctamente pero se calento desde qUE lo conecte la primera vez no se que pasaria :(
23/10/2010 #108
Moderador general

Avatar de Cacho

Respuesta: LM35 se calienta demasiado... esto es normal???
Y V+ es de ¿qué valor?
¿Está conectado entre V+ y GND o entre V+ y V-?
Viéndolo con la parte plana de frente a vos, ¿cómo es, de izquierda a derecha, el orden de las patas que tomaste?

Saludos
23/10/2010 #109

Avatar de panxozu

Respuesta: LM35 se calienta demasiado... esto es normal???
Ese circuito lo monte y me ocurrio lo mismo, mi dedo quedo marcado con el lm35 de lo caliente que estaba, digamos que lo conecte al reves :enfadado: . la unica manera para que el lm35 se caliente es que lo conecten mal. Ay que ser cuidadoso en las conexiones sino te lo truenas.
Imágenes Adjuntas
Tipo de Archivo: jpg LM35.jpg (48,1 KB (Kilobytes), 104 visitas)
23/10/2010 #110
Moderador general

Avatar de Fogonazo

Respuesta: LM35 se calienta demasiado... esto es normal???
panxozu dijo: Ver Mensaje
Ese circuito lo monte y me ocurrio lo mismo, mi dedo quedo marcado con el lm35 de lo caliente que estaba, digamos que lo conecte al reves :enfadado: . la unica manera para que el lm35 se caliente es que lo conecten mal. Ay que ser cuidadoso en las conexiones sino te lo truenas.
Dijo Confucio (Filosofo Chino 551 a. C. - 479 a. C.): "Quién se quema con un semiconductor, ! Cuando ve el silicio llora ¡ "

23/10/2010 #111


Respuesta: LM35 se calienta demasiado... esto es normal???
pUEs con la parte plata viendo hacia mi de izquierda a derecha tengo
GND - VOUT - V+
y
con la pansita al frente tenmos

V+ - Vout - GND

pUEs panxozu como es la forma correcta de conectarlo porqUE yo lo conecte como esta de el datasheet
http://www.national.com/ds/LM/LM35.pdf
23/10/2010 #112
Moderador general

Avatar de Fogonazo

Respuesta: LM35 se calienta demasiado... esto es normal???
Mira la imagen:
Vista desde abajo
+Vs: Alimentación
Vout: Señal de salida
GND: Tierra del circuito
Imágenes Adjuntas
Tipo de Archivo: gif LM35.gif (3,9 KB (Kilobytes), 349 visitas)
23/10/2010 #113

Avatar de panxozu

Respuesta: LM35 se calienta demasiado... esto es normal???
Fogonazo dijo: Ver Mensaje
Vista desde abajo
exacto, en el datasheet te indican las patillas vistas desde abajo, a veces eso puede confundir si no te fijas bien en lo que dice.

como lo tenias conectado estaba mal, interpretaste mal la imagen del datasheet
15/11/2010 #114


Hola a todos,

Quisiera saber si pueden ayudarme a saber si este circuito es correcto, lo conecté a 5V y el potenciómetro de 50k se me quemó, espero que no se haya quemado el LM35. El circuito es un sensor de temperatura con LM35 que tiene un Op Amp, el LM324. Por favor ayúdenme a saber si funcionará y más o menos a darme idea de cuánto está amplificando.
También, ¿para qué me sirven ahí los potenciómetros? ¿tengo que variar su valor para calibrar la salida o algo así?

Muchas gracias, es muy importante porque es para un proyecto final.

http://www.forosdeelectronica.com/pr...termometro.htm
15/11/2010 #115
Moderador general

Avatar de Fogonazo

rickastralboy dijo: Ver Mensaje
....Quisiera saber si pueden ayudarme a saber si este circuito es correcto, lo conecté a 5V y el potenciómetro de 50k se me quemó, ........
Si se te quemó el preset de 50KOhms, es porque conectaste algo muy, muy mal.
15/11/2010 #116


Ok, gracias, sí ya revisé y espero que ya haya quedado bien, no crees que debía bajarle al voltaje de 5 V a 2 V por ejemplo?

Qué me puedes decir del circuito? crees que sirva?

Gracias!
15/11/2010 #117
Moderador general

Avatar de Fogonazo

Si le reduces la tensión a +- 2V los operacionales trabajarán mal, o directamente no lo harán.

Aparentemente parece que funciona (Opinión sin mayor análisis).
15/11/2010 #118


Fogonazo dijo: Ver Mensaje
Si le reduces la tensión a +- 2V los operacionales trabajarán mal, o directamente no lo harán.

Aparentemente parece que funciona (Opinión sin mayor análisis).
Ah ok, qué bueno que me dices...

Alguien entonces puede ayudarme por favor analizando el circuito para saber si es correcto? Les agradezco mucho, es que es muy importante!!!
19/02/2011 #119


Hola. Veo que aqui estan trantando el tema de operacionales asi que mi duda es la siguiente... El amplificador operacional de la izquierda (adjunto el circuito) esta en modo Inversor? Y como puedo calcular la tension en la entrada no inversora del mismo? El LM 335 proporciona 100mV cada 1ºC. Desde ya gracias. Saludos.
Imágenes Adjuntas
Tipo de Archivo: jpg circuito operacionales2.JPG (21,0 KB (Kilobytes), 156 visitas)
26/02/2011 #120


-DarkNess- dijo: Ver Mensaje
Hola que tal ya hice ese circutio para una practica lo hice con comparadores y compuertas logicas ya que no tube otra eleccion y no encontre nada en internet entre un cuate y yo hemos diseñado este circuito y espero que te sea de utilidad si quieres mas información dilo suerte

que tal quisiera saber con que voltaje se alimenta el circuito y si por ejemplo se alimenta con 15 y -15 y las compuertas con 5 oseas con un voltaje independiente gracias saludos
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.