Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?
08/07/2016 #1


Suitcheo con transistor TIP32C
Buen día.

Sucede que estoy tratando de hacer un circuito con displays multiplexados de anodo común por lo que uso el TIP32C para realizar el suicheo de la corriente, sin embargo sucede que: sea que la entrada por base sea +5v ó 0v el transistor suichea de igual manera y nunca se apaga el display.

Será que tienen idea de que puedo estar haciendo mal.



Nota. El suicheo lo realiza un pic

Les agradezco mucho cualquier ayuda ...
08/07/2016 #2

Avatar de pilm

Tu problema es que tienes 9V en el emisor del transistor; debe ser 5V
08/07/2016 #3


pilm dijo: Ver Mensaje
Tu problema es que tienes 9V en el emisor del transistor; debe ser 5V
Gracias por responder, pero que pasa si mis displays funcionan a 9v, no puedo hacer el suicheo de esta manera?
08/07/2016 #4

Avatar de ruben90

Podrías tener 100VDC en el emisor (dependiendo del transistor claro ) y debería funcionar. Claro que como es un PIC, necesitaras colocar otro transistor por seguridad.
08/07/2016 #5


ruben90 dijo: Ver Mensaje
Podrías tener 100VDC en el emisor (dependiendo del transistor claro ) y debería funcionar. Claro que como es un PIC, necesitaras colocar otro transistor por seguridad.
El detalle es que si hago lo que me sugiere pilm, inmediatamente funciona, pero si el voltaje que esta en el emisor del TIP es una fuente diferente, ya me sucede lo mismo el transistor no realiza el suicheo correcto, ¿Porque puede ser?
08/07/2016 #6
Moderador

Avatar de elaficionado

Hola.

No tomes en cuenta los valores.





Chao.
elaficionado.
Imágenes Adjuntas
Tipo de Archivo: gif swicth2.gif (23,4 KB (Kilobytes), 88 visitas)
Tipo de Archivo: gif swicth1.gif (38,2 KB (Kilobytes), 88 visitas)
08/07/2016 #7

Avatar de pilm

Ecj; Porque dices que funcional a 9V?
En un led, lo importante es la corriente entre ánodo y cátodo (por lo general entre 10mA y 15mA) El voltaje solo debe ser superior al que el polarización directa cae entre ánodo y cátodo, característica ésta asociada al color del led. Por ejemplo para el rojo si mal no recuerdo es de 2.1V. Por eso siempre se pone en serie una resistencia. Así por ejemplo; si usas una fuente de 5V, en el led se quedan 2.1V, para la resistencia sobra 2.9V, si deseas que circulen 10mA, 2.9/0.01 = 290. Pones una resistencia de 290 ohm.

---------- Actualizado después de 8 minutos ----------

Si el voltaje con el que atacas la base es menor al usado en el emisor, siempre tendrás polarizada directamente la juntura emisor-base y por tanto siempre habrá corriente de emisor a colector y tu display siempre estará encendido. Por tanto si importa tener 5V o 9V (o 100V como alguien mesiona)
08/07/2016 #8


pilm dijo: Ver Mensaje
Ecj; Porque dices que funcional a 9V?
Esto es porque los display son unos display grandes y funcionan a ese voltaje, a 5v dan una luz demasiado tenue.

El led solo es una representación en el esquema
08/07/2016 #9

Avatar de ruben90

ruben90 dijo: Ver Mensaje
Podrías tener 100VDC en el emisor (dependiendo del transistor claro ) y debería funcionar. Claro que como es un PIC, necesitaras colocar otro transistor por seguridad.
...y sostengo lo que dije. Prueba el siguiente circuito:
Q1 es el TIP32C y Q2 cualquier transistor de pequeña potencia (BC547, 2N2222, 2N3904, etc).
Imágenes Adjuntas
Tipo de Archivo: jpg imagen01.jpg (44,5 KB (Kilobytes), 19 visitas)
08/07/2016 #10

Avatar de pilm

Mmmm... solo si internamente cada segmento esté formdo por varios leds en serie. Tiene el número de parte? o usa fuente de 5V y mide cuanto hay entre ánodo y cátodo y me cuentas...

---------- Actualizado después de 6 minutos ----------

Pues sí, ruben90, tu circuito funciona. Pero, si se pude solucionar con un solo transistor y una sola fuente?. Entre mas sencillo, mejor...
08/07/2016 #11


ruben90 dijo: Ver Mensaje
...y sostengo lo que dije. Prueba el siguiente circuito:
Q1 es el TIP32C y Q2 cualquier transistor de pequeña potencia (BC547, 2N2222, 2N3904, etc).
Perfecto, esta conexión funcione bien.

Pero no entiendo porque que diferencia hace estre transistor NPN antes del PNP, que no logra directamente el PIC
08/07/2016 #12

Avatar de ruben90

pilm dijo: Ver Mensaje
Mmmm... solo si internamente cada segmento esté formdo por varios leds en serie. Tiene el número de parte? o usa fuente de 5V y mide cuanto hay entre ánodo y cátodo y me cuentas...

---------- Actualizado después de 6 minutos ----------

Pues sí, ruben90, tu circuito funciona. Pero, si se pude solucionar con un solo transistor y una sola fuente?. Entre mas sencillo, mejor...
Pues si, pero el compañero no da mas información y sin maíz no puedo hacer tortillas . El especifico el componente (TIP32C), pero lo primero que se me vino a la mente fue un MOSFET .

Ecj dijo: Ver Mensaje
Perfecto, esta conexión funcione bien.

Pero no entiendo porque que diferencia hace estre transistor NPN antes del PNP, que no logra directamente el PIC
eso ya te lo explico el compañero pilm en el post#7, y el transistor NPN evita eso.
09/07/2016 #13


pilm dijo: Ver Mensaje
Mmmm... solo si internamente cada segmento esté formdo por varios leds en serie. Tiene el número de parte? o usa fuente de 5V y mide cuanto hay entre ánodo y cátodo y me cuentas...

---------- Actualizado después de 6 minutos ----------
Saludos.

Este es el display que estoy usando:

http://www.datasheets360.com/pdf/-1996421161851072873

Si tambien me gustaria si no se necesitara el transistor intermedio, pero sino por lo menos ya existe una solucion

---------- Actualizado después de 6 minutos ----------

ruben90 dijo: Ver Mensaje
Pues si, pero el compañero no da mas información
Que otra información puedo darte, el PIC es un 16f883
09/07/2016 #14

Avatar de pilm

Efectivamente, tiene varios leds en serie (3). Con 5V no funcionaría. Tienes que usar un circuito con dos transistores como el de Ruben90. Con un solo transistor funcionaría solo si fueran de cátodo común.
09/07/2016 #15

Avatar de ruben90

OK , verifique el datasheet del display con calma y claro que se puede con un solo transistor, pero NO del tipo PNP (sorry ). Prueba el siguiente circuito:
Imágenes Adjuntas
Tipo de Archivo: jpg imagen02.jpg (62,1 KB (Kilobytes), 11 visitas)
09/07/2016 #16


Muchas gracias pilm y ruben90 por el apoyo.

Si ruben efectivamente asi podria funcionar bien, sólo que esa parte ya se hace para formar el numero en el display y por el otro lado tambien debo suicharlo para multiplexar y hacer el contador de varios digitos.

Pero entonces ajustare la placa para agregar los transistores adicionales.

MUCHAS GRACIAS,
17/07/2016 #17
Moderador

Avatar de elaficionado

Hola.

Más vale, tarde que nunca.



Chao.
elaficionado.
Imágenes Adjuntas
Tipo de Archivo: gif sw222.gif (5,6 KB (Kilobytes), 33 visitas)
27/07/2016 #18


Leí todo y quedé con una duda, por qué estaba sucediendo lo que ECJ dijo? si alguien pudiera sacarme de la duda se lo agradecería.
27/07/2016 #19
Moderador

Avatar de elaficionado

Hola.

Para que el transistor PNP este en corte, El voltaje E-B debe ser menor a 0.6V.
Si el emisor está 9V y la base a 5V, el voltaje E-B es de 0.6V o está saturado. Es decir, el transistor siempre conduce.

Chao.
elaficionado.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.