Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/10/2015 #1


Temporizador con CD4060 funciona a medias
Hola no estoy seguro de que el título o el foro sean los correctos.
En cualquiera de los casos los moderadores podrán corregir mi fallo.
Yo necesito un temporizador de dos tiempos
Un OFF largo, una a dos horas y un ON corto en el orden del minuto.
De los muchos circuitos que hay en internet opté por el adjunto.
Cumple a la perfección con lo que necesito y está muy documentado en el sitio del que lo bajé.
Finalmente logré que funcione perfecto en protoboard.
Decidí entonces pasarlo a plaqueta definitiva, increíblemente salió andando.
Durante el procedimiento de ajuste de los tiempos, en algún momento, coincidiendo
con la conexión de un buzzer activo a la salida del relay, para no estar todo el tiempo mirando que se encienda un led, en fín, no sé cómo dejó de andar. En medio pasaron a mejor vida un BC547 y algún 4060.
No pude encontrar el fallo. Cómo es el fallo?:
Uno, deja de oscilar, (el diodo a la patilla 9 no titila)
Murió el integrado
Dos, oscila pero el led de la patilla 7 titila casi al mismo ritmo que el de la 9
¿?
Después de manosear, revisar, verificar, decidí volver a armarlo en otra plaqueta perforada
para incluso mejorar el armado.
Y realmente quedó mucho mejor... pero no anda. Funciona siempre y cuado no cambie de rango, es decir, sin conectar el "puente" range a alguna patilla según la tabla.
Esto de cambiar de rango eligiendo pines distintos según la tabla, funciona, lo pude comprobar en el protoboard y en la primer plaqueta armada.
Ahora mismo estoy peor, pués decidí cambiar R5 que la tenía con un valor más bajo 2M2, por el valor de 4M7 indicado, y directamente ni oscila. Estoy revisando, me llama la atención que midiendo tensión entre la pata 8 (-VCC) y la 16 (+VCC) tengo -12.
Está claro que mi nivel es el de un aficcionado, por eso me pregunto, entre tantas cosas: dónde se invierte la tensión?
Llevo días "internado" con este tema, cualquier ayuda o sugerencia, será muy bien recibida.
Saludos
27/10/2015 #2

Avatar de chclau

Nunca me gustaron los diseños de temporizadores que usan valores de resistencias o capacitores altisimos.

En todos mis diseños el valor de resistencia mas alto que he usado es de 1M e incluso ese solo en casos excepcionales. Una resistencia muy alta es super sensible a la humedad, suciedad, contaminacion, etc.

Para realizar temporizaciones de horas lo mas simple, economico y confiable es usar un microcontrolador.
28/10/2015 #3


Gracias chclau por tu aporte.
Pensé en un micro, pero aún no estoy listo para eso, justo ahora estoy acopiando elementos para incursionar con Arduino.
No puedo opinar con autoridad sobre el tema de las resistencias y capacitores, pero en este caso no son responsables directos, al menos en el tiempo largo. Sí es cierto que de R3-R4 y C3 depende la frecuencia del oscilador, lo demás es una cuenta.
Con respecto al tiempo corto, sí depende de C2 y R8, pero aquí no tengo problemas, salvo que el ajuste del pote es super crítico, posiblemente se resuelva con un multivueltas.
Bien, anoche trabajé hasta tarde y hoy desde temprano y el aparatejo "funciona", salvo que:
el tiempo más largo, a la frecuencia más baja que obtengo es de 37 minutos en la pata 3 !! que en teoría es la que va de 8 hs a 24.
En los prototipos anteriores, obtenía 1 hora en la pata 15 que es la que corresponde, según los valores y la tabla. El único cambio es que ahora puse R5 de 4M7 (según el circuito) y antes tenía una de unos 2M y algo. Debo analizar C3 y R4 para bajar la frecuencia de oscilación, no sé por qué pues esos valores funcionaron.
Saludos
28/10/2015 #4

Avatar de pandacba

Algo, evidentemente paso en tu primer placa, es muy posible que el CI resultara dañado, y que en la que armaste después cometieras algún pequeño error, típico en la etapa de aprendizaje, y que cuesta ver aunque este delante nuestro.
Para brindarte una mejor ayuda, sería bueno que publicases algunas fotos de tu montaje, tanto del lado de componentes, como de las pistas
28/10/2015 #5


pandacba, todo lo que decís es correcto. Un tanto benévolo eso de "pequeño error". Hasta llegué a poner al revés el CI, encima el zócalo que tengo es para 18 patas lo que contribuye a la confusión.
Adjunto las fotos. La primera es sin flash para que se vean los leds.
Como dije en el anterior mensaje, ahora funciona, pero no logro los tiempos que lograba antes y que eran los esperados.
Saludos






Imágenes Adjuntas
Tipo de Archivo: jpg 01.jpg (129,5 KB (Kilobytes), 93 visitas)
Tipo de Archivo: jpg 02.jpg (132,5 KB (Kilobytes), 84 visitas)
Tipo de Archivo: jpg 03.jpg (137,6 KB (Kilobytes), 82 visitas)
28/10/2015 #6
Moderador general

Avatar de Fogonazo

Lee esto:
¿ Como subir imágenes ?
28/10/2015 #7


Disculpas, creí que lo hacía bien-Gracias


[Edita tus comentarios en lugar de crear nuevos]

Cambié R4 por una de doble valor y mejor calidad, aunque la frecuencia del oscilador bajó considerablemente (a ojo, claro) los tiempos no son los esperados.
Cambié el CI por las dudas, sin resultado alguno.
Ahora voy por el capacitor C3, que en realidad son dos, aunque sea los pondré por afuera en paralelo, a ver que pasa.


[Edita tus comentarios en lugar de crear nuevos]

Ahora sí, le puse en paralelo el par de elctrolíticos que uso en el protoboard y es el que usé en la primer placa, y la oscilación bajó muchísimo. El led de la patilla 9 titila desesperadamente lento - Todavía no sé que tiempo me dará en la pata 13 que es la que estoy chequeando.
31/10/2015 #8

Avatar de Scooter

Ese es el problema de los temporizadores analógicos.
Aunque este es mixto.

Para tiempos cortos es razonable/ asumible ajustarlos.
Para tiempos de horas es inasumible el ajuste: esperar 2h, ver que le falta, esperar 2h ver que le sobra, esperar 2h le falta de nuevo... Puedes estar una semana ajustando. Si no tienes nada mejor que hacer y cobras las horas a 0€ es una opción. Si cobras barato, a mitad de ajuste ya habrás perdido más dinero del que vas a cobrar por el trabajo.
Si cobras caro, mientras lees este post tan largo ya lo has perdido.

Corolario, no recomiendo circuitos de mediados de sXX en el ya bien entrado sXXI. Hasta finales de los 80 ese circuito era bueno, pero ya no lo es, aparte de los matices posteriores de condensadores, de resistencias etc.
Para más de un minuto, temporizador digital puro.
Para más de dos integrados, y un temporizador digital semidecente los lleva, se pone un microcontrolador, osea se pone casi siempre.


Perdón por el panfleto. Es mi opinión sincera.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.