Haz una pregunta
  Foros de Electrónica » Diseño analógico » Diseño de circuitos en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

08/03/2012 #21


yduenas dijo: Ver Mensaje
Colegas por lo que estuve viendo y comprobando por mi mismo, el Cocodrile Clips no es muy exacto para realizar simulaciónes con led, ya que como no especifica que tipo de leds usa este programa, es decir voltaje y amperajes, no se si concuerdan conmigo, en esta afirmación. Saludos
Yo uso el proteus. En él sí puedo especificar el voltaje y amperaje de los led´s. Por contra no he descubierto si puedo editar los transistores. Directamente cojo uno y ya presupongo que lleva las características que veo en el datasheet
08/03/2012 #22


Yo descargue ayer un Proteus Portable de un tamaño de alrededor de 65 mb, hoy lo probaré en la PC de mi casa, pues aquí en el trabajo lo que uso es Linux.
08/03/2012 #23


elaficionado dijo: Ver Mensaje
Hola.

Los LEDs deben alimentarse de los 12V, (todas las resistencia van a 12V) y no del terminal del PIC.

Chao.
elaficionado.

Nota: calcula el valor de las resistencias en función de los 12V.

chclau dijo: Ver Mensaje
No, por supuesto que no, porque el pin no puede proveer la corriente para todos los LEDs, si fuera así, no necesitarías el transistor.
Bueno con 12v funciona a la perfección y calculando sus resistencias salen de 820. De esta manera y SIN transistor, lo más básico, tengo una I de 9,8 , casi los 10 que debería en cada rama. Si conecto el transistor con su Rb calculada, me baja un montón la corriente por cada rama, tanto que tengo que poner resistencias de 560 en vez de 820 para que vuelvan a pasar los 10 mA por cada rama y que iluminen los leds como deben. No sé si será cosa del simulador o realmente es así, porque incluso si quito la Rb me siguen dando los mismos valores...
08/03/2012 #24

Avatar de zaiz

AjarDeNauer dijo: Ver Mensaje
tengo que poner resistencias de 560 en vez de 820 para que vuelvan a pasar los 10 mA por cada rama y que iluminen los leds como deben. No sé si será cosa del simulador o realmente es así, porque incluso si quito la Rb me siguen dando los mismos valores...
Es obvio que si baja el voltaje de alimentación, tienes que bajar las resistencias para que la corriente sea la que necesitas.

Pero necesitas el transistor. como dijo chclau y elaficionado. Hazles caso, si no, tu microcontrolador se va a dañar.
08/03/2012 #25


No se porque tantas dudas. Poné un transistor Tip 29 o Tip 31, ponele en la base 100 ohms y los leds con sus resistencias en el colector como lo dibujaste. Y con las resistencias regulá la corriente que querés según la fuente. No te calentes calculando la ganancia. Ahora bien si pones 100 leds entonces sí tenes que poner algún transistor mas grande.
10/03/2012 #26


Gracias a todos por contestar.

Al final creo que me decantaré por el uln2803 que me da hasta 500 mA.. Simulándolo, para 12v. las resistencias teóricamente me salen 68 ohm, pero las tengo que bajar a 33 para que la corriente total sea 30 (15 por cada rama, que es la de cada led) y me iluminen bien los led´s. Es normal no? por los transistores del uln imagino...

Y luego, es necesario que el común de este integrado esté alimentado? porque por lo que he podido ver por ahí, me ha dado la impresión que sólo se alimenta cuando se quiere poner un zener y protegerlo, si no, no hace falta.



Un saludo.
10/03/2012 #27
Moderador

Avatar de elaficionado

Hola.

No necesitas un transistor de 0.5A.
Usa un transistor BC54X (X=7,8,9) o equivalente.
Una resistencia de 1K en la base.

Chao.
elaficionado.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Diseño de circuitos en general

Alarmas, temporizadores, acondicionadores de señal...

Cerrar
Foros de Electrónica » Diseño analógico » Diseño de circuitos en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.