Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/12/2011 #101


si tamb lo instale pero tampoco me anda... :S
07/12/2011 #102

Avatar de SERGIOD

Te digo entonces que te fijes en las pistas del pcb talbes hay una que no hace un buen contacto ya varias veces a ocurrido eso que por soldadura fria o un microcorte como dicen muchos pase eso
07/12/2011 #103


Pense en eso en un momento y estañe todas las pistas por las dudas pero nada... empiezo a creer que los pics tienen algo contra mi
07/12/2011 #104

Avatar de XandroX

Hace algo mas facil, decimos que problema especifico tenes, porque "no anda" o "no graba" es muy general. Decinos cual es el problema especifico, algun error al intentar cargar (son muy comunes), no te detecta el pic?? te quema los pics?? si es asi, como sabes que te los quema.
Como te dijeron usa el winpic800, q tiene una funcion de reconocer el dispositivo y si mal no recuerdo tambien se puede hacer un testeo de las tenciones en puntos especificos. De nuevo, decinos un poco mas puntualmente cual es tu problema, porq sino vamos a tirar miles de soluciones....

PD: respecto a las librerias, fijate bien si estas compilando bien, si tenes todo en su lugar, fijate algun libro o alguna guia...pero decinos cual es el problema puntual

Saludos
08/12/2011 #105


Te paso a explicar: el archivo .hex lo baje de la pagina picproyect.com ( es el proyecto que tiene leds rgb y cambian los colores automaticamente) por lo que supongo que el archivo anda bien...
Cuando programo con el Ic-prog me tira el error 000h, cuando programo con el WinPic 800 no me detecta el hardware y si programo me tira el mismo error.
Pensé que seria el pic y compre otro pero tengo el mismo error, tambien probe con otra pc y sigue haciendo lo mismo, configure el puerto COM desde panel de control como se debe, probe todos los componentes del programador JDM Plus (uno por uno), y además antes me habia armado el jdm (de la pagina fullcustom) y otros que encontre por la red y con todos tengo el mismo error.
Cuando pruebo tensiones sobre el ICSP encuentro que los 13v sobre VPP y 5v sobre VDD.
08/12/2011 #106

Avatar de XandroX

Bueno, ahi cambia mucho la cosa, ese error 0000h es muy comun, fijate por el foro (aca por ejemplo--->Solución al error de verificación 0000H en el ICPROG) y por miles de lugares mas, hay incontables lugares donde tratan ese error y como solucionarlo
08/12/2011 #107


Gracias a todos por la ayuda, pero me voy a comprar el programador usb... No hay caso con los JDM
14/12/2011 #108

Avatar de christian elric

Una pregunta, el icsp ya lo busqe y no lo encontre y me dijeron los de las tiendas de electronica que no sabian que era,si me pudieran decir con que otro nombre lo puedo buscar o si lo puedo pedir en alguna pagina de internet ya que busque en mercado libre y tampoco lo encontre


Otra cosa, al meter la placa en cloruro ferroso me disuelve el cobre pero no se quedan las pistas marcadas solo queda un poco de tinta que se borra si le pasas el dedo saben aque se pueda deber???
14/12/2011 #109


icsp es el NOMBRE de la pinera, son pines, nada mas....
con el otro asunto: comprate un buen fibron indeleble ( la marca edding es muy buena), y cuando lo dibujes le tenes que pasar dos veces el fibron sobre la pista para marcarlo bien, igual yo te recomiendo que hagas este circuito con el metodo de la placha
16/12/2011 #110

Avatar de christian elric

Gracias manu, ya lo ize con un marcador y lo remarque bien y efectivamente quedo.

En cuanto a lo de los pines al rato lo voy a buscar asi.
18/12/2011 #111

Avatar de BKAR

christian elric dijo: Ver Mensaje
...
En cuanto a lo de los pines al rato lo voy a buscar asi.
esto es lo que buscas?
ICSP
19/12/2011 #112

Avatar de christian elric

muchas gracias BKAR eso es lo que buscaba
14/02/2012 #113


Hola, queria decirles que arregle el programador JDM Plus y ahora parece que programa. El problema era que no le habia hecho el puente entre el diodo y el capacitor, ya que no habia visto los comentarios...
Ah tambien queria pedirle si alguien tiene un programa simple que haga titilar un led para el pic 12f675, si lo tiene en .hex mejor porque no tengo el mplab instalado
17/02/2012 #114


Ya conseguí el programa
11/05/2012 #115


hola hermanitos hice el programador pero ni si quiera me lo detecta el programa winpic800 ....me dice ERROR -> EL hardware no responde

---------- Actualizado después de 3 minutos ----------

me gustaria saber cuales son los voltajes de entrada y salida gracias espero me puedan ayudar
11/05/2012 #116


si no te lo detecta no es tan grave, es decir, el winpic no es capaz de decir que no encuentra el hardware porque el programador no envia una informacion que identifique el programador como lo hace Windows cuando se conecta un dispositivo usb...

me gustaria saber cuales son los voltajes de entrada y salida gracias espero me puedan ayudar


cuendo palomees vpp deben ser 12v aprox

cuando palomees el resto deben ser 5v
Imágenes Adjuntas
Tipo de Archivo: jpg Dibujo.JPG (46,9 KB (Kilobytes), 301 visitas)
11/05/2012 #117


si hermano ya revise la configuracion y esta bien pero en las salidas me dan voltajes negativos -5.6 v
11/05/2012 #118


esta mal armado en las salidas tienen que ser . en VPP aprox 0v o 12v, en Data y clock aprox 0v o 5v....

si son -5v probablemente se queme el pic porque no esta diseñado para aguantar esas tensiones... ver electrical caracterist en la hoja de datos de cualquier pic...

---------- Actualizado después de 10 minutos ----------

aaahhh y la figura no la puse para que vieras la configuracion sino para que veas donde palomees el TEST y midas voltajes en tu programador...
08/06/2012 #119


Buenas tardes a todos, muy agradecido por todos los aportes que tanto nos han servido a todos los usuarios de este magnífico foro.

Les comento, desde hace dos días llevo intentando hacer funcionar mi programador JDM, el cual fabriqué yo mismo basado en un esquemático encontrado en el foro, no recuerdo en que post, lo adjunto a continuación.

Me la he pasado leyendo y probando la gran mayoría de soluciones pero nada!, intento programar un PIC16F84A, ya probé con el IC-PRog (última versión) el cual me arroja el error de "error de verificación en 0000h", probé con el winpic y me dice "ERROR: Programming FAILED !":enfadado: luego de mostrar un montón de líneas como esta: "Verify Error: 000000: read 003FFF, wanted 003000", probé con el PICPgm Programmer pero no me detecta el PIC, y lo selecciono y todo de la lista desplegable, y lo borra y lo chequea si esta en blanco, pero al programar sale "verify errors ocurred!", luego monté este programador:

http://www.google.com/url?sa=t&rct=j...kx685g&cad=rja

Probé denuevo con el PICPgm Programmer y ya lo detecta solo, pero persiste el problema de "verify errors ocurred!".

Luego usé el WinPIC800 y lo mismo!, error de verificación.

LO CURIOSO ES: Cuando leo el pIC y guardo el .hex generado por el PICPgm y luego lo programo, lo hace sin problemas (bueno, la mayoría de veces), es decir, leo el contenido del pic y el programa lo guarda en un archivo con extensión .hex, luego le doy abrir archivo, abro ese .hex y le doy programar y listo!, todo verde!, lo programa sin problemas en todos los programas. OTRO DATO CURIOSO: Usando el PICPgm desconecté el JDM, y luego le di blank check y lo peor es que sale "device is blank!" cómo es posible con el hardware desconectado!. Luego le dí en Verify y salió "verify successfull!" jajajaja entonces me dije, pero que @*/-+* ´+``+. Lo único que he visto es que el pin MCLR al programar no supera los 4.7 voltios, y según lo que he leído, debe llegar a casi 12V. Luego monté el programador de Helder Guerra, el sencillo, pero tampoco, sale lo mísmo.

Ya cambíe la configuración del COM1 a 2400 baudios, bit de datos=8, paridad=ninguno,
bits de parada=1, control de flujo xon/xoff.

Adjunto los archivos en EAGLE, brd, sch y dos PDF con el PCB y el Silk screen.
También adjunto el plano del circuito que tengo ensamblado. Además de unas imágenes renderizadas del proyecto tal y como lo tengo ensamblado.
También el plano de Helder Guerra

De antemano muchas gracias por cualquier sugerencia.

La cosa es que además necesito programar el PIC18F2550 para armar mi PicKit2 Clone.

PD. Visité las siguientes páginas donde encontré muy buena info:

https://sites.google.com/site/electr...los-1/jdm_plus
http://r-luis.xbot.es/pic1/pic02.html
http://picmania.garcia-cuervo.net/picc.php
http://perso.wanadoo.es/pictob/jdmd.htm
Imágenes Adjuntas
Tipo de Archivo: png JDM_esquema.png (38,7 KB (Kilobytes), 52 visitas)
Tipo de Archivo: jpg programador pic18f2550.jpg (29,8 KB (Kilobytes), 37 visitas)
10/06/2012 #120


Resuelto!
Bueno, después de muchos intentos y revisadas a mi PCB, al cable serial y al puerto del PC, AL FIN! pude hacer andar mi progamador JDM, cuyo plano se adjuntó en los primeros post y que yo también subí. El problema era un diodo (condenado diodo!!!) que no era 1N4148 si no uno de 5.1V No me di cuenta cuando lo soldé por que no vi la referencia del afán. Ya logré programar un generador de pulsos de 0.5 y 1 Hz con ayuda del CCS Compiler, Muchas gracias a todos.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.