Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

10/12/2013 #141

Avatar de locodelafonola

hola ... gusfavio...bueno veo que te la pasas en moderacion...pero hasta... el amigo D@rkbytes... de da una mano...bueno tecuento que yo.de esto..no sse nada..pero absolutamente nada....recien empiezo...yyyy a ver elegi este programador porque es el cual consegui mas informacion dentro y fuera del foro......esta es mi cuarta placa diseñada y costruida por mi...y me refiero al soft.... lo que tendrias es que pensar ..... no aportas datos en tus consultas y NO USAS EL BUSCADOR....pues por mas que te respondamos..asi no vas aprender nunca..y te lo dice quien no sabe nada ....aca subo los pdf listos para imprimir escala 1:! ..pero te puede pasar que la impresora este mal configurada.... la medida de la placa es 10 cmts X 4 CMTS (en realidad 3.95 ) hoy grabe mi primer pic ...fue el 18f2550..usando wimpic800....y no me salio a la primera...pero bueno.....si me preguntan por que...... no sabria decirles..... a nadie... de tanto cambiar configuraciones al azar parece que di por casualidaden la que funciono..ademas me aparece el icono cuando graba en la barra de tareas...... yo no invente nada.....lo que hice... fue rediceñar la placa....las pistas eran muy finas..... las mias son mas gruesas....y lo saque de aca Aporte: Programador JDM Plus... GRACIAS arias887 por tu aporte me fue muy util... tambien me gustaria que alguno que sepa.por favor..explique el funcionamiento del winpic800..porque tengo la ultima vercion y los tutos o imagenes que consegui en el foro difieren unas de otras en la interfas grafica..(deben ser verciones anteriores )..y tambien del IC prog..(susede lo mismo..... gracias
10/12/2013 #142

Avatar de Gustavo.gmb

me detecta el hardware segun lo que parece, en winpic800, le di la opcion de detectar dispositivo y lo detecta, pero me sale desconocido O.o a alguien le ha pasado? tengo windows 7 64 bits

incluso brilla el led al apretar esa opcion :S
10/12/2013 #143

Avatar de locodelafonola

a ver amigo gusfavio .... de que estas hablando.... que dispositivo... no te detecta .... que compu usas... ????????
10/12/2013 #144

Avatar de Gustavo.gmb

pues en este momento tengo un 18f2550 conectado al jdm, y bueno lo conecto al puerto serie de mi compu, que al parecer es el com1, entro al win800pic y entro a configuracion>hardware y selecciono el JDM , me salgo de ahi y le doy en un botoncito que dice "Detectar Dispositivo" y el programador hace que brille por unos segundos el led, si le doy en com3 no pasa nada, asi que asi descubri que era el com1 el puerto serial, pero me sale DESCONOCIDO, estoy usando una de escritorio por supuesto
10/12/2013 #145

Avatar de locodelafonola

vamos por partes... antes que nada te vas al icono de "mi pc" en el escritorio..."click" boton izquierdo del raton y tevas a DEVICE MANAGER.... te fijas en la lista de dipositivos si aparece WIMPIC800 como aca bueno eso por primero y lo segundo es que tenes que apagar y encender la maquina con la interfaz colocada. hasta ali verifica eso que te digo y seguimos
Imágenes Adjuntas
Tipo de Archivo: png capture_12102013_163101.png (92,6 KB (Kilobytes), 114 visitas)
10/12/2013 #146

Avatar de Gustavo.gmb

listo, he hecho lo que dices y si me sale tal cual lo muestras
10/12/2013 #147

Avatar de locodelafonola

bueno ahora vamos a configurar el winpic800 para que te detecte el pic..coloque en la mia un pic18f2550 igual que vos y vamos aver que hace... buen apenas lo abri me detecto el pic como veras per te explico como se hace clickeas el boton asi y luego el que esta debajo fijate eso por ahora
Imágenes Adjuntas
Tipo de Archivo: png capture_12102013_165047.png (79,9 KB (Kilobytes), 114 visitas)
10/12/2013 #148

Avatar de Gustavo.gmb

bueno no se si me lo detecto jaja pero la primera vez que lo probe yo seleccione el pic de la lista, ahora no se si se quedara configurado asi o no, por que volvi a prender la compu y entre a winpic800 y ya estaba seleccionado el pic 18f2550 , supongo que lo habra detectado

pd: por cierto no se pueden ver dos imagenes que subiste
10/12/2013 #149

Avatar de locodelafonola

apurado¡¡¡¡¡ las estaba subiendo ¡¡¡¡¡¡.... bueno ahora te muestro como configurar la opciones..teneme paciencia capturo mis pantallas y las voy subiendo... paciencia...!!!!!!! no saques ni pongas la interfaz con la compu andando siempre apagada y verifica quel led este completamente apagado porque indica que los capacitores tienen carga y podes quemar el pic ¡¡¡¡¡¡ vamoa configurar el hadware clickeas aqui y luego buscas el jdm en la lista (flecha roja)..... luego lo guardas en la configuracion establecida (flecha azul ).... y luego le das aceptar el cambio ( flecha amarilla )..eso siempre que tengas seleccionado puerto com 1 (circulo rojo ) bueno fijate sitenes todo igual a esto
Imágenes Adjuntas
Tipo de Archivo: png capture_12102013_171047.png (54,5 KB (Kilobytes), 111 visitas)
Tipo de Archivo: png capture_12102013_171129.png (35,0 KB (Kilobytes), 111 visitas)
10/12/2013 #150

Avatar de Gustavo.gmb

jajaja ok espero

PD:listo tengo todo igual
10/12/2013 #151

Avatar de locodelafonola

bueno ahora vamos aconfigurar el soft clickas aqui y luego te fijas en todas estas opciones ponelas igual y en cada una de ellas.. le das confirmar cambios bueno hasta aqui fijate como lo tienes en tu compu
Imágenes Adjuntas
Tipo de Archivo: png capture_12102013_171108.png (54,4 KB (Kilobytes), 112 visitas)
Tipo de Archivo: png capture_12102013_172637.png (20,6 KB (Kilobytes), 112 visitas)
Tipo de Archivo: png capture_12102013_172657.png (19,6 KB (Kilobytes), 112 visitas)
Tipo de Archivo: png capture_12102013_172713.png (18,5 KB (Kilobytes), 113 visitas)
Tipo de Archivo: png capture_12102013_172730.png (18,5 KB (Kilobytes), 113 visitas)
Tipo de Archivo: png capture_12102013_172745.png (17,1 KB (Kilobytes), 111 visitas)
Tipo de Archivo: png capture_12102013_172801.png (20,2 KB (Kilobytes), 111 visitas)
Tipo de Archivo: png capture_12102013_172829.png (18,5 KB (Kilobytes), 111 visitas)
Tipo de Archivo: png capture_12102013_172931.png (21,7 KB (Kilobytes), 196 visitas)
10/12/2013 #152

Avatar de Gustavo.gmb

listo, hasta ahi he hecho todas esas opciones, excepto el que dice "asociar los acrchivos Hex con WinPic800" por que me sale error, ahora cierro el winpic800 y lo vuelvo a abrir y me empieza a verificar que dispositivo estoy usando y me sale esto

Abriendo COM1
Detectado -> DESCONOCIDO

pero incluso el led empieza a parpadear por un momento al empezar la verificacion
10/12/2013 #153

Avatar de locodelafonola

bueno ahora vas hacer asi.... con la interfaz colocada .... te vas a archivos de programa..y buacas la carpeta wimpic..y buscas el desintalador...lo desintalas por completo al programa...pero siempre con la JDM colocada..... reinicias la maquina y volves a instalar el programa con la JDM siempre colocada...y te fijas cuando aparece el icono de usb y el port mientras se instala... tiene que tildarce solo los dos..reinicias y se acabo el problema...comenta que hace despues y vemos
10/12/2013 #154

Avatar de Gustavo.gmb

no se tildan :S, vos decis cuando se empiezan a instalar los driver no es cierto?? si es asi el port y el usb aparecen destildados :S

PD: a no no no no, espera ya se tildaron,al poner continuar jeje

PD: pero el problema persiste u.u , me sigue saliendo DESCONOCIDO
10/12/2013 #155

Avatar de locodelafonola

siiiiii asi se cargan..al poner continuar...una vez que se instalo le das reiniciar ala compu... y con eso creo que se soluciona el problema
10/12/2013 #156

Avatar de Gustavo.gmb

hice todos los pasos, y me seigue saliendo desconocido :/,he tratado de grabar el programa haber que pasa y me sale este error


ERROR de escritura en direccion 0x000000

Escrito 0xEF85 leido 0xFFFF
10/12/2013 #157

Avatar de locodelafonola

trata de capturar una pantalla.... para ver cual es la parte que te sale mal ....asi te ayudo.....volve a desintalar y instalar de nuevo pero deja todo como te lo pone el programa por default....creo que tengo idea de donde puede estar el error pero no lo puedo duplicar en mi maquina esto es parecido pero fijate las direcciones no son iguales o mejor subime .hex y vemos si lo puedo grabar y vemo si me hace lo mismo
Imágenes Adjuntas
Tipo de Archivo: png capture_12102013_183249.png (7,3 KB (Kilobytes), 110 visitas)
10/12/2013 #158

Avatar de Gustavo.gmb





cargo el HEX y pongo programar y sale esto



Imágenes Adjuntas
Tipo de Archivo: png Captura.PNG (111,7 KB (Kilobytes), 111 visitas)
Tipo de Archivo: png Captura2.PNG (58,3 KB (Kilobytes), 112 visitas)
Tipo de Archivo: png Captura3.PNG (97,4 KB (Kilobytes), 112 visitas)
Tipo de Archivo: png Captura4.PNG (114,6 KB (Kilobytes), 111 visitas)
10/12/2013 #159

Avatar de locodelafonola

bueno proba sacando el tilde a la casilla donde esta el circulo rojo i fijate que la direccion sea 0x00 donde esta el circulo verde
Imágenes Adjuntas
Tipo de Archivo: png capture_12102013_184309.png (53,4 KB (Kilobytes), 112 visitas)
10/12/2013 #160

Avatar de Gustavo.gmb

sip esta en esa direccion, tal y como lo muestras, ya lo tenia ahi, pero de todos modos lo puse, pero igual siguesin detectar
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.