Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

15/11/2010 #1


Asesoria en uso de interrupcion por registro INTCON
Hola amigos de FELEC escribo por el siguiente inconveniente sucede que tengo una rutina que consiste en un contador de 0-255 cuya cuenta se debe ver por un LCD DE 2X16 la que muestro mientras se efectua la cuenta en la primera fila despues por medio de un pulsador debo parar esta cuenta y a su vez mostrar un mensaje que diga (esta es una int ) en la primera fila y en la segunda fila (la cuenta es:xxx) con el valor que capturo .La hice y me funciona por proteus pero no utilice el registro INTCON si no que testeando el valor de entrada RA0 pero al momento de probarlo en mi Projet Board solo puedo ver la cuenta pero al momento de presionar el pulsador no me sale el mensaje de interrupcion y la cuenta me vuelve a 0.Entonces pense hacerlo con el registro INTCON pero tengo dudas de como utilizarlo.Les cuento puse en 1 el Bit GIE ademas el RBIE Y EN 0 EL RBIF.Ahora por lo que e leido al generarse una interrupcion por automatico el programa salta a la direccion 0x04 en donde puse ir a isr en donde pregunta si es 0 con btfsc el intcon rbif por lo que no es y me salta a INTERRUP al llegar aqui pone en 0 con BCF el INTCON,RBIF y despues sigue con la muestra del mensaje de interrupcion gracias al btfsc que pregunta si el INTCON,RBIF es 0 y como lo es queda dando bueltas en ese mensaje para luego si yo presiono nuevamente el pulsador este me salga de esta rutina y vuelba a contar pero antes de ir a contar hice una rutina de borrar el LCD en la cual = tengo dudas y luego desde aqui se va a CUENTA para luego irse incrementando desde donde quedopero al ir a ese punto cuando llego a conta despues de borrar el diplay segun yo pone nuevamnete el RBIF EN 0 y luego va a DEM1 endonde comiensa la cuenta normal pero he leido de que debe existir un RETFIE para volver a la direccion 00x4 a lomejor estoy equivocado pero por el momento lohe entendido asi entonces desde aqui deberia ira a DEM1 pero al principio al poner en servicio mi rutina esta salta a INICIO setear los demas parametros entonces si vuelvo con el RETFIE como lo hago para ir a DEM1 y no a INICIO nuevamente. AHORA NO SE SI EN LA PRIMERA INTERRUPCION DEBIA UTILIZAR EL retfie ESTOY CONFUNDIDO.por eso coloque en CUENTA despues de dejar el RBIF en 0 ir con goto a DEM1 PERO PARECE QUE HAY ESTOY FALLANDO.adjunto rutina para el que me puede ayudar.Gracias.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.