Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

28/01/2016 #1


Atmega8A solo funciona cuando lo reseteo
Buenas noches, como están?

Les comento que he estado trabajando en dos PCB que son muy similares. Tienen un micro y un modulo de radiofrecuencia para transmitir inalambricamente.

Ahora, el problema que tengo es que una vez hago la programación del micro, este funciona bien. Pero si apago y prendo el sistema, deja de funcionar y solo vuelve a hacerlo cuando pongo el pin de reset del programador sobre el pin de reset del micro. Luego de esto, puedo retirar la conexión mencionada y sigue todo funcionando... hasta que lo vuelvo a apagar.

Saben a que se debe esto y que podría hacer para darle solución a este problema? He pensado en colocar una resistencia de 1k entre reset y tierra... no se si funcionaría y no lo he hecho, por miedo a hacer un daño peor.

Si alguien sabe la respuesta, estaría muy agradecido.

Hasta pronto ...
28/01/2016 #2

Avatar de Daniel Meza

¿Cómo has configurado los bits "fuses"?, hay uno en especial llamado POR, BODEN que se encarga de mantener en RESET al micro antes de iniciar el programa. Cada que se apaga y enciende el sistema, esta señal se activa para colocar al micro en un punto conocido.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.