Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

15/01/2009 #1


Comportamiento extraño del pic 18F452
Hola a todos, a ver si me pueden explicar algo extraño que sucede en mi placa con el PIC 18F452.

He hecho una placa para sacar todos los puertos del pic a unas clemas y de esta forma tener accesible dichos puertos, el pic funciona con un cristal de 20MHz y tiene un max232 para comunicaciones con el puerto serie del PC y ademas cargar los programas por medio del bootloader. Tambien tiene un zocalo para incluir una eeprom que no esta insertada. Toda la placa esta alimentada a una tension de 5v por medio del 7805.

Bueno pues hasta aquí todo normal, la aplicación consiste en leer el ADC y implementar un frecuencimetro. este frecuencimetro lee los pulsos por la interrupción externa INT0 y el funcionamiento consiste en leer el tiempo entre pulso y pulso y sacar la frecuencia. los pulsos se obtiene de un integrado 74XX para medir la velocidad ee un motor DC; donde los valores de tension de los pulsos estan entre 0 y 5v.

He realizado la prueba colocando directamente la salida del 74xx a la INT0 y colocandole una resistenacia de 10K a masa entre la INT0 y el 74xx. Sucediendo siempre un comportamiento extraño ya que mientras esta el pic funcionando yo recibo los datos en el Hiperterminal del PC pero si apago el pic quiero decir si corto la alimentación del PIC, y por un casual en el INT0 se le sigue aplicando 5v del 74xx, el PIC no se apaga y sigue funcionando transmitiendo. (vamos que cojo el polimetro y mido la tensión y parece como si del 74 estuviese proporcionando la tension para que funcione el pic).


Alguien sabe como se puede solucionar esto, ¿este comporatamiento es normal?

un saludo y muchas gracias.

PD: PErdonar por este tocho que he soltado jejeje
15/01/2009 #2


Interesenta cosa te sucede...

Tendras el diagrama electrico de tu circuito?, postealo y vemos que puede estar pasando, tendras fotos detalladas? igual y tienes un puente electrico por ahi que no has detectado.

Si todo esta bien implementado tenemos un pic que no necesita energia para trabajar = ) ! disculpa el mal chiste,,,,manda información.

saludos !
16/01/2009 #3


primero que todo gracias por el interes jejeje, (chiste inteligente jejeje)


Bueno tengo los esquemas electricos que los pondré esta tarde; respecto a puentes electricos es posible pero creo que es dificil por que como comente, la placa lo unico que tiene son clemas que van directo a los puertos del pic y no tienen puentes.

la verdad que es extraño, pero bueno a ver si se puede encontrar el problema.

un saludo
16/01/2009 #4

Avatar de Ferny

No te extrañe demasiado, a mi hace unos años me pasaba lo mismo con el 18F442 que es como el tuyo... Prueba intercalando la resistencia de 10K en serie entre la salida del 74XX y la entrada del PIC
17/01/2009 #5


bueno como dije ayer este es el esquema que estoy utilizando. por si sirve de algo.

Ferny pues no me extrañaré jejeje, de todos modos he intercalado una resistenacia de 1K y de 10K y sigue pasando lo mismo. Con la alimentación aplicada el comportamiento es normal, pero me llamo mucho la atención que si le aplicaba tensión por la INT0 arrancase el PIC estando la alimentación principal desconectada .

Bueno, gracias por responder.
Imágenes Adjuntas
Tipo de Archivo: jpg dibujo_828.jpg (60,6 KB (Kilobytes), 41 visitas)
25/01/2009 #6


Hola

Tengo una teoria que podria explicar este comportamiento y tiene que ver con el hecho que el diseño electrico de los pines de los PIC, se supone que usan diodos de enganche (diode clamp) para limitar el voltaje que puedes inyectar como entrada, sabemos que es posible conectar un pin de entrada a 120 volts directamente (limitando la corriente claro) y el PIC no sufre daños debido a esa proteccion, es posible que por ahi este una ruta a VDD por su configuracion electrica interna.

Que opinan?
25/01/2009 #7


Por que no?
Pues no esta mal la idea, comento mis medidas.

Digo que podría ser por que cuando meto la señal TTL (5v) en la INT0 y mido con el polimetro en el PIN VDD y tiene tensión de 5v y por esa razon empieza a funcionar el PIC.

un saludo.
25/01/2009 #8

Avatar de Eduardo

Efectivamente es por los diodos de proteccion.
Hay incluso una nota de aplicacion de Microchip de una tarjeta RFID, donde la alimentacion del microcontrolador se saca rectificando (con estos diodos) la señal de la bobina de entrada.
25/01/2009 #9


Hola Eduardo

Tendras la clave de la nota de aplicacion en donde leisto eso? No esta por demas aprovechar para enterarme bien del asunto.

Gracias de antemano.
26/01/2009 #10


Hola de nuevo, pues opino igual que Tratante, si tienes la referncia perfecto a ver si yo tambien me entero jijiji.

Muchas gracias por las respuestas y aclarame ese expediente X 8-) .
26/01/2009 #11

Avatar de Eduardo

La trampa es que la nota de aplicacion no esta en la pagina de Microchip ni es de las notas oficiales. Son trabajos presentados al concurso "De$igning for Dollar$" de Microchip.
Tuve que Googlear un poco porque ni me acordaba donde la habia visto, solamente que era con el 12C508. Esta aca:
http://www.nalanda.nitc.ac.in/indust...nsor/index.htm
Es el primer link: http://www.nalanda.nitc.ac.in/indust...nsor/3_001.pdf

En la figura 2 (del pdf) se ve el principio. Los diodos de proteccion de las entradas terminan formando un puente de diodos con salida a Vdd y Vss.

Para devolver el codigo, lo que hace es ir programando GP2 como entrada o salida.
Cuando esta programada como entrada la carga es minima y cuando esta como salida le cortocircuita un semiciclo y la carga es maxima --> De acuerdo a las variaciones de carga que ve el circuito de excitacion se lee el codigo.
27/01/2009 #12


Gracias Eduardo
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.