Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

24/04/2012 #1


comunicacion pic16f887 y usb-uart
Hola estoy haciendo como proyecto un sistema de control de luces de corriente alterna mediante la pc y para eso estoy ocupando un pic16f887 y un modulo usb2.0-uart como el siguiente http://articulo.mercadolibre.com.mx/MLM-80451135-comunicación-usb-20-a-uart-rs232-arduino-pic-atmel-atmega-_JM ahora la programación del pic esta perfecta no tiene errores ni advertencias, y la simulación en proteus corre a la perfección el problema es que cuando lo monto en físico no manda ni recibe datos de la hiperterminal probe el modulo conectando su tx y rx entre si y si manda y recibe datos, entonces el problema creo yo radica en el pic o el circuito como lo estoy ensamblando:

pin13 y 14 ocilador externo de 8mz con 2 capacitores ceramicos de 15pf
pin 11 y 32 corriente
pin 12 y 31 GND
pin 34 (RB1) a un led con su respectiva resistencia
pin 26 (RX) al TX del modulo
pin 25 (TX) al RX del modulo

cabe mencionar tambien que la comunicacion esta a 9600budios, el data bits es de 8, parity: ninguna, stop bits:1 y el hadshaking: none asi esta configurada tanto en el pic como en la hyperterminal.

quisiera ver si alguien me podria echar la mano para ver porque cuando monto el circuito no pasa nada, dejo adjunto un rar con el diseño en proteus y tanto el .c y .hex para que los puedan corroborar de antemano grasias

PD: los leds que prenden al iniciar la simulacion(RB2,RB3,RB4,RB5) los puse para chekar si el pic no estaba dañado y no lo estaba.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.