Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

24/04/2014 #1


Hola a todos soy muy nuevo en esto de los pics y por eso encuentro muy bueno el foro.
Mi problema consiste en la conexion del sensor sht75 al pic 18f442. Lo he probado en Proteus pero cuando leo los valores del sensor me devuelve valores erroneos. No se si es por la libreria del sensor que me esta causando problemas o la forma de conexion del sensro con el pic. Si me pudiesen ayudar se los agradeceria.


Subo unos archivos para que vean como tengo conectado el circuito y el codigo que estoy utilizando


Saludos ...
24/04/2014 #2
Moderador general

Avatar de DOSMETROS

Probá con la librería del sht11 , que es compatible
24/04/2014 #3
Moderador

Avatar de D@rkbytes

elnovato13 dijo: Ver Mensaje
Mi problema consiste en la conexión del sensor sht75 al pic 18f442. Lo he probado en Proteus pero cuando leo los valores del sensor me devuelve valores erróneos.
Debe ser porque en la librería están definidos los pines para SCK y DATA

Librería:
#define sht_data_pin PIN_c1
#define sht_clk_pin PIN_C0

Y tú estás declarando otros pines dentro del programa principal que no reconoce la librería.
#define sck pin_c3
#define data pin_c4


Prueba con el programa que adjunto y verás que si funciona.

Suerte.
Archivos Adjuntos
Tipo de Archivo: rar prueba_sensor II.rar (28,2 KB (Kilobytes), 10 visitas)
24/04/2014 #4


Muchas gracias a los dos! Ahora voy a probar como me dijiste!

Saludos
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.