Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

21/04/2012 #1


Se congela la programacion
tengo una programacion que trabaja una secuencia de semaforo y una lcd lo tengo montado en la protoboar y lo pongo a funcionar y funciona la secuencia asta una parte donde entra a trabajar la lcd, ( en la protoboard no la tengo montada todavia ) en ese momento queda congelada la secuencia ( en el simulador proteus funciona bn)

sera problema de corriente, o nececita estar conectada la lcd
21/04/2012 #2

Avatar de Ajna

Pon el diagrama del circuito, para ver, puede ser que si usas la lectura de la LCD para saber si ya se desocupo y no la conectas entonces el microcontrolador se quede esperando a que se desocupe cosa que no va pasas porque no esta conectada "eso para si usas la patita RW"
21/04/2012 #3
Moderador

Avatar de Chico3001

Casi estoy seguro que tienes un bug en la secuencia del LCD o esta desconectada una señal de control, necesitamos ambas partes... codigo y diagrama...
21/04/2012 #4


aca esta el esquema en isi y la programacion
Archivos Adjuntos
Tipo de Archivo: rar pic proyecto cemaforo.rar (22,5 KB (Kilobytes), 12 visitas)
Tipo de Archivo: rar isi.rar (70,9 KB (Kilobytes), 6 visitas)
25/04/2012 #5


Ya pude solucionar el problema era la protoboard
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.