Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/05/2011 #1

Avatar de ivan_mzr

DMX de Microchip, ¿funciona?
¿Alguien a echo funcionar el codigo de receptor que viene en el documento AN1076 de microchip?, e intentado echarlo andar y no lo e logrado, pero un problema es que no uso el pic que viene ahi (18F24j10) trate de adaptar el codigo a un 18F2550 pero no me funciona, lo raro aqui es que funciono un par de veces y despues nada. Busque haber si alguien tenia alguna aplicacion del codigo pero solo encontre quejas acusando que el codigo era incorrecto o que no funcionaba bien(foros de microchip). Encuentro proyectos en C pero solo se usar el ASM.
Hay otra cosa que no entiendo: el codigo original utiliza un oscilador de 16Mhz con el PLL activado pero donde carga el BRGH menciona que trabaja a 16Mhz... como puede ser esto?

  • El PWM si funciona ( lo cheque en una rutina)
  • Corre a 16Mhz (oscilador)
  • Creo que tengo todos los Fuses bien.
  • Mi señal de DMX es correcta
A lo que veo es que nunca sale del -Waitbrake- uso LED como banderas para ver esto.

Código:
MainLoop
                  ; first loop, synchronizing with the transmitter
WaitBreak
   btfsc   PIR1,RCIF      ; if a byte is received correctly
   movf   RCREG,W      ; discard it
   btfss   RCSTA,FERR  ; else 
   bra     WaitBreak     ; continue waiting until a frame error is detected
    movf  RCREG,W      ; read the Receive buffer to clear the error condition
                               ; second loop, waiting for the START code
WaitForStart
    btfss   PIR1,RCIF     ; wait until a byte is correctly received
    bra      WaitForStart
    btfsc   RCSTA,FERR
    bra      WaitForStart
    movf    RCREG,W
Estos son los fusibles que uso:
Código:
CCP2MX = OFF
WDT = OFF
FOSC = EC_EC
STVREN = ON
XINST = OFF
CP0 = OFF
FCMEN= OFF
IESO = OFF
WDTPS = OFF
PWRT = OFF
BOR = ON
VREGEN = OFF
BORV = 3
PBADEN = OFF
MCLRE = OFF
LVP = OFF
AN1076:
http://www.microchip.com/stellent/id...pnote=en527825
01/06/2011 #2

Avatar de ivan_mzr

El problema era un error de OVERRUN, en la pagina 235 del datasheet da intrucciones para solucionarlo.
10/07/2012 #3


An1076a
Hola estoy interesado en realizar el proyecto de AN1076A de microchip
para controlar un robot movil...

como que he visto en el foro, que ya te has enfrentado al problema.
Quisiera hacerte unas preguntas

dices que el fabricante da como consideración el uso del
PIC18f24J10
PERO QUE TU USASTE OTRO TUVISTE UN PROBLEMA DE OVERRUN Y LO SOLUCIONANSTE.
ESE PROBELAMA DE OVERRUN HACE REFERENCIA AL CHIP QUE TU USASTE O AL PIC18F24J10

SERIA POSIBLE USAR EL PIC16F876A?
O EL PIC16F876?

AGRADECERIA MUCHO CUALQUIER OTRA INFORMACIÓN QUE PUEDAS PASARME COMO CUALQUIER CONSEJO....

MUCHAS GRACIAS DE ANTEMANO

ATENTAMENTE NACHO DE VALENCIA (ESPAÑA)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.