Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/04/2010 #1


El Driver para pic18F4550 no funciona bien ?
Buenas a todos, hace una semana estoy queriendo simular el 18F4550 en el proteus 7.5 SP3, y en mi primera prueba con el encendido y apagado de un led mediante un programa en java... no me ha funcado.

He instalado el driver usb correctamente, y al conectar el 18F4550 al USB... mi pc no reconoce el hadware ( pic )... por lo cual he optado instalar los drivers manualmente... como tengo el windows 7 de 32b, hice un ejectuar/hdwwiz, e instale el driver E:\MCHPUSB Driver\Driver Microchip\mchpusb.inf; pero ocurre un error... dice que se instalo mal, y que no se puede iniciar; he intentado con muchos drivers ke he encontrado firmadas y no firmadas digitalmente... pero ninguna me ha funcado, sale el mismo error.
Lo he probado en una pc con windows xp sp3, en un windows 7 de 64 y el de 32, y en todas el mismo resultado.
Espero porfavor una ayudadita para poder continuar trabajando con este pic.
Gracias.

27/04/2010 #2

Avatar de Eclip-se

Respuesta: El Driver para pic18F4550 no funciona bien ?
Ese problema se puede presentar por algunos de estos casos:
  • El archivo .hex se encuentra mal grabado.
  • Estas usando un cristal diferente al valor requerido.
  • Alguno de los cables del puerto USB están mal conectados.
Si automáticamente no te sale la ventanita que te indica para instalar el drive, quiere decir que el problema principal esta en el PIC y no en la PC.
29/04/2010 #3


Respuesta: El Driver para pic18F4550 no funciona bien ?
Bueno al parecer... ia se soluciono el problema... lo que hice fue updatear el proteus al 7.6 ... y luego no instalar aparte el driver del pic... sino esperar a que tu pc te reconozca el pic cuando lo simulas con el proteus, y con el proteus 7.6 ya me empezo a reconocer el pic; cambie unos fuses que tambien estaban mal escritos y listo..

Gracias.
24/07/2010 #4


Respuesta: El Driver para pic18F4550 no funciona bien ?
la verdad es que ese driver si funciona solo que lo descargan desactualizado ,aca les doy un link donde viene todo un paquete de drivers de microchip y aplicaciones, trabaja de maravilla en windows 7, pero no esta el dll, y se instala muy facilmente:
http://ww1.microchip.com/downloads/e..._Installer.zip
29/08/2010 #5

Avatar de albermillan69

Respuesta: El Driver para pic18F4550 no funciona bien ?
pedroivan dijo: Ver Mensaje
la verdad es que ese driver si funciona solo que lo descargan desactualizado ,aca les doy un link donde viene todo un paquete de drivers de microchip y aplicaciones, trabaja de maravilla en windows 7, pero no esta el dll, y se instala muy facilmente:
http://ww1.microchip.com/downloads/e..._Installer.zip

Cual de todos el el driver??? si puedes postealo solo!!! el del w7!!! la verdad no doy con el!!!
16/11/2010 #6


si es que han programado con los compiladores de microchip, sabran que en todas ese paquete hay herramientas utiles para el mplab ya sea c18,c30,herramientas seriales, etc y el driver debe estar en "USB TOOLS"

el driver debe instalarse solo, al insertar el dispositivo debemos ubicar el driver y listo..., hay paginas donde te enseñan a hacerlo.

en cuanto a eso de proteus debemos ver bien como hemos configurado El VID en el pic, es mas facil hacerlo con CCS. vean la programacion del microcontrolador
17/11/2010 #7


A mi me suscedio un problema parecido. EL problema estaba en la configuracion de la frecuencia,
Como tenia un cristal de 16MHZ tube que cambiar el divisor para el pll entre 4, por que solo tenia el hex y no el codigo.
01/01/2011 #8


tengo problemas con el micro q no reconoce la PC
El problema principal es que no se que esta mal, cambie la configuracion VIP PID es importante. pero lo que no logro descubrir es con que cristal trabaja al menos yo le puse 12Mhz, No se si me puedes ayudar con esto.... estoy trabajando con un pic 18f4550
Les agradezco de antemano
01/01/2011 #9


te lo dire de una forma sencilla, en la programacion en la parte de la configuracion del pic como :

#fuses HSPLL,MCLR,NOWDT,NOPROTECT,NOLVP,NODEBUG,USBDIV,PL L5,CPUDIV1,VREGEN

La configuracion del oscilador nos indica que se debe obtener una entrada de 4Mhz independientemente de cualquier crystal que se este utilizando.

PLL3 si es que es un crystal de 12MHZ o PLL5 si es que es un crystal de 20 MHZ en esta pagina te lo explican un poco mejor.

http://uelectronika.blogspot.com/201...y-labview.html
10/03/2012 #10


amigo si has programado bien, tanto el VID Y EL PID y sabes que es el correcto, hay 2 opciones que te puedo dar.

1.-seguramente esta utilizando windows 7 o vista , de ser asi el driver actualizado lo encuentras en:

http://www.microchip.com/stellent/id...cName=en547784

buscas en usb tools, revisas que el driver coincida con tu programacion y no deberia darte ningun problema el reconocimiento.

2. no colocaste el capacitor necesario en la patilla RC3/VUSB.
11/03/2012 #11

Avatar de Basalto

pedroivan dijo: Ver Mensaje
amigo si has programado bien, tanto el VID Y EL PID y sabes que es el correcto, hay 2 opciones que te puedo dar.

1.-seguramente esta utilizando windows 7 o vista , de ser asi el driver actualizado lo encuentras en:

http://www.microchip.com/stellent/id...cName=en547784

buscas en usb tools, revisas que el driver coincida con tu programacion y no deberia darte ningun problema el reconocimiento.

2. no colocaste el capacitor necesario en la patilla RC3/VUSB.
Por voto por que falláis en la opción 2. El condensador puede ser de 1uF electrolítico. Un saludo
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.