Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?
12/12/2012 #41


drkblog dijo: Ver Mensaje
Yo te diría que compres un 12F629 para probar y saber si el programador está funcionando bien. Es muy barato y eventualmente le vas a dar uso. En argentina cuesta 17 pesos.
Por lo que veo esta funcionando bien los tuyo, me alego.

@JGB1966, tendrías que probar con un PIC nuevo.
12/12/2012 #42


Mucha gracias drkblog y xxnuil, voy a intentar con sus consejos auque demore un par de dias ya que no tengo una casa de electronica cerca. Cuando lo pruebe subo los comentarios.
12/12/2012 #43


xxunil dijo: Ver Mensaje
Por lo que veo esta funcionando bien los tuyo, me alego.
¡Sí! Ya armé mi generador de señales con un AD9850 y un PIC12F629
Imágenes Adjuntas
Tipo de Archivo: jpg AD9850_PIC12F629_1.jpg (148,6 KB (Kilobytes), 78 visitas)
Tipo de Archivo: jpg AD9850_PIC12F629_2.jpg (124,3 KB (Kilobytes), 44 visitas)
20/02/2013 #44


no puedo grabar en el grabador de pic k150
hola amigos como estan espero que me ayuden no puedo grabar con el k150es una grabador el pic 16f628a y otros pic aparece rom = no erased,eeprom= no edased,id = no erased,fue= no erased. me ayudaria si dejan un totorial como grabar y un 16f876a muchas gracias
20/02/2013 #45


Hola josafat20, me pasó lo mismo pero con un 18f2550.
me aparecía lo mismo que a ti: rom = no erased,eeprom= no edased,id = no erased,fuse= no erased.
Lo solucione actualizando el k150, con otro 16f628a. Luego pude borrarlo sin problemas
Archivos Adjuntos
Tipo de Archivo: rar epk150.rar (4,1 KB (Kilobytes), 577 visitas)
21/02/2013 #46


muchas gracias pero me podrias decir como atualizar ya que cuando abro el archivo que me mandastes sale un archivo hex y la verdad soy nuevo en esto muachas gracias
22/02/2013 #47


tendrías que programarlo en un pic 16f628a y luego sustituirlo por el pic que trae el k150
02/03/2013 #48


ohhhh... funciona gracias... tenía el mismo problema con el 18f2550, solo volví a grabar el 16f628a que viene en la placa con el archivo que colgó abtron y listo ahora el grabador trabaja sin problemas
03/03/2013 #49

Avatar de digito

Hola el Software del K150 resulta ser obsoleto por el chipdata.cid, entonces te voy a enviar el Nuevo Software con Guia y chipdata.cid actulizado y perfectamente funcionante, el Driver es lo que utiliza el puerto COM (no el programador) sea "COMn" o adaptador "USB-COM".

Lo he utilizado varios años y todavia funciona perfectamente.

Chau y hasta la proxima.
Archivos Adjuntos
Tipo de Archivo: rar K159_programmer_GUI.rar (359,4 KB (Kilobytes), 531 visitas)
04/03/2013 #50


a mi el k150 me da errores en el programa, pero sin embargo hasta ahora no he tenido problemas a la hora de programar.
josafat20 prueba cambiando los drivers del usb
06/03/2013 #51


Problema K150 y PIC 12F1840
Hola, alguien sabe alguna forma de que el K150 soporte el PIC 12F1840?

He conseguido añadir los datos a mano a la lista que trae el sotfware por defecto, pero al parecer los "FUSES" en este PIC están en una dirección totalmente distinta a cualquiera de los modelos estandar que reconoce originalmente.

Hay alguna forma que mediante el propio programa del PIC se autoreprograme los FUSES?.
La otra opción sería un firmware actualizado y no parece que exista :(
30/04/2013 #52


problema con mi programadora k150
acabo de comprar una k150 pero tengo un problema no puedo quemar pic 16F887 y esos son los que necesito utilizar para un proyecto porque son los mas faciles de programar alguna respuesta de como puedo hacer en este caso
30/04/2013 #53


uzumakirivera dijo: Ver Mensaje
acabo de comprar una k150 pero tengo un problema no puedo quemar pic 16F887 y esos son los que necesito utilizar para un proyecto porque son los mas faciles de programar alguna respuesta de como puedo hacer en este caso
Amigo, como minimo debes poner:
  • Datos de tu sistema.
  • Pasos que hiciste en el proceso de instalación del programador.
  • Cual es el error que tira?
  • Fotos
  • y todo lo que pienses, podría ayudar a darnos mas pistas de cual puede ser el problema.

Saludos
26/05/2013 #54


pic16f877a me sale un error (EEPROM error at 0x0010 Good 0xFF Bad 0x7F) y he notado que cuando borro el Rom, ID,Fuse se Borran pero el EEPROM no se borra no sé si es el mismo caso que menciona abtrom en líneas pasadas. Alguien tiene una idea de porque sale este mensaje y como lo puedo solucionar.
26/05/2013 #55

Avatar de Scooter

Prueba a borrarlo primero a ver si se deja programar después
26/05/2013 #56


El error aun sigue scooter aun si lo borro primero dejo una imajen para documentar el error

Aun el erro sigue aun que borre primero
Imágenes Adjuntas
Tipo de Archivo: png error.png (96,9 KB (Kilobytes), 536 visitas)
28/05/2013 #57


drkblog dijo: Ver Mensaje
Probé con los drivers nuevos y tampoco funciona. Ahora voy a hacer una última prueba con Windows XP. Pero no creo que sea ese el problema en este caso.

Lamentablemente lo compré porque me pareció barato. No sé cuando cuesta el Pickit2, pero lo voy a tener en cuenta. Ya que a esto no le veo salida.

Hola DRKBLOG , te comento que yo también adquirí un KIT 150 de los chinos (Por Ebay), igual al tuyo y tuve el mismo problema con el driver. El problema esta realmente en que no hay drivers para WIN 7 - 64 bits. Yo probé el Kit en una pc con Win7 - 32 bits y funcionó perfectamente (utilizando los drivers que compartió XXUNIL). Vos pudiste hacerlo andar al kit al final? porque veo que tú ultima publicación fue en diciembre de 2012.

Saludos!
30/05/2013 #58


Hola a todos bueno tengo que comentar que estado usando el grabador con ese mensaje que mostré en líneas anteriores y por lo que veo graba el programa pero noto que el ciclo es muy lento y a medida que le bajo la frecuencia al oscilador a menos de la mitad tiene un una repetición mas continua (encender y apagar un led) e leído mucho del fuses pero no logro configurarlo de la forma correcta porque cuando pongo la frecuencia del cristal (4MHZ) se pone lento. Me puede dar una orientación para ver por donde ataco el problema, si es o no el fuses o es otra cosa. Estoy usando el Pic16f877a con el editor de codigo Pic C compiler
22/11/2013 #59


hola a todos, yo tambien tengo un programador chino y tengo el mismo problema que nelsonr no consigo programar un 2550, he intentado programar el 16f628a , pero tengo el mismo problema al programar, osea que no puedo, tendria que intentar programarlo con otro programador y probar ese a ver si no da problema con el error del mensaje good-bad, si alguien ha solucionado este problema de alguna forma, le agradeceria lo comentara,
Un saludo a tod@
27/12/2013 #60
Moderador

Avatar de tiago

Estos programadores parece que no tienen fin con sus pegas.
Yo tengo uno, y siempre me arroja algún error cuando lo intento resetear, pero luego graba bien.
He probado con todos los drivers que he encontrado, y lo he probado tanto en XP como en W7 de 32 bit.

Parece que no hay manera de hacerlos dóciles, pero por otra parte, leen y programan bastante bien.
Yo he encontrado algunas pegas, y son éstas:
Parece que el software de programación, que es el mismo que se emplea en los comentarios y fotos de los posts anteriores, tiene algún bug. lo digo porque he estado cargando repetidas veces el mismo archivo en diferentes PIC, siempre desde una copia que tengo en el escritorio. En una de estas, la copia del escritorio ha perdido algunos datos del bloque de EEPROM. No sé a que puede ser debido, quizá he metido la pata yo solito.

Pero lo mas importante de todo es que al cargar cualquier archivo de cualquier PIC y quererlo guardar, los datos de ROM los guarda perfectos, pero los de EEPROM los deja siempre en blanco.
¿Alguien ha tenido el mismo problema y sabe como resolverlo?

Saludos.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.