Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

19/01/2015 #41


por ahi bienen mis problemas porque ya no tengo valores erroneos enormes, es decir 650 grados ahora solo tengo un sobre valor de +5 grados con los leds encendidos... voy a tratar de corregirlo por codigo porque tengo todo armado ya y en su correspondiente gabinete, y de ultima arè un driver para cada led con transistores como me aconsejas, cual es la mejor configuracion para usar un transistor a la salida de un pic a modo de driver? o cual es la que tù usas?
20/01/2015 #42

Avatar de papirrin

por ahi bienen mis problemas porque ya no tengo valores erroneos enormes, es decir 650 grados ahora solo tengo un sobre valor de +5 grados con los leds encendidos
es que sin ver el diagrama se complica que te pueda dar una opinion, porque ya mencionas que son leds (en plural) lo que significa que son varios, si por cada led le sumas 10mA mas los optos, mas lo que le tengas colgado al 7805, puede que este limitado ya que por lo general no entrega el 1A que dicen.

cual es la mejor configuracion para usar un transistor a la salida de un pic a modo de driver? o cual es la que tù usas?
con respecto al "driver" yo me refiero a hacer esto:



* modifique la imagen asi que no le hagas caso a eso que dice prox sens, y cualquier transistorcito de uso general te sirve como el bc548, el 2n2222, o similares
20/01/2015 #43


Me sigue dando un error en +5 grados casi... , estoy usando un display azulcon fondo blanco de 4x20 winstar 2004, tendre que reconciderar la fuente de viltage??
20/01/2015 #44

Avatar de papirrin

osea que agarre una imagen del google parecida al circuito que necesitaba mostrarte y la edite con el paint pero se me olvido borrar eso que tiene de prox sens
20/01/2015 #45


Me quiero morir... sabes cual era el problema?? faltaba GND en la pata 3 del sht75 no se como pudo pasar eso... y lo mas extraño es que asi y todo las lecturas sin ninguna carga (solo el lcd) me daban correctas te molesto por ultima ves, sabes como ago para imprimir por pantalla el simbolo de grados (°)?
20/01/2015 #46

Avatar de papirrin

intenta mandarle el caracter 239 o en exadecimal 0xEF

no se como estes imprimiendo pero esto te puede servir

printf("simbolo %c",0xEF);
20/01/2015 #47


ya intente eso y no me funciono, estoy haciendo algo asi

printf(lcd_putc,"%3.1f%c", restemp, 223); el 223 me trae un punto arriba a la derecha a modo de grados algo asi ° pero es solo un punto
20/01/2015 #48

Avatar de papirrin

pues prueba otro ascii cada LCD tiene su propia tabla ascii, ¿cual es el modelo de tu LCD?

el que yo te puse es el del popular HD44780
Imágenes Adjuntas
Tipo de Archivo: jpg Dibujo.JPG (64,9 KB (Kilobytes), 3 visitas)
20/01/2015 #49


es de 4x20 winstar 2004A
20/01/2015 #50

Avatar de papirrin

si me equivoque se supone que si es el 223, si no lo tiene o no te gustan los que tiene puedes diseñar el tuyo.
20/01/2015 #51


una pregunta más y me la contestas cuando puedas, un delay de (delay_ms(1000)) 1 segundo verdad?! cambia la duración si modifico el clock?
ejemplo:
#use delay(clock=1MHz)
por
#use delay(clock=20MHz) ?
20/01/2015 #52

Avatar de papirrin

una pregunta más y me la contestas cuando puedas, un delay de (delay_ms(1000)) 1 segundo verdad?! cambia la duración si modifico el clock?
ejemplo:
#use delay(clock=1MHz)
por
#use delay(clock=20MHz) ?
si, el delay_ms(1000) es un segundo, y si cambia si modificas el #use delay(clock=X), se pone a como este configurado el FOsc. que generalmente pero no siempre es igual al cristal, porque se puede configurar un micro con divisores de frecuencia.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.