Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

29/04/2008 #1


Duda ICD2 y PIC16F84
Hola, tengo una pequeña duda. Cuando programo mi PIC insertado en mi circuito con el ICD2 (usando MPLAB), para que el circuito comience a funcionar, le doy "release from reset", y el circuito comienza a funcionar sin ningún problema. La cuestión viene cuando mi circuito usa alguna de las patillas que usa el programador para la programación del PIC (RB6 y RB7), ya que estas se quedan a nivel bajo y para que el circuito funcione correctamente tengo que desconectar mi circuito del ICD2. ¿Esto es normal?

Saludos.
29/04/2008 #2


Al parecer esto es normal para el ICD2.

En mi caso siempre es necesario desconectar RB6 y RB7 del ICD2 cada vez que las necesito usar en mi aplicacion. Lo que yo siempre hago es tratar en la medida de lo posible de no usar RB6 y RB7 hasta que no haya otra manera de lograr echar a andar mis proyectos sin ellos. Para no utilizar RB6 y RB7 basta dejarlos como entradas en el firware para que no generen mayor problema.

Al parecer el ICD2 no libera los pines RB6 y RB7 al elevar el Reset, posiblemente porque no cuenta con bufferes de 3 estados en sus pines de programacion.

Espero mis experiencias te ayuden.
Saludos.
29/04/2008 #3


Muchas gracias por la respuesta. Estaba seguro que no era el único que tenía este "problema", jeje.

Saludos.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.