Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

26/02/2009 #61


intenta cambiando el tipo de micro : Configure > select device y en device selecciona el uC

si no lo resuelve, postea el programa , asi sera mas sencillo auxiliarte
26/02/2009 #62

Avatar de Moyano Jonathan

Es verdad postea el programa y fijate bien en las configuraciones del mplab, una ves matandome la cabeza para ver cual era mi error me di cuenta que el micro seleccionado no era el que estaba en el programa... una tontera pero puede causarte un gran dolor de cabeza si no lo configuras bien.
27/02/2009 #63


;Leer el estado de los 5 interruptores E0-E4 conectados a RA0-RA4 y reflejar el nivel lógico de
;los mismos sobre los leds S0-S4 conectados en RB0-RB4

List P=16F84A ;Tipo de procesador
include <P16F84A.INC> ;Incluye el fichero P16F84.INC que contiene la definición con los nombres
;de los registros internos


org 0x00 ;Vector de Reset
goto Inicio

org 0x05 ;Salva el vector de interrupción

Inicio clrf PORTB ;Borra los latch de salida
bsf STATUS,RP0 ;Selecciona banco 1 de la memoria de datos
clrf TRISB ;Puerta B se configura como salida
movlw b'00011111'
movwf TRISA ;Puerta A se configura como entrada
bcf STATUS,RP0 ;Selecciona banco 0 de la memoria de datos

Loop movf PORTA,W ;Leer las entradas RA0-RA4
movwf PORTB ;Reflejar en las salidas
goto Loop ;Bucle sin fin

end ;Fin del programa fuente


Es con cualquier programa no es con uno en especial y lo del tipo de micro ya lo mire,saludos
27/02/2009 #64


con la adecuacion que te dije, el programa que posteas al compilarlo MPLab no me marca errores y si genera el archivo .hex correspondiente


fijate que tipo de micro te marca en la barra de status del MPLab
28/02/2009 #65


Hola,el programa ya me trabaja bien,pero lo sorprendente es que no le hice nada para solucionarlo,lo del micro ya lo habia chequeado,pero muchas gracias por haberme contestado.
Saludos.
19/03/2009 #66


Problema con compilador hi - tech para mplab 8.10
Hola amigos lo que pasa es que recien ando iniciandome en programacion de pics en C yo manejaba assembler sin problemas y ahora he intentado programar en C pero el mplab no acepta la compilacion me sale este error

Executing: "C:\Archivos de programa\HI-TECH Software\PICC\PRO\9.60\bin\picc.exe" --pass1 "E:\ELECTRONICA\PROGRAMAS MIL\primero.c" -q --chip=16F84 -P --runtime=default --opt=default -D__DEBUG=1 -g --asmlist "--errformat=Error [%n] %f; %l.%c %s" "--msgformat=Advisory[%n] %s" "--warnformat=Warning [%n] %f; %l.%c %s"
Error [141] E:\ELECTRONICA\PROGRAMAS MIL\primero.c; 12.18 can't open include file "16F84.h": No such file or directory

al parecer no jala el include no lo acepta nose que puede estar faltandome cualquier ayuda se los agredecere saludos.

PD. El pic q utilizo es el 16f84 y el compilador el de hi tech que viene con el mplab 8.10
21/03/2009 #67


aparte del mplab otro programador de pic. por fa contesten
21/03/2009 #68


puedes encontrar versiones gratuitas de otros compiladores (aunque limitadas) aqui : http://softwarepic.50webs.com/freesoft.html
25/03/2009 #69


En lugar de declarar

#include <16F84.h> esto solo lo haces con ensamblador

La forma correcta en Hi tech
es

#inlude <pic.h> para programar en Ansi C
25/03/2009 #70


Ha! tambien tienes que crear un proyecto nuevo, al cual deberas agregarle el codigo fuente; no sin antes seleccionar la herramienta de compilación correcta.

Deberias revisar algun manual; en este momento no tengo ninguno a la mano, creo que lo puedes obtener en la pagina de hi- tech.
Si encuentro un manual te lo envio; ya que no recuerdo bien todo el procedimiento.
12/04/2009 #71


Tengo un problema con MPLAB, retardos.inc
Hola a todos

Tengo un problema al compilar con el PIC18, el error es el siguente:

Error[105] C:\USERS\ALEJANDRO\DESKTOP\PROJECTS MPLAB\NITO_PROJECT.ASM 72 : Cannot open file (Include File "RETARDOS.INC" not found)
Halting build on first failure as requested.

ya agregue el archivo de retardos.inc en la carpeta de Header Files y lo guarde iy aun asi sigo teniendo ese error, agradeceria su ayuda, gracias

tambien dejo el programa para que lo vean...
__CONFIG _CP_OFF & _WDT_OFF & _PWRTE_ON & _XT_OSC
LIST P=16F84
#include <p16F84a.inc>

CBLOCK 0X0C
ENDC

#DEFINE B0 BCF STATUS,RP0
#DEFINE B1 BSF STATUS,RP0
#DEFINE SERVO PORTB,7
ORG 0

B1
MOVLW B'00001111'
MOVWF TRISB
BCF OPTION_REG,NOT_RBPU
B0
BCF SERVO


INICIO
BTFSS PORTB,0
GOTO DERECHA
BTFSS PORTB,1
GOTO IZQUIERDA
BSF SERVO
CALL RET_CENTRO
BCF SERVO
CALL RET_RESTANTE
GOTO INICIO


DERECHA
BSF SERVO
CALL Retardo_1ms
CALL Retardo_500micros
CALL Retardo_200micros
CALL Retardo_100micros
;CALL Retardo_20micros
NOP
NOP
NOP
NOP
BCF SERVO
CALL RET_RESTANTE
GOTO INICIO

IZQUIERDA
BSF SERVO
CALL Retardo_1ms
CALL Retardo_50micros
CALL Retardo_20micros
;CALL Retardo_20micros
BCF SERVO
CALL RET_RESTANTE
GOTO INICIO

RET_CENTRO
CALL Retardo_1ms
CALL Retardo_200micros
CALL Retardo_200micros
CALL Retardo_50micros
;CALL Retardo_10micros

;CALL Retardo_20micros
RETURN

RET_RESTANTE
CALL Retardo_10ms
RETURN

INCLUDE<RETARDOS.INC>
END




muchas gracias
12/04/2009 #72


coloca el archivo *.inc en el mismo lugar que el archivo *.asm
12/04/2009 #73
Moderador

Avatar de Vick

mabauti dijo:
coloca el archivo *.inc en el mismo lugar que el archivo *.asm
o en la carpeta del MPASM, que debe ser:

C:\Archivos de programa\Microchip\MPASM Suite

Donde estan los demas archivos .INC, así el ensamblador buscará automáticamente ahí todos los archivos .INC que coloques en tus programas...
27/04/2009 #74


Error de librería en MPLAB
Hola a toda la comunidad, antetodo quiero presentarme soy un usuario que le gusta la electrónica ya que la he estudiado en mi carrera y también la tengo como hobby. También quiero felicitaros por el foro, veo que tenéis muchísima información y bastante interesante. Hace poco he creado un programa para el PIC16F873 así que me descargué la última versión del MPLAB y veo que el interfaz ha cambiado bastante, hará cosa de 4 años que no volvía a programar PICs, cuando meto el asm para compilar me da un error de librería. ¿Alguien sabe cómo se soluciona esto?
27/04/2009 #75

Avatar de Ardogan

¿Y cual es el error de librería? (hay unos cuantos).
Viendo que retomaste después de un paso largo, ¿seguiste todos los pasos que menciona la ayuda para crear un nuevo proyecto? con el wizard: elegir pic, archivo inc, archivo lkr, y el template en asm (opcional).
27/04/2009 #76


Sí, he seguido todos los pasos del wizard. Pero ya he arreglado me lo compila pero me salen mensajes del estilo "Message[302] C:\PROGRAMACION\PROYECTO1.ASM 19 : Register in operand not in bank 0. Ensure that bank bits are correct."

Así que me va a tocar mirar los bancos bancos. Muchas gracias por todo.
27/04/2009 #77

Avatar de Ardogan

Ok, para el tema bancos te recomiendo usar banksel, y para cambios de página de memoria de programa-> pagesel. Así no tenés que andar viendo a qué banco pertenece cada registro que vas a usar.
Ya hablamos en el foro de banksel y pagesel en el foro, lo podés encontrar con el buscador para más detalles (también en la ayuda del mpasm).
Saludos.
27/04/2009 #78


Yo es que soy de la vieja escuela y en el programa tengo:

BCF STATUS,RP1
BSF STATUS,RP0

Para ir al banco 1 y entonces configurar las entradas y salidas en el TRISA, y creo que lo tengo todo bien.

Aun así te haré caso y echaré un vistazo a lo que me has dicho. Muchísimas gracias por todo. Creo que este es el mejor foro de electrónica de toda la Red.
27/04/2009 #79


Solo has puesto eso?
Pega todo el programa.
27/04/2009 #80


Ya está chicos lo he solucionado muchas gracias por todo. Me habéis sido de gran ayuda.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.