Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

21/02/2007 #1


interferencia con el PIC
Hola tengo un sistema microprocesado con el PIC16F877A, el cual controla una alarma con todos los requerimientos necesarios, y esta funcionaba correctamente hasta que le aumente una parte.
Lo que aumente fue un control de un portero eléctrico (Chapa electrica) a traves del mismo teclado, cuando presiono una tecla el pic pone en alto una salida, y esta controla un rele comun y corriente a traves de un transistor, el rele es el que conmuta para accionar la cerradura, pero justo en el momento en que mando la acción el programa en el pic se pierde o eso es lo que creo, se salta a lugares donde no tenia que estar e incluso a veces se cambia la clave, a veces funciona bien pero son pocas.
Si se podrian ayudar con este problema

Muchas gracias

PD al activar el rele sin conectar la cerradura funciona correctamente..
22/02/2007 #2
Moderador

Avatar de Chico3001

Pon capacitores de desacoplo en las alimentaciones del PIC y de los circuitos integrados.... tambien añade bobinas de filtro de CA a la entrada de alimentacion, incluso varistores en paralelo con la chapa electrica para eliminar picos de voltaje

Verifica que la señal de salida de la fuente se encuentre bien filtrada, tambien puedes poner un TVS despues de los puentes de rectificado de la fuente para eliminar aun mas espígas de voltaje....

Saludos...
22/02/2007 #3


INTERFERENCIA
GRACIAS POR LA INFORMACION PERO NO LA ENTIENDO MUY BIEN CUALES SON CAPACITORES DE DESACOPLO, SON LOS FILTRO COMUNES EN PARALELO, NECESITO INFORMACION SOBRE LAS BOBINAS DE FILTRO PORQUE DE ESO SI NO TENGO IDEA, ADEMÁS QUE ES LO DE TVS, TALVES CONOSCA PERO CON OTRO NOMBRE

GRACIAS

Chico3001 dijo:
Pon capacitores de desacoplo en las alimentaciones del PIC y de los circuitos integrados.... tambien añade bobinas de filtro de CA a la entrada de alimentacion, incluso varistores en paralelo con la chapa electrica para eliminar picos de voltaje

Verifica que la señal de salida de la fuente se encuentre bien filtrada, tambien puedes poner un TVS despues de los puentes de rectificado de la fuente para eliminar aun mas espígas de voltaje....

Saludos...
23/02/2007 #4


Hola Jairo.

Mira esto a ver si te sirve de algo:

http://www.todopic.com.ar/foros/index.php?topic=11903.0

Un saludo desde Alicante!
12/04/2007 #5


Wenas a todos,

Tengo unas dudillas, que parece que me podeis solucionar. El tema es que estoy haciendo un circuito con sensores y un PIC, que me procesará las muestras y me las almacenará. No estoy muy puesto en la electrónica, pero por ahora, he podido hacer todo el acondicionamiento de los sensores, y me funcionan perfectamente (ya los tengo con un margen de medida de 0 a 5V para poder procesarlos con el ADC del PIC, y con salida lineal). El problema me viene a la hora de conectar el PIC a la alimentación. Esta me varía mucho (unos 700mV), lo que me varía también las salidas de los sensores.

Supongo que esto se podría solucionar con los condensadores de desacopla que comentais, y/o con un filtro a la salida del acondicinamiento de los sensores, pero me surgen dos dudas:

1º Que valor deben tener los condensadores de desacoplo
2º ¿Conoceis algún fitro paso bajo que se pueda alimentar con una tensión positiva y masa?

Todos los filtros que yo he utilizado antes (y son muy pocos, no los conozco mucho) eran alimentados a tensiones de +Vcc y -Vee. He probado a utilizar estos pero con la alimentación a 0V no me funcionan. Necesito que la alimentación sea de este tipo, porque el circuito que estoy diseñando será autónomo, y estará alimentado con un pila.


Muchas gracias adelantadas.
12/04/2007 #6


Vamos por partes:

Siempre debe haber lo mas cercano a las patillas de alimentacion del micro uun condensador de 47nf a 100 nF si puede ser de lenteja mejor pero no te sirve culaquiera.
tambien es necesario poner algun condensador electrolitico segun las dimensiones de la placa y el numero de integrados, con uno de 470uF bastaria.

Como es que tienes esas bajadas de tension, que alimentas elementos de gran consumo?


Para el tema del filtro hay varios "trucos"

Uno es utilizar un amplificador operacional y configurarlo como no inversor (ese que tiene unido la salida con la patilla inversora), en la patilla no inversora pones un divisor de tension o mejor todavia un zener o un ref02 y la salida del operacional seria la masa, el positivo es el positivo de la fuente y el negativo es la masa de la fuente.

otro metodo es utilizando un simple divisor de tension pero eso ya deberia conocer el esquema.
La idea es inyectar un tension de Vcc/2 al operacional con un divisor de tension de dos resistencias de 100k sin que se influencien mucho las medidas. En alterna es facil.
13/04/2007 #7


La verdad es que no entiendo porque se producen esas variaciones de tension, no alimento nada con mucho consumo. De todas formas, lo he conseguido arreglar coloconado un filtro pasivo a la salida del acondicinamiento de los sensores, ya que elimino el ruido, y consigo que vuelva a tener una salida en continua bastante estable.

Sólo utilizo tension en continua.

Muchas gracias por la información de los condensadores. Ya lo había utilizado (los condensadores de desacoplo), pero no recordaba el valor.

Muchas gracias por la rápida contestación,

Hasta la próxima

Un saludo
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.