Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

11/12/2011 #1


L293D quema PIC16F876A
Hola compañeros

Me gustaría comentaros un pequeño problema que tengo... Estoy haciendo un robot seguidor de línea usando el pic16f876A como controlador. El problema viene cuando quiero exprimir al máximo los motores conectándolos a 12V... el pic deja de funcionar. Uso el driver L293D que en teoria tiene los diodos internos con la configuracion tipica del datasheet que permite ir hacia delante y atrás. Utilizo un regulador 7805 cuya salida es la tensión lógica del uc y la entrada (los 12V de la fuente) es la entrada del pin tensión del motor del L293D. Explico unas pruebas que he hecho...

1) A 5V sin regulador funciona todo perfecto (Tensión en bornes del motor 3.7V debido al consumo del puente en H del driver)

2) A 6v con regulador va todo perfecto (Tensión en bornes del motor 4.8V debido al consumo del puente en H del driver)

3) A 12V con regulador el uc deja de funcionar al minuto o dos de estar funcionando

4) A 12V con regulador y todas las conexiones entre uc y driver (las 2 inputs y el pwm enable por cada motor, es decir, 6 conexiones) las conecto directamente a 5V o a 0V. Con esto, no hay conexiones reales entre uc y driver. El funcionamiento es perfecto no se quema el uc, por lo tanto, el fallo esta bastante acorralado.

Mi pregunta, puede ser que los diodos del L293D no esten funcionando o se hayan quemado? La verdad es lo único que se me ocurre que puede estar fallando... Os ha pasado esto alguna vez? Debería ponerlos externamente por mi cuenta o puede puede haber otro motivo del fallo? Como seria la conexión de dichos diodos?

Muchas gracias de antemano por vuestra ayuda!
11/12/2011 #2
Moderador general

Avatar de Fogonazo

¿ Circuito ?

Reglas generales de uso del foro

12) Cuando consultes sobre algún esquema sobre el que estás trabajando ! Publícalo ¡ NO presupongas que somos adivinos y conocemos de que cosa estas hablando.
11/12/2011 #3

Avatar de pandacba

Como ya te dijeron esquema sobre el que has trabajo, datos del motor(voltaje, consumo) y fotos de tus placa/s armadas para poder obserbar el coneccionado.

Poro otro lado eso que tu dices de menor voltaje y explicas que es por el consumo, no es asi, es por la caida de tensión que se producen en la juntura de los transisotres del puente y que es algo menor a los 1.4, pero eso no tiene nada que ver con ningún sonsumo
11/12/2011 #4


Hola compañeros,

La conexión del driver como dije es la que marca el datasheet (esquema adjuntado como L293D). He hecho esa conexión para cada uno de los dos motores.

Las demás conexiones pensaba que el texto publicado era suficiente por eso no añadí nada. De todas maneras, adjunto un pequeño esbozo (Esquema) de las conexiones que tengo.

Adjunto el datasheet del motor (DCMOTOR) es el modelo 82 840 0 de 12V, es decir, la tercera columna.

Gracias por la corrección del tema del cosumo pandacba Tienes toda la razón, es debido a lo que explicas y no al consumo.

Estaría muy agradecido de cualquier consejo que puedan facilitarme acerca del problema que comenté antes.

Muchas gracias
Archivos Adjuntos
Tipo de Archivo: pdf L293D.pdf (88,2 KB (Kilobytes), 65 visitas)
Tipo de Archivo: pdf Esquema.pdf (178,1 KB (Kilobytes), 152 visitas)
Tipo de Archivo: pdf DCMOTOR.PDF (23,0 KB (Kilobytes), 59 visitas)
11/12/2011 #5

Avatar de BKAR

esta muy bonito tu esquema...
cuida si uC esta muy cerca del motor, esto por si es muy peligroso para el...
sobre los diodos de proteccion? no hay diodos internamente que yo sepa, tienes que ponerlos externamente
en el pdf que enviaste esta la configuracion de diodos
y a que te refieres con "pwm enable"?

---------- Actualizado después de 4 minutos ----------

luiscd dijo: Ver Mensaje
4) A 12V con regulador y todas las conexiones entre uc y driver (las 2 inputs y el pwm enable por cada motor, es decir, 6 conexiones) las conecto directamente a 5V o a 0V. Con esto, no hay conexiones reales entre uc y driver. El funcionamiento es perfecto no se quema el uc, por lo tanto, el fallo esta bastante acorralado.
las 6 lineas de control, mira tu como ves como ponerlas,
2 enable, para cada motor, y las otras 4 (2 por motor)
controlan el giro o "stop" de cada motor, no preguntes si las conectas directamente a 5v o 0v
tiene que haber conecciones reales... sino como lo controlarias?
11/12/2011 #6


Muchas gracias por tu respuesta compañero.

El L293D dispone de diodos internos, en el datasheet hay esta nota:

NOTE: Output diodes are internal in L293D.

El driver y el uc están cerca si, es un pequeño protoboard y uno esta encima del otro, podría ser este el problema? Piensa que desconectando las conexiones uc y driver todo funciona correctamente.

PWM Enable es la señal de enable que hay para el puente en H del driver, lo único que al utilizar una señal PWM la he llamado así.

Respecto tu mensaje editado, lo que he querido decir es que he hecho una prueba en la cual el uc no estaba conectado al driver, las conexiones del driver las ponía a 5V o a 0V en función de su actividad (no era una pregunta, era una explicación). Obviamente el robot no seguía la línea, pero esto lo hice para confirmar que el fallo venía del driver. Al no quemarse el uc, me ha confirmado que el regulador esta trabajando correctamente y es el driver el que quema el uc.

Un poco mi duda viene por el driver ya que nunca lo he utilizado y no se hasta que punto es fiable y si los diodos internos pueden llegar a quemarse. También estaría altamente interesado de escuchar alguna opinión de algún compañero del foro en caso de creer que el uc se puede quemar por otras causas.

Muchas gracias por vuestros aportes
11/12/2011 #7

Avatar de BKAR

si lo he usado pero... no he intentado controlarlo con PWM para la velocidad
y siempre le ponía diodos...como también estan diseños en internet que en el PCB le ponian diodos
pero por seguridad igual le pongo diodos y mas aun si hay algún integrado sensible a los típicos problemas al switchear cargas inductivas como RELAYS y MOTORES
en el caso si se queman...que secederia...se cortan o se abren?
si se cortaran Uuhhy corto circuito!!!
pero supongo que como muchos diodos estos de romperian y no dejarian pasar la corriente
11/12/2011 #8


Que tal amigo.

Supongo, por tu fantástico esquemático, que estás alimentando tanto el uC como los motores con la misma fuente, solo que usas un regulador para el micro. Si es así, craso error, puesto que aunque el datasheet te diga que el driver tiene diodos de protección y tales para proteger el chip, esto no evita que los pulsos altos de corriente al momento de activar o desactivar el motor te resetee e incluso cause un "ruido" sobre la señal de reloj que tiene el micro.

Lo más conveniente para estos casos es que, mientras quieras probar, utilices dos fuentes, una para lo digital y otra para los motores (eso si, uniendo las tierras de referencia), revises a ver que sucede en esta prueba, y nos cuentas.

Suerte y hasta pronto
12/12/2011 #9


Muchas gracias por tu aportación QuimCri estoy muy agradecido, comentaré algo nada más probarlo.

PD. Siento el esquemático pero en ese mismo momento no tenía más recursos disponibles y creo que a pesar de su aspecto cumple el objetivo de cualquier esquemático, mostrar las conexiones. De todas formas, perdona las molestias.
17/03/2012 #10


mira viendo el esquema veo q no usas diodos de proteccion .
2. veo q el datasheet ese esta erroneo pues lo q tienes q verificar siempre es el fabricante del l293d ya estos en el esquema equivalente interno no traen diodos de proteccion por eso se te quemo el circuito a y tambn tienes q tener en cuenta las alimentaciones del circuito una indepeniente para la parte de control y otra para los motores unicamente solo asi puede q te funcione bn
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.