Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

18/06/2011 #1

Avatar de ema95

ayuda con lcd de 1x16 y pic 16f628a
Hola gente. Como andan? Bueno estoy desesperado es lo primero que digo. Resulta que se me habia ocurrido hacerle un regalo a mi viejo por el dia del padre y queria usar un lcd de 1x16 con un pic 16f628a y escribirle un mensaje. Bueno para probar empece con el clasico "Hola mundo" y que despues se apague. Pongo todo en el protoboard y no me muestra nada, osea en realidad si me muestra pero me marca todos los leds, ahora les muestro una foto de lo que me hace.... bueno yo lo programe en pic simulator IDE porque de lenguaje assembler o C no se nada. Un problema que encontre es que en la patita del pic donde tiene que salir RS, se encuentra siempre en 0, por lo que yo simule en proteus y me dice que la patita en cada segundo va cambiando, es decir, pone 1 en la patita RS y espera un segundo y se pone en 0.... y despues vuelve, cosa que en la vida real en protoboard siempre se queda en 0. No se que puede estar causando eso. Espero que me puedan ayudar, ahora les dejo el programa, el circuito y una foto de lo que me esta pasando. Si pueden arreglarme el problema en el programa mejor y si no, si pueden, dejenme un programa que hayan hecho que les funcione. Ah me olvidaba el codigo del lcd es WM-C1601Q

El programa (en pic simulator IDE):

Código:
Define LCD_BITS = 8
Define LCD_DREG = PORTB
Define LCD_RSREG = PORTA
Define LCD_RSBIT = 1
Define LCD_EREG = PORTA
Define LCD_EBIT = 3
Define LCD_RWREG = PORTA
Define LCD_RWBIT = 2

Lcdinit 0

inicio:

Lcdout "HOLA MUNDO!"
WaitMs 500
Lcdcmdout LcdClear
WaitMs 500

Goto inicio
Las Fotos:

http://www.publicarfotos.com/foto_gratis-f4055-a1
http://www.publicarfotos.com/foto_gratis-f4055-a2
http://www.publicarfotos.com/foto_gratis-f4055-a3



http://www.publicarfotos.com/foto_gratis-f4056-a1


Una pregunta.... el ENABLE Y EL R/W TAMBIEN ESTAN EN 0.... SEGUN LA SIMULACION ESO ESTA BIEN, PERO ME PARECE RARO QUE EL ENABLE ESTE EN 0 Y FUNCIONE..... GRACIAS POR SU AYUDA!
19/06/2011 #2

Avatar de kenoby

yo tambien estoy aprendiendo a utilizar los lcd
te recomiendo que vayas aprendiendo a usar el assambler ademas del lenguaje que ya sabes.
http://patna.sancharnet.in/guria741/pic2lcd/pic2lcd.htm
ese funciona aunque es para un 84a ... muestra hello word
podes probarlo con el .hex o bajarte el .asm y modificarlo que no es tan dificíl (ya lo hice yo) creo que nada mas tenes que cambiarle el <P16F84A.INC> por el del 628 porque el codigo funciona para los dos.
para aprender ensamblador:
http://wiki.webdearde.com/index.php/...en_Ensamblador
19/06/2011 #3

Avatar de ema95

muchas gracias kenoby.... ahora mismo lo pruebo
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.