Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/03/2010 #1


¿Qué le pasa mi robot?
Hola a todos. Es la primera vez que recurro a un foro para pedir ayuda.
En el siguiente link podeis ver a mi robot recorriendo una trajectoria programada
(sin sensores de ningun tipo).

http://www.youtube.com/watch?v=t7mEpcsKiAc

Adjunto, programa en C de una trayectoria similar ( no es exactamente la misma que la del video, pero es para que os hagaís una idea).
Adjunto tambien un esquema completo en isi de PROTEUS por si quereis simular..o construirlo. Si alguien está interesado le puedo enviar referencias de los motores i servomotores..

PROBLEMA: el robot sufrio un pequeño accidente y no ejecuta la secuencia completa. Mejor dicho, de vez en cuando la realiza, de vez en cuando no la realiza..como si a veces el microcontrolador sufriera un reset inesperado.

Ya he hecho:
a)cambiar el cristal i los condensadores
b)cambiar los fuses en el codigo
c)cambiar servomotores i motores
d)cambiara baterias por si microcortes
e)cambiar mil veces de microcontrolador (pic16f876a)
....
por favor, alguien puede ayudarme? podeis mirar el codigo i decirme algo...
25/03/2010 #2
Moderador general

Avatar de Fogonazo

Respuesta: ¿Qué le pasa mi robot?
¿ Te fijaste que en el "Accidente" no se halla torcido algún eje del sistema de transmisión mecánica ?
Si así fuera podría ocurrir un sobre-consumo eléctrico en algún momento (Durante el movimiento) que produzca el reset.
25/03/2010 #3


Respuesta: ¿Qué le pasa mi robot?
La verdad es que el sistema de transmision mecanico, tanto a los servomotores delanteros como a los 4 motores de tracción, es nuevo y esta perfecto.
Situando el robot en una plataforma elevada, para que los motores trabajen en vacio,
tambien se producen resets inesperados.
Gracias por ayudarme.

Lo siento fogonazo, soy nuevo en esto del foro y no se que signifaca esto de la estadistica.
25/03/2010 #4
Moderador general

Avatar de Fogonazo

Respuesta: ¿Qué le pasa mi robot?
rikicarpio dijo: Ver Mensaje
.....Lo siento fogonazo, soy nuevo en esto del foro y no se que signifaca esto de la estadistica.
Es mi firma, aparece en "Todos" mis mensajes, NO es algo particular sobre tu consulta.
25/03/2010 #5


Respuesta: ¿Qué le pasa mi robot?
¿Has mirado los condensadores de desacoplo? ¿Tensiones en varios puntos? ¿Reguladores de tensión? ¿Puedes poner el esquema para que le hechemos un vistazo? ¿Protecciones contra los picos de consumo? ¿Mal contacto de algún conector?
25/03/2010 #6


Respuesta: ¿Qué le pasa mi robot?
Condensadores de desacoplo son los que se conenctan entre Vcc i masa en los IC? De esos no lleva. El esquema lo he puesto en isisi de PROTEUS si quieres lo pudeo poner en express sch. Los contacot estan todos bien. Los he echo de nuevo todos. Las protecciones a sobrecorrientes no sé a que te refieres. Gracias Beamspot.
25/03/2010 #7


Respuesta: ¿Qué le pasa mi robot?
Lo primero y más importante, son los condensadores de desacoplo. Uno para cara par Vcc-GND. Los motores tienden a 'pegar chupones' en la alimentación, así que se suele filtrar por separado la alimentación de los mismos respecto de la alimentación de la circuitería digital. La fuente digital debe llevar un condensador bien dimensionado, tanto a la entrada como a la salida del regulador, y a ser posible, un diodo en serie en la entrada.

¿Puedes poner una captura de pantalla del esquema?
25/03/2010 #8


Respuesta: ¿Qué le pasa mi robot?
Aqui tienes dos capturas. Una que utilizo para simular y otra que es exacta.
Gracias BEAMSPOT!
Archivos Adjuntos
Tipo de Archivo: rar capturas.rar (156,1 KB (Kilobytes), 8 visitas)
25/03/2010 #9


Respuesta: ¿Qué le pasa mi robot?
Bueno, parece que falta la etapa de potencia en tu esquema de la placa de control real, no en el de la simulación.

La fuente de 5V parece estar bien, según el manual. Te falta un condensador de desacoplo del micro directamente en los pines de alimentación del mismo, y sería recomendable usar uno de 10-100nF en el pin de reset, para evitar problemas ahí.

¿82pF en el cristal de cuarzo? ¿T'has equivocat o t'has tornat boig? Revisa esta parte, y ante la duda, ponlos de 12 a 22pF.

A ver si puedes poner la parte del esquema relativa a los motores y servos.

Siendo un proyecto de robótica, busca información sobre la Asociación de Robótica De España (ARDE), igual hay alguien cerca de tí que te pueda ayudar 'en vivo y en directo'.
25/03/2010 #10


Respuesta: ¿Qué le pasa mi robot?
Gracias BEAMSPOT. He puesto un condensador de 100nF entre Vcc y GND del micro. Y parece que se resuelto el problema de los resets. Lo he puesto en la cara de pistas entre la patilla 19 y la 20.
No habia visto nunca un condensador en el reset. Supongo en paralelo con la resistencia no?
Perdona por los condesadores en ell esquema. Realment son de 22pF pero en el esquema puse un cristal de 500Khz. Ahora lleva un cristal de 16Mhz con dos condensadores de 22pF.
Los servos, en paralelo van directamente al pin del micro, no tienen etapa de potencia pero los motores cc si. Los dos derechos van en paralelo como los dos izquierdos. Te subo una captura del circuito.
Muchas gracias por todo. voy a montarlo y le haré una pruebas definitivas.
Eres catalan, valenciano o de las islas?
Si algun dia te puedo ayudar en algo me envias un correo.
GRACIAS.
Archivos Adjuntos
Tipo de Archivo: rar Control_Motors_cc.rar (10,4 KB (Kilobytes), 7 visitas)
26/03/2010 #11


Respuesta: ¿Qué le pasa mi robot?
En teoría, los servos llevan la etapa de potencia interna, por eso tienen los pines de alimentación.

La etapa de potencia que pones (una clásica entre las clásicas), ¿se alimenta de la misma batería que el control, o de la misma salida del regulado de 5V (recomendable lo primero, y totalmente prohibido lo segundo)?

El condensador se suele poner 'en serie' con la resistencia, o lo que es lo mismo, en paralelo con tu pulsador.

Som de ses illes, 'paisano' d'es gran Mestre Nadal...

Por cierto, me alegro que esto haya resuelto tus problemas.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.