Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/05/2014 #81


Hola quiero felicitar a todos los que han aportado a este tema, tambien estoy intentando hacer una matriz de le hice una de 8 x 56 pero tengo algunos inconveniente; me queda la tercera fila encendida levemente y no he podido hacer apagar tambien intente ponerle la hora con un ds1307 pero no he podido si me pueden dar una ayuda se los agradezco mucho lo desarrolle en pbp.
06/05/2014 #82

Avatar de tecniloco80

JOSE JAVIER BAEZ dijo: Ver Mensaje
,.........Solo me queda una duda, ¿como hago para que los caracteres sean en mayúsculas?. gracias
Para escribir en mayúsculas tienes que tener presionada la tecla mayúsculas o shift
25/07/2014 #83


JOSE JAVIER BAEZ dijo: Ver Mensaje
hola juanc08, este es el ex para remplazar el 16f716 por el 16f628, para el 18f452 tienes que utilizar el ex de tecniloco80... saludos
Gracias Jose, es factible que subas el archivo en ccs para ver las modificaciones plis

Gracias

Juka

---------- Actualizado después de 57 minutos ----------

Tecniloco80, muy bueno su trabajo, excelente, estoy en la face de simulacion todo bien hasta que marco el 1, marca cualquier cosa y luego se queda detenido, pasado un tiempo largo vuelve y lo hace (yo probe con el 12) que puede ser.

Ademas en proteus aparece dos pulsadores que en su main son los de reset y para mostra mensajes grabados (este ultimo falto conectar a negativo en el ares, verdad), estoy en lo correcto

Estare atento a sus respuestas

Juka
07/08/2014 #84


JOSE JAVIER BAEZ dijo: Ver Mensaje
hola juanc08, este es el ex para remplazar el 16f716 por el 16f628, para el 18f452 tienes que utilizar el ex de tecniloco80... saludos
buena tarde amigo , te consulto en la practica te funciono el codigo hex para el 16f628 o solo en proteus,no logro echarlo a andar
13/09/2014 #85


hola amigos, empece a hacer los pcb del amigo tecnilo80 ( que de paso se le agradece todo su ayuda), pero me encontré con el problema que no puedo conseguir el cristal de 19.63, por lo que he leído se puede cambiar el pic por 16f628 y cambiar el cristal por 20 M, alguien lo ha hecho y ha funcionado en practico o hay que hacer otra modificación.

Espero puedan responder

Taquino
13/09/2014 #86


hola para el pic 16f628 puedes usar un cristal de 20 mhz para que el oscilador funcione a frecuencias superiores a 4Mhz, debes elegir el oscilador del tipo HS. Si no lo haces, el pic no funcionará! porque no andará el oscilador esto lo he hecho en otros proyectos, no lo he probado en la matriz de del gran amigo tecniloco. Espero y te sirva
13/09/2014 #87


xavierymiriam dijo: Ver Mensaje
hola para el pic 16f628 puedes usar un cristal de 20 mhz para que el oscilador funcione a frecuencias superiores a 4Mhz, debes elegir el oscilador del tipo HS. Si no lo haces, el pic no funcionará! porque no andará el oscilador esto lo he hecho en otros proyectos, no lo he probado en la matriz de del gran amigo tecniloco. Espero y te sirva
Gracias, esto se refiere solo a la simulación verdad.

Alguien a hecho en fisico estos cambios

Talquino
14/09/2014 #88


Buenos dias!! Yo lo he hechos circuito real como no quiere dar el codigo hex por eso los deje abandonado y me decidi aprender atmel poco a poco por mi mismo. Saludos amigo!!!
14/09/2014 #89

Avatar de locodelafonola

Printpix dijo: Ver Mensaje
Buenos dias!! Yo lo he hechos circuito real como no quiere dar el codigo hex por eso los deje abandonado y me decidi aprender atmel poco a poco por mi mismo. Saludos amigo!!!
pues compañero creo que estas desorientado ...... esto es pic .. no atmel ( atmega ) .... ¿¿¿¿ y a que te refieres con que no comparten el codigo hex ???? de este montaje esta publicado y es accesible a todos los integrantes del foro .....
14/09/2014 #90


talquino2012 dijo: Ver Mensaje
Gracias, esto se refiere solo a la simulación verdad.

Alguien a hecho en fisico estos cambios

Talquino
hola amigo , yo monte este circuito con el 16f628 y el codigo hex para 20 megas y hasta ahora no logro que arranque , no me funciona , creo que el problema esta en los fuses ala hora de compilar, en proteus funciona, no he hecho practicas con los fuses en c, porque solo manejo proton,
14/09/2014 #91


locodelafonola dijo: Ver Mensaje
pues compañero creo que estas desorientado ...... esto es pic .. no atmel ( atmega ) .... ¿¿¿¿ y a que te refieres con que no comparten el codigo hex ???? de este montaje esta publicado y es accesible a todos los integrantes del foro .....
Hola! Entonce porque borro mi pregunta el tecniloco si solo estoy pidiendo un favor pues dejame checar bien y te comento apena estoy aprendiendo en atmel ninguno lo se el atmel ni el pic por eso me decidi estudiar. ya armaste y ha funcionado?Saludos!!!
14/09/2014 #92

Avatar de torres.electronico

juanc08 dijo: Ver Mensaje
hola amigo , yo monte este circuito con el 16f628 y el codigo hex para 20 megas y hasta ahora no logro que arranque , no me funciona , creo que el problema esta en los fuses ala hora de compilar, en proteus funciona, no he hecho practicas con los fuses en c, porque solo manejo proton,
Con que estas grabando? te fijaste si en software de la grabadora aparecen los fuses bien puestos? intentastes colocarlos manualmente? al final de grabar el micro, te sale correcta la verificacion?... tenes la resistencia del reset puesta? son muchos datos que te faltaron comentar... saludos
14/09/2014 #93


Hola torres estes aparatito me sirve para baja hex o tengo que ir como comenta el compañero de los fuse?te adjunto las foto.
Saludos!
Imágenes Adjuntas
Tipo de Archivo: jpg avr.jpg (307,0 KB (Kilobytes), 37 visitas)
14/09/2014 #94

Avatar de locodelafonola

Printpix dijo: Ver Mensaje
Hola! Entonce porque borro mi pregunta el tecniloco si solo estoy pidiendo un favor pues dejame checar bien y te comento apena estoy aprendiendo en atmel ninguno lo se el atmel ni el pic por eso me decidi estudiar. ya armaste y ha funcionado?Saludos!!!
aaaaa ver ..por empezar el amigo tecniloco .... no puede borrar nada ... seguro que tu mensaje fue eleiminado por el moderador ... .. y viendo este mensaje ..... es mas que claro que no leiste bien el post ...... y creo que hay demaciadas muestra que esto funciona ... en cuanto aque si lo arme ..bueno noes presisamente este montaje ...yo uso atmega ...y este es para pic ... que son cosas completamente distintas ..... pero funcionar !!!!!! funciona ¡¡¡¡¡¡¡¡¡¡ .... te recomiendo que estudies un poco mas ....... asi puedes encarar la construccion de el proyecto
14/09/2014 #95


Muy bien ya veremos y que compilacion estas aprendiendo?
14/09/2014 #96

Avatar de torres.electronico

Printpix dijo: Ver Mensaje
Hola torres estes aparatito me sirve para baja hex o tengo que ir como comenta el compañero de los fuse?te adjunto las foto.
Saludos!
tiene pinta a un clon de un mini pony... para saber si soporta tu dispositivo el pic este, desde el programa de control, tenes que ver si figura en gris o negro oscuro... si aparece en gris clarito, significa que no lo soporta (me paso con williems y ponys viejos)... Ahora, en el supiuesto caso en que tenemos soporte, fijate si en la seccion de fuses, estan marcados / seleccionados... si no estan puestos, se los colocas manualmente
16/09/2014 #97


Printpix dijo: Ver Mensaje
Buenos dias!! Yo lo he hechos circuito real como no quiere dar el codigo hex por eso los deje abandonado y me decidi aprender atmel poco a poco por mi mismo. Saludos amigo!!!
Estimado, el hex esta en la carpeta de tecniloco80, pero si aun lo necesitas lo subo, solo dilo
16/09/2014 #98


juanc08 dijo: Ver Mensaje
hola amigo , yo monte este circuito con el 16f628 y el codigo hex para 20 megas y hasta ahora no logro que arranque , no me funciona , creo que el problema esta en los fuses ala hora de compilar, en proteus funciona, no he hecho practicas con los fuses en c, porque solo manejo proton,
una consulta, cuales fueron tus modificaciones que realizastes, que error te arroja?

javier

---------- Actualizado después de 16 minutos ----------

Tecnilo80, una consulta estoy haciendo los cambios para el pic 16f628a, realice los cambios en el ccs, pero analizando el físico me encontré con lo siguiente

pin pic 16f716 pic 16f628a

pin 6 RB0/INT/ECCPASS2 RB0/INT
pin 8 RB2/T1OSI RB2/TX/CK
pin 9 RB3/CCP1/P1A RB3/CCP1

Se mantiene el orden de los pines o al cambiar el 716 por el 628a, debo cambiar el pin 8 por el pin 13 (RB7/T1OSI).

Espero agradecido su orientacion

Javier
17/09/2014 #99


jucaceledon dijo: Ver Mensaje
Estimado, el hex esta en la carpeta de tecniloco80, pero si aun lo necesitas lo subo, solo dilo
Permiteme ver los hex y dejame estudiar en que quedo ahora si empiezo a trabajar.
Saludos!!
22/09/2014 #100


juanc08 dijo: Ver Mensaje
buena tarde amigo , te consulto en la practica te funciono el codigo hex para el 16f628 o solo en proteus,no logro echarlo a andar
claro,,,,el la practica funciona muy bien, con el ex que te envié tienes que ver por alli puede estar algun problema, a mi me costo pero ya lo logre, saludos

---------- Actualizado después de 2 minutos ----------

talquino2012 dijo: Ver Mensaje
hola amigos, empece a hacer los pcb del amigo tecnilo80 ( que de paso se le agradece todo su ayuda), pero me encontré con el problema que no puedo conseguir el cristal de 19.63, por lo que he leído se puede cambiar el pic por 16f628 y cambiar el cristal por 20 M, alguien lo ha hecho y ha funcionado en practico o hay que hacer otra modificación.

Espero puedan responder

Taquino
nuestro amigo tecniloco80 lo explica muy bien, a mi me funciono sin problemas, cambiando el codigo donde dice tecniloco80 con el pic 16f628a. saludos

---------- Actualizado después de 4 minutos ----------

juanc08 dijo: Ver Mensaje
hola amigo , yo monte este circuito con el 16f628 y el codigo hex para 20 megas y hasta ahora no logro que arranque , no me funciona , creo que el problema esta en los fuses ala hora de compilar, en proteus funciona, no he hecho practicas con los fuses en c, porque solo manejo proton,
yo hice los cambios que recomienda tecniloco80 y funciona muy bien en la practica con el 16f628a , déjame reviso en estos dias que fue lo que cambien, y lo comparto. saludos

---------- Actualizado después de 3 minutos ----------

jucaceledon dijo: Ver Mensaje
Estimado, el hex esta en la carpeta de tecniloco80, pero si aun lo necesitas lo subo, solo dilo
creo que el amigo se refiere al codigo ex para el 16f628, yo ya lo subi solo revisen bien el foro

---------- Actualizado después de 3 minutos ----------

talquino2012 dijo: Ver Mensaje
una consulta, cuales fueron tus modificaciones que realizastes, que error te arroja?

javier

---------- Actualizado después de 16 minutos ----------

Tecnilo80, una consulta estoy haciendo los cambios para el pic 16f628a, realice los cambios en el ccs, pero analizando el físico me encontré con lo siguiente

pin pic 16f716 pic 16f628a

pin 6 RB0/INT/ECCPASS2 RB0/INT
pin 8 RB2/T1OSI RB2/TX/CK
pin 9 RB3/CCP1/P1A RB3/CCP1

Se mantiene el orden de los pines o al cambiar el 716 por el 628a, debo cambiar el pin 8 por el pin 13 (RB7/T1OSI).

Espero agradecido su orientacion

Javier
no tuve ningún error, ya paso un tiempo desde que me funciono perfectamente en la practica, tengo que volver a checar mis archivos para ver que cambios fue los que hice . ya lo comentare. ok
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.