Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

22/09/2014 #101


Gracias Jose por responder pero disculpa, lo que desprendo de tus comentarios es que solo cambias en el programa el nombre del pic y el clock, en la pcb no realizas ningun cambio, estoy en lo correcto, espero tus comentarios estoy en la etapa de comenzar las `pruebas.

Javier
18/10/2014 #102


Hola a todos!

Muy interesantes todos estos proyectos!
Sabríais decirme cómo lo plantearíais para que la matriz tuviera más de 8 filas? Digamos 16.
Se me ocurre usar un PIC con 8 pines más, pero ¿hay alguna otra forma de, usando ese mismo pic y solo 8 pines de salida para las filas, controlar un total de 16 filas?

Muchas gracias!
19/12/2014 #103


JOSE JAVIER BAEZ dijo: Ver Mensaje
hola juanc08, este es el ex para remplazar el 16f716 por el 16f628, para el 18f452 tienes que utilizar el ex de tecniloco80... saludos
hola amigo, disculpa que insista pero no logro echar a andar el proyecto , te consulto ala hora de compilar incluyes los fuses o los colocas en el programador, te hago la consulta porque yo programo con con pickit y no me da la opcion de colocar los fuses,
#fuses HS,NOWDT,NOPROTECT,NOPUT,NOBROWNOUT
#use Delay(Clock=16934400)
y veo que no aparece el reset , igualmente para el 18f452
20/12/2014 #104
Moderador

Avatar de D@rkbytes

juanc08 dijo: Ver Mensaje
¿A la hora de compilar incluyes los fuses o los colocas en el programador? Te hago la consulta porque yo programo con con pickit y no me da la opción de colocar los fuses.
#fuses HS,NOWDT,NOPROTECT,NOPUT,NOBROWNOUT
#use Delay(Clock=16934400)
Y veo que no aparece el reset, igualmente para el 18f452
Los programas ejecutables *.hex que mencionas ya tienen los fuses incluidos.
No sé cual sea el problema que tienes pero si es por algún problema con los fuses, deberías explicarlo.

Los fuses que tiene el archivo: MATRIZ LED 16F628 JB.hex, son éstos: Fuses 16F628A.jpg

16F628A con PICKit3: Fuses 16F628A PK3.jpg

Los fuses para el archivo BASE18.hex, son éstos: Fuses 18F452.jpg

18F452 con PICKit3: Fuses 18F452 PK3.jpg

No mencionas que versión de PICKit usas, pero las interfaces si permiten la edición de fuses.
20/12/2014 #105


D@rkbytes dijo: Ver Mensaje
Los programas ejecutables *.hex que mencionas ya tienen los fuses incluidos.
No sé cual sea el problema que tienes pero si es por algún problema con los fuses, deberías explicarlo.

Los fuses que tiene el archivo: MATRIZ LED 16F628 JB.hex, son éstos: Archivo Adjunto 122417

16F628A con PICKit3: Archivo Adjunto 122420

Los fuses para el archivo BASE18.hex, son éstos: Archivo Adjunto 122418

18F452 con PICKit3: Archivo Adjunto 122421

No mencionas que versión de PICKit usas, pero las interfaces si permiten la edición de fuses.
hola D@rkbytes, lo delos fuses era una duda, anteriormente me paso y ere el fuse del reset que no lo habia colocado off, cuando conecto el votaje y tecleo alguna letra no sale nada en la matris ,solo le he conectado una matris de 7x8, no se si tenga algo que ver con que no me funcione todavia , pero no paran las ganas de verlo funcionar, seguirebuscando la solucion, la version que uso es 2.61.00 de pickit 2 , y lo de las interfases no lo sabia, mil gracias por tu respuesta,
Imágenes Adjuntas
Tipo de Archivo: jpg DSC00677.jpg (147,2 KB (Kilobytes), 62 visitas)
17/02/2015 #106


Hola, juanc08. Disculpa por no responderte, hace ya algún tiempo que no reviso este foro.
¿Me gustaría saber si ya solucionaste tu problema?
18/02/2015 #107


JOSE JAVIER BAEZ dijo: Ver Mensaje
Hola, juanc08. Disculpa por no responderte, hace ya algún tiempo que no reviso este foro.
¿Me gustaría saber si ya solucionaste tu problema?
Gracias por responder, amigo José Javier.
La verdad, no he conseguido que funcione. He revisado varias veces el circuito y nada que arranca.
Al conectarlo al voltaje, simplemente no enciende ningún LED en la matríz.
23/02/2015 #108

Avatar de tecniloco80

juanc08 dijo: Ver Mensaje
no he conseguido que funcione. He revisado varias veces el circuito y nada que arranca.
Al conectarlo al voltaje, simplemente no enciende ningún LED en la matríz.
Lastima que no le funcione pero no se rinda a veces son fallas muy pequeñas las que causan estos problemas trate de probar el circuito por partes con un cable usb-r232 y el hyperterminal,
retire pic18f y conecte en el pin 26 el pin rx del cable rs232 presione el teclado mire si el 16f628 envía datos al hyperterminal si recibe los datos la falla no seria en el pic16 si no en el pic18
24/02/2015 #109


Ola solo tengo una duda, ¿si podría ponerle matices de 8*8 en vez de 7*5?. Y también ¿que comando podría utilizar para detener totalmente todas las letras a la vez?, muy buena aportación de 10.
17/03/2015 #110


juanc08 dijo: Ver Mensaje
Gracias por responder, amigo José Javier.
La verdad, no he conseguido que funcione. He revisado varias veces el circuito y nada que arranca.
Al conectarlo al voltaje, simplemente no enciende ningún LED en la matríz.
No te des por vencido, en cuanto pueda reviso mis apuntes, a mi tambien a la primera no funciono nada, revise y todo estaba bien, pero el circuito estaba muerto, empecé a mover todas las conexiones en el proto, y encontre un cable que no estaba haciendo contacto. Yo empecé, la practica solo con un display, cuando ya me funciono este, le agregue el resto.

---------- Actualizado después de 45 minutos ----------

juanc08 dijo: Ver Mensaje
Gracias por responder, amigo José Javier.
La verdad, no he conseguido que funcione. He revisado varias veces el circuito y nada que arranca.
Al conectarlo al voltaje, simplemente no enciende ningún LED en la matríz.
Otra cosa que tambien debes tener en cuenta es que la configuracion de bits, al grabar al pic 16f628a no es igual al 16f716.
Archivos Adjuntos
Tipo de Archivo: zip javier.zip (1,48 MB (Megabytes), 172 visitas)
30/03/2015 #111


gracias a todos los del foro por sus aportes en este tema, hoy he logrado echar a andar el circuito, esta a medias pero me con este animo lo acabare rapido cuando este terminado subire fotos nuevamente mil gracias
d@rkbytes , tecniloco80 , jose javier y demas integrantes del grupo
01/07/2016 #112


wow! juanc08 es fantástico
juanc08, en verdad pudiste echarlo a funcionar? , yo no lo he logrado ya que el código que me dio el amigo tecniloco no me funciono y me revolví con todos los comentarios que hacían los demás colegas respecto al código de ambos micros por favor juanc08 compartenos el código que usaste te lo agradeceremos bastaste
04/07/2016 #113


xavierymiriam dijo: Ver Mensaje
juanc08, en verdad pudiste echarlo a funcionar? , yo no lo he logrado ya que el código que me dio el amigo tecniloco no me funciono y me revolví con todos los comentarios que hacían los demás colegas respecto al código de ambos micros por favor juanc08 compartenos el código que usaste te lo agradeceremos bastaste
hola amigo xavierymiriam, de verdad me funciono , lo tuve funcionando en mi van escolar de hecho, los codigos que dan aqui estan bien ,ami de una no me salio pero con la ayuda de todos aqui lo logregiate con los diseños de proteus y todos los datos que estan aqui , segur funciona
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.