Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/06/2009 #1


No me graba Datos En EEprom del pic16f88
Hola amigos, espero me puedan dar ideas acerca de mi problema.....

resulta que tengo un programa que toma 2 datos de un teclado matricial 3x4 , lo almacena en La eeprom del pic 16f88, y de acuerdo a estos números, genera temporizaciones de encendido (primera tecla digitada) y de apagado (segunda tecla digitada). la primera vez que se usa el dispositivo, se lee la posición 0 de la eeprom y si vale 0ff(255) indica que no se ha grabado nunca y envia a una subrutina donde pide los datos del teclado para grabar las posiciones 0 y 1 de dicha memoria y luego envia a inicio apagando el dispositivo. cuando se reinicia el programa, deberia detectar dichos datos en la memoria y ya no pedir el ingreso de ellos pero siempre vuelve a pedirlos y se queda asi todo el tiempo.

ya intente grabar la posicion 0 con el icprog directamente, compre otro micro, utilice el winpic800, cambie el programador, y nada.

en la simulación con mplab y proteus hace lo que se desea pero al quemar el pic nada de nada.
la rutina de lectura y grabación de eeprom siempre me ha funcionado con otros pic, y solo es cortar y pegar como siempre.

será virus? en estos momentos estoy volviendo a instalar el mplab a ver que pasa? que mas puedo hacer?

anexo el asm por si acaso....

gracias

gracias
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.