Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?
01/01/2008 #21


Ciertamente el MCLR puede conectarse directamente a + sin problema alguno. Miento, con un problema. no puedes resetear el micro a través de la patilla.

El problema lo tienes en la conexión de alimentación o fuente como te han dicho (supuestamente)
Un conocido te pediría que lo consultases con un espiritista a ver si los pic estás malditos (escoña) Otro rezaría y enviaría donativos a todos los que forman este foro. Enviame el donativo a: donativosParaEstafar@estafa.es

Saludos y suerte
01/01/2008 #22


Gracias por vuestra ayuda, como todos sabeis cuando algo nos falla en un proyecto nos volvemos locos buscando los errores, y nos quebramos la cabeza intentando encontrarlo. Eso mismo me pasa a mi, y por mas que pruebo, lo desinstalo y lo vuelvo a instalar, comprobando cada conexion, cada patillaje, pero todo lo veo correcto.
Me encantaria que alguno de vosotros, si es posible, me podais mandar algun esquema electrico de una secuencia como esa, realizada con un pic, ya sea el que sea, y tambien a ser posible le programa comprobado y verificado en asm o hex para poder cargarlo en el pic, y montarlo y comprobarlo.
Se lo agradeceria enormemente.
Creo que lo proximo que hare sera hacer el circuito en pcb, pasarlo a placa y montarlo y soldarlo, con un estabilizador 7805 y como fuente de alimentacion una pila de 9 voltios.
Asi sabre que es lo que me falla, no lo hago en la protoboard porque tampoco me fio de que se me vuelva a joder el ultimo pic que me queda vivo.

Espero recibir su opinion.
01/01/2008 #23
Moderador general

Avatar de Fogonazo

Yo antes del suicidio haria lo siguiente con un PIC difunto:

1) Medir que tension tiene cada pata del IC, anotar
2) Retirar el IC
3) Medir que corriente circularia por el IC si estubiera colocado (Multimetro en mA), claro esta que la excepcion serian la alimentacion y las patas conectadas a +VCC, sino, tambien te cargaras un multimetro.
4) Ver que pasa en el momento de aplicar tension, no sea que tengas una circulacion de corriente indebida solo en ese momento, por ejemplo algun electrolitico que se cargue a travez del PIC.


Si todo esto tampoco resulta, manda unos $$$ a:

donativosParaEstafar@estafa.es

Para que le recen a los dioses de los PIC´S
01/01/2008 #24


Creo chicos que lo que hare con los pobrecicos pics sera irme al parque mas cercano, hacer unos agujericos en el cesped, a cada uno, uno y enterrarlos alli, despues colocarles una cruz, y en su lapida escribir....." Lastima que acabaseis en vuestro puesto de trabajo."

En fin, no hay solucion para ellos.
01/01/2008 #25
Moderador general

Avatar de Fogonazo

Confucio diria: Si no los puedes vencer, entierralos con dignidad !
01/01/2008 #26


No los tires, no sea alguna tonteria.

Si quieres intentar resucitarlos y ya los das por muertos, prueba de hornearlos, sisisi, habia un integrado antiguo (muyyy caro) que se reparaba horneandolo a unos 300ºC unos minutos.

Siempre cuesta arrancar con cualquier pieza nueva.

En la patilla reset mejor poner una resistencia, si tienes el watchdog activado te puede dar problemas. ya que hay un transistor que la pone a masa,
01/01/2008 #27

Avatar de anthony123

mmmm por que no usas un programador confiable?¿?
01/01/2008 #28
Moderador general

Avatar de Fogonazo

Bueno, ironia al margen yo tampoco los tiraria, no sea cosa que tengas un error de lectura con el programador y vallan a estar sanos.

Tio, Con lo del horno me dejaste estupefacto no lo habia escuchado nunca, tiene su logica, rara pero logica al fin.
01/01/2008 #29

Avatar de anthony123

Creo que deberias, en vez de gastar en comprar otros PIC's, comprar una placa virgen, un bote de acido y buscar los millones de testimonios de programadores que hay en el foroy tomar su esquema y PCB y ahorrarte ese monton de cables que podrian ser el origen de tu problem
01/01/2008 #30


Jajaja , me parece bien el comentario del horno. Tambien, podrias ver si los incineras como digno funeral, para luego enterrarlos.

Reza "De polvo de silicio eres, y en polvo de silicio te convertiras", como homenaje a su humilde y breve existencia... luego entierralos en la arena silice.

Esta clase de cosas nos ocurren a todos. Usualmente, lo que ocurre es que a menudo nos convencemos de que las cosas estan perfectamente bien, y convencidos de que todo anda bien, ovbiamos aquellos detalles que son menores pero muy importantes, que son precisamente la causa del problema.

Descarta que las conexiones estan bien, que la fuente esta bien, que el esquematico esta bien, descarta que ese cable verde recien cortado esta bueno, no creas en que el nodo de tierra que usas en la protoboard conduce bien, ni creas que la protoboard tiene sus rieles longitudinales (los mas largos) unidos en el centro... es decir, bota tus barreras mentales, si piensas que algo estaba bien, mejor revisalo de nuevo. Solo asi tendrias una oportunidad de allar eso que esta mal.

Saludos.
01/01/2008 #31

Avatar de pepechip

El comentario de Tiopepe123 sobre el horno, no es ninguna tonteria.
Hay un integrado empleado en televisores que se repara calentandolo con el soldador durante varios minutos.
01/01/2008 #32

Avatar de anthony123

Quizas la cosa sea como dice Fogonazo, un errorsito en el programador y nosotros diciendole que le meta candela :mrgreen:
01/01/2008 #33


Aun cuando nunca habia visto que fuera posible reparar un componente por medio de calentarlo excesivamente, pense que se trataba de alguna broma. Las discupas del caso sean entonces.

Sera que con el tiempo esos chips de televisores se deterioran internamente a causa de el continuo cambio de temperatura, y que la recalentadita le "asienta" sus uniones internas? Quiza sea algo similar a las soldaduras quebrantadas donde con derretirlas de nuevo se arreglan?

Mas sin embargo volviendo al montaje presentado, propongo el motivo por el que no funciona debe ser el siguiente: Se esta pasando por alto algo muy sencillo, aunque evidentemente es poco obvio, debe ser motivo suficiente para que los PIC se quemen.
01/01/2008 #34


Hola, estuve mirando el foro y realmente me parece raro que te este pasando eso, yo te recomendaría que si los pic no te ponene en corto la fuente no los tires, prueba con toro programa más sencillo, el de prender y apagar un solo LED por ejemplo.

Por que no quitas el capacitor de 10 uF de MCLR, yo nunca lo he usado y todo me funciona de maravilla las resistencias puedes bajarlas a 220R y no pasa nada y para descartar probelmas de fuente usa un regulador 7805 y una pila de 9 voltios, con eso sales de dudas.

De todas formas no te rindas debe ser una tontería, que sin animo de burlarme te ha salido bastante costosa, te recomendaría que te asesoraras de alguien con más experiencia para que te ayude.

En mi pagina puedes encontrar el codigo para algunos proyectos sencillos y los planos para que los montes asi que animo.

SUERTE.
02/01/2008 #35


Tiopepe123
Me gustaria que me facilitaras la información del MCLR donde dice que algo lo pone a masa.
te he pegado un esquema del datasheet del ciruito y no logro verlo.

Ciertamente se te ha ido la mano
Imágenes Adjuntas
Tipo de Archivo: jpg reset_207.jpg (38,7 KB (Kilobytes), 183 visitas)
02/01/2008 #36


Chicos me parece que el problema lo tengo en la fuente de alimentacion, no lo he llegado a comprobar, pues no tengo a mano un polimetro tester, de esos que eran analogicos, pues quizas al conectar la fuente, pulsar el interruptor, quizas le meta un pico de tension al pic y sea la causa del desastre, pero es que me da miedo conectar una pila de 9v y un 7805 por si me vuelvo a cargar otro pic.
02/01/2008 #37

Avatar de anthony123

Recuerda que los 7805 son de facil conexion y funciona siempre a la primera, ademas vas a tener que tomarte un cafecito de paciencia y esperar hasta que consigas un buen multimetro
02/01/2008 #38


tiopepe123 dijo:
No los tires, no sea alguna tonteria.

Si quieres intentar resucitarlos y ya los das por muertos, prueba de hornearlos, sisisi, habia un integrado antiguo (muyyy caro) que se reparaba horneandolo a unos 300ºC unos minutos.

Siempre cuesta arrancar con cualquier pieza nueva.

En la patilla reset mejor poner una resistencia, si tienes el watchdog activado te puede dar problemas. ya que hay un transistor que la pone a masa,
El nombre dijo:
Tiopepe123
Me gustaria que me facilitaras la información del MCLR donde dice que algo lo pone a masa.
te he pegado un esquema del datasheet del ciruito y no logro verlo.

Ciertamente se te ha ido la mano
Me temo que en este sentido ha habido una pequeña confusion.

Lo que ocurre es que el PIC puede "resetearse" a si mismo bajo ciertas circunstancias (como cuando hay sobreflujo en el WDT). Eso hace imaginar a algunos, que el PIC cuenta con un transistor que le permite poner en bajo su linea de MCLR para dicho cometido.

En realidad, en el esquema de RESET publicado por El nombre se mira claramente que hay una serie de elementos logicos que permiten que en el PIC se produzca un reset por diversas fuentes, y, como el lo menciona, no hay ningun transistor.

La entrada de MCLR es una entrada solamente, el poseer un transistor lo convertiria en una salida de colector (o mas bien drenador) abierto. Bajo condiciones de operacion normal, puede ser tratada sin mayor problema como una entrada CMOS y puede colocarse a positivo directamente, o a traves de una resistencia a positivo, colocarsele un switch, colocarle circuitos digitales que provoquen el reset segun las necesidades del diseño, etc.

Saludos.
03/01/2008 #39


les comento rapidamente la experiencia de mi hermano,

empezo a trabajar con el PIC18F2550 con muy poca experiencia previa en micros, por simplificar conexiones conectaba el /MCLR directo a 5V. El programa funcionaba unos minutos, el micro se sobrecalentaba y se quemaba, no se podia leer ni escribir posteriormente.

Asi quemos varios PIC (creo que 5)... y me pregunto que cual podria ser el problema, me mando el esquematico que tenia, y el pin de /MCLR lo tenia directo a 5V, le dije ponle una resistencia de 10K a 5V y desde ahi dejo de tener el problema.

Casi no trabajo con PIC, casi solo trabajo con AVR y siempre coloco dicha resistencia...
Aunque es cierto, en apariencia a partir de datasheet no seria necesario ponerla.
03/01/2008 #40


ME COLE!, grccias Hombre

recordaba de memoria esta pagina y en su momento me dio problemas y como vi que todos ponian la resistencia de marras, pues uno no esta para hacer pruebas por una simple resistencia.

Un saludo a todos.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.