Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

16/02/2008 #1
Visitante


No me muestra nada el LCD
¡¡Hola a todos! Os escribo porque me ha surgido el siguiente problema con un trabajo de clase, os comento: Estoy realizando un termostato, y ya tengo escrito el código y probado en el Proteus. En la simulación va correctamente, bueno el único fallo que tengo que al poner los pulsadores a la entrada del pic, el programa se vuelve loco y pasa ntre las distintas funciones que tenie. Bien,una vez grabado el .hex al Pic me surge mi problema, que es que el LCD se que en negro la primera linea de caracteres, sin mostrarme ninguno de los mensajes que tiene el código. El LCD lo he probado con otros pic de compañeros de clase y si funciona, y el pic lo he probado con LCD de otros compañeros y ocurre lo mismo, por lo que creo que el problema es del LCD ya que lo he probado en circuitos de mis compañeros. El pic si que manda señal, ya que le he conectado al puerto de salida de datos que va al LCD unos Led´s y se ve como varían, y el puerto que va conectado al controlador del lcd, (E,RS,RW) también varían. Para controlar el LCD empleo RB0,RB1,RB2, y para mandar los datos empleo el puerto D. Aquí les dejo una foto de como actúa el LCD. Un saludo y gracias por las molestias.
16/02/2008 #2


deberias fijarte en el oscilador si es externo. de ser interno fijate en la configuracion del mismo. esto me sucedio una vez que tenia el oscilador dañado
verifica y me cuentas
chao
17/02/2008 #3


jhonjjtr tiene razon, el display es un elemento leeeento, ponle unos cuantos delay para solucionar el problema.
Simplemente no se te inicializa bien, te van a meter una multa por ir a demasiada velocidad.

Metele nop o delay
17/02/2008 #4

Avatar de capitanp

ese display esta frito
17/02/2008 #5
Visitante


No me muestra nada el LCD
Gracias por vuestras respuestas, el oscilador es externo, ya que uso un cristal de 4Mhz, así que probaré lo de los delays,el delay que me viene en la librería que empleo es de 20 ms. Intentaré darle mas tiempo.
Referente a que el LCD esta frito, el LCD funciona perfectamente con el programa de otro compañero mio, así que ese no creo que sea el problema. Un saludo y gracias de nuevo.
17/02/2008 #6


Lo bueno sería que subieses el programa ya que tienes que inicializar el LCD y demas.

Aquí te dejo una rutinas del manejo que van bien. (revisa las conexiones para ver que las tienes como de debe) Tienen que coincidir.
Archivos Adjuntos
Tipo de Archivo: rar contllcd_190.rar (3,4 KB (Kilobytes), 107 visitas)
18/02/2008 #7
Visitante


No me muestra nada el LCD
Gracias a todos por vuestra ayuda y sobretodo a jhonjjtr que tenia razón, el problema era debido a que el oscilador que me programaba el Mplab era el RC mientras que yo usaba el XT, una vez cambiado esto en el .hex, ya funciona bien el LCD. Por lo que gracias a todos por vuestra ayuda y un saludo.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.