Haz una pregunta
  Foros de Electrˇnica » Dise˝o digital » Microcontroladores y sistemas embebidos
Foros Registrarse ┐Olvidaste tu contrase˝a?

Temas similares

06/04/2007 #1


nose que le pasa a mi pic 16f84a...
wenas,la verdad soy nuevo en esto de los pic┤s y bueno tengo un peque˝o problema con mi PIC 16F84A y el icprog 1.05E.

cuando lo programo: bien
pero cuando lo mando a leer el pic me muestra algo raro despues de recien programado

0000: 0003 0002 0003 0000 0002 0000 0003 0001 ........
0008: 0003 0003 0003 0003 0003 0003 0003 0003 ........
0010: 000F 000F 000F 000F 000F 000F 000F 0009 ........
0018: 000F 000F 000F 000F 000F 000F 000F 000F ........
0020: 000F 000F 000F 000F 000F 000F 000F 0009 ........
0028: 000F 000F 000F 000F 000F 000F 000F 000F ........
0030: 000F 000F 000F 000F 000F 000F 000F 0009 ........
0038: 000F 000F 000F 000F 000F 000F 000F 000F ........
0040: 000F 000F 000F 000F 000F 000F 000F 0009 ........
0048: 000F 000F 000F 000F 000F 000F 000F 000F ........
0050: 000F 000F 000F 000F 000F 000F 000F 0009 ........
0058: 000F 000F 000F 000F 000F 000F 000F 000F ........

y cuando lo pruebo en elcircuito de pruebas no hace nada de nada....


por ejemplo le mando a programar este que es fascil:
los nibles bajos se apagan y los altos se encienden "del puerto B"

0000: 1683 0186 1283 30F0 0086 2804 3FFF 3FFF âćâ­ć.  
0008: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0010: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0018: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0020: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0028: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0030: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0038: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
...

y no hace ni pio.

despues lo borro todo, y le doy leer y si ya parece ser borrado


0000: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0008: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0010: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0018: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0020: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0028: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0030: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
0038: 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF 3FFF         
...


y ya le he medido los voltajes a mi programador de pic TS_20SE.
tanto el "socalo de 18pines" sin el pic, y con el pic. y todo esta bien.
Y me base en estas tablitas que adjunte,
muy efectivas ademas, lautilice despues de terminado mi programador de pic
y si fue muy acertadola verdad
07/04/2007 #2


Mira, yo tuve el mismo problema, con un ProPic II, la falla la tenia en el circuito, me volvio loco, pero tenia un 74ls04 funcionando mal, con lo que la se˝al de CLK usando el ICProg no estaba presente. Se paciente y revisa los componentes ya que estas usando un JDM (T0-20SE), si bien es comodo, no es muy fiable.

Saludos.
07/04/2007 #3


A bueno gracias; ya lo probe en otra compu y pasa lo mismo, asi que voy a tener q hacerme otro grabador de pics.... tambien porsi las moscas, aunque los primeros programas si me funcionaron al pelo todo bien.... pero es mejor tener otra opcion a la mano.

Yo creo que voy a tener que comprar otro pic porque fue una vez q lo conecte mal en el circuito de pruebas para unos leds. Le conecte un pin mas arriba; es decir; donde debia ir
el pin4(vpp/mclr) conecte pin5(vss), y donde debia ir pin14(vdd) le meti el pin13(Rb7);
me di cuenta por la fuente que estava utilizando, normalmente led verde y si pasa algo "un corto" encende un led Rojo, casi 2seg despues de haber encendido la fuente fue que me di cuenta; ya que mire los led y nada de inmediato apague la fuente. Pero creo fue demasiado tarde.
Sin embargo el pic funciono despues de esto; y luego con otro programa que grabe si note que le acercaba la mano o el dedo y si funcionaba, no funcionaba.... le coloque un cap 104 entre masa o tierra y vpp, y una R=10K entre la funte de 5V y el pin 4(vpp).
pero ya no jala nda de nada...
y bueno creo que me lo tire, pero es de verdad una lastima ya estaba emocionado haciendo y demas...
Y si alguien le paso algo asi que me comente.....
hay estan
Imßgenes Adjuntas
Tipo de Archivo: gif pic16f84a_modificacion_653.gif (12,1 KB (Kilobytes), 335 visitas)
07/04/2007 #4


A bueno gracias; ya lo probe en otra compu y pasa lo mismo, asi que voy a tener q hacerme otro grabador de pics.... tambien porsi las moscas, aunque los primeros programas si me funcionaron al pelo todo bien.... pero es mejor tener otra opcion a la mano.

Yo creo que voy a tener que comprar otro pic porque fue una vez q lo conecte mal en el circuito de pruebas para unos leds. Le conecte un pin mas arriba; es decir; donde debia ir
el pin4(vpp/mclr) conecte pin5(vss), y donde debia ir pin14(vdd) le meti el pin13(Rb7);
me di cuenta por la fuente que estava utilizando, normalmente led verde y si pasa algo "un corto" encende un led Rojo, casi 2seg despues de haber encendido la fuente fue que me di cuenta; ya que mire los led y nada de inmediato apague la fuente. Pero creo fue demasiado tarde.
Sin embargo el pic funciono despues de esto; y luego con otro programa que grabe si note que le acercaba la mano o el dedo y si funcionaba, no funcionaba.... le coloque un cap 104 entre masa o tierra y vpp, y una R=10K entre la funte de 5V y el pin 4(vpp).
pero ya no jala nda de nada...
y bueno creo que me lo tire, pero es de verdad una lastima ya estaba emocionado haciendo y demas...
Y si alguien le paso algo asi que me comente.....
hay estan
Imßgenes Adjuntas
Tipo de Archivo: gif creo_q_lo_mande_a_la_dick_192.gif (12,2 KB (Kilobytes), 335 visitas)
Tipo de Archivo: gif pic16f84a_modificacion_624.gif (12,1 KB (Kilobytes), 334 visitas)
Respuesta
┐Tienes una mejor respuesta a este tema? ┐Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrˇnica » Dise˝o digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.