Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

17/06/2008 #1


PIC 16F876A: Error de verificación
Estoy montando en una protoboard el programador JDM (fullcustom) y aparentemente, sí lo lee o borro todo con el ICPROG no da ningún error, tampoco si lo verifico en blanco, pero en el momento en que intento programar algo, me da error de verificación... "Verificación falló en la dirección de codigo 0000h !"

He leído bastantes páginas en busca de alguna solución, pero ninguna ha resuelto mi problema, así que he llegado a la conclusión de que mi circuito está mal diseñado o el puerto serie no envía el voltaje suficiente.

Os dejo los dos diseños, a ver si alguien ve algo que yo no veo (mi diseño es el segundo).

Muchas gracias de antemano y saludos!

PD: Muy buena la comunidad.


17/06/2008 #2
Visitante


Si cuando programas el micro tiene habilitada la opción CP (code protection) en los bits de configuracion, el IC-prog no podrá verificar los datos grabados y te dará ese error.

Saludos.
17/06/2008 #3


Sí, eso ya lo estuve leyendo, pero gracias de todas maneras.
18/06/2008 #4


TO020 / JDM MOD

Je!, tipico error por tener un nivel de tensión VPP por debajo de lo esperado.
18/06/2008 #5


Hola de nuevo...

Esta mañana decidí montar el programador Pablin 2 Reloaded, utilizando un transformador de 12V 500mA.

Al principio todo aparentaba que funcionaba correctamente, ya que cuando leía el PIC o "escribía" en él el LED rojo se encendía, pero cuando llegaba a la verificación del código...

"Verificación falló en la dirección de codigo 0000h !"

Volvemos a lo mismo... revisé el circuito, estaba bien, lo desmonté y lo volví a montar muy lentamente para asegurarme de que todo era correcto y volví a probarlo, pero me seguía dando error.

Encontré un transformador de 12V 1.3A y se lo puse, noté como "parpadeaba" el LED de encendido y empezó a salir humo... creía que era del condensador pero toque el regulador (7805) y me quemé... xd y bueno... mientras escribía esto me di cuenta de que en el transformador ponía "12V ~ 1.3A", de ahí que el LED parpadease (solo ciclos positivos) y de que el 7805 echase humo...

Ya llevo dos intentos fallidos, ¿me aconsejáis otro programador aparte del JDM y del ProPic/Pablin? Aparte del 7805, ¿creéis que me habré cargado también el PIC?
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.