Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

15/03/2014 #1


Ayuda PIC16F1829 y fototransistor.
Muy buenas, el problema es bien sencillo, pero no sé cómo resolverlo.

Estoy intentando hacer que funcione un opto-switch conectando un fototransistor a un pin del micro. El esquema sería el siguiente:

PIN ------> FotoTransistor------> GND.

Como tengo el pull-up resistor activado con esto solo sería suficiente. O al menos eso creo yo.

Por último, programo el micro para que me detecte solamente las subidas de tensión (rising edge).

El circuito funciona, solo que tiene el problema de que me detecta tanto las subidas de tensión, como las bajadas de tensión, y es un problema del circuito, ya que he hecho varias comprobaciones y he descartado la programación en el micro.

Al parecer la bajada no la hace limpia y debe de haber un pico de subida que haga que el micro la detecte como subida. Menuda paranoia tengo.

Asi que creo que el problema está en el esquema.

Alguien sabría decirme como solucionar esto????
15/03/2014 #2
Moderador general

Avatar de DOSMETROS

Picando en mas opciones subí el diagrama y al código
15/03/2014 #3


El pull up de cuanto es? Se puede usar tanto en entrada como en salida, aunque la salida muchas veces viene en CMOS o TTL, que ya te fija los 2 estados sin necesidad de pullup.

Si querés aprovechar esa R para no ocupar espacio ni gastar plata, lo podés hacer, pero tiene un valor fijo y el circuito de salida (optoacoplador) lo vas a tener que adaptar a la corriente y todo eso.
15/03/2014 #4


Antes de nada, gracias por la repuesta.

He conseguido saltarme el problema utilizando una instruccion en el micro, pero el problema lo sigo teniendo. Pero por ahora me vale.

Ahora bien, el pull up resistor no se que valor tiene, ya que forma parte del micro y se puede activar y desactivar. Pero el valor debe ser bajo, ya que la tensión a la salida del pin(que está configurado en entrada) es VCC.

Es un poco raro, ya que si quito el fototransistor y le pongo un interruptor, todo va perfectamente.

Utilice este método ya que era una posibilidad que te ofrece el micro y ahorras en componentes y en placa, pero parece ser que no va del todo bien, así que utilizaré el método convencional de toda la vida, que sé que funciona.

Saludos.
16/03/2014 #5

Avatar de Daniel Meza

Pon tu circuito, puede ocurrir que el fototransistor no "sature" bien y el voltaje VCE sea mayor al rango de cero lógico para el micro dando esas lecturas erróneas.
16/03/2014 #6

Avatar de Gudino Roberto duberlin

Hola el comentario de Daniel es muy razonable, quizás el fototransistor está conectado al revés o la resistencia pull tiene un valor bajo para ésta condición. Chequea con multímetro los valores altos y bajos que lees en dicha entrada.
16/03/2014 #7


No entiendo. Si es un fototransistor tiene que ir en una entrada, pero aquí parece que se habla de salida.
¿Por que no publican el circuito? ¿Les cuesta? 2M te lo pidió.
17/03/2014 #8


Perdonar, el esquema no lo subí antes, ya que parecía muy simple. Ya lo he subido.

Ahora que lo pienso, creo que tenéis toda la razón en cuanto a que el fototransistor no satura. En cuanto tenga un poquito de tiempo voy a comprobar los valores, ya que tiene que ser eso, en vez de lo que yo decía.

En todo caso, como es un Opto-switch, lo único que tendría que hacer sería bajarle el valor a la resistencia del LED para que el fototransistor llegue a saturarse del todo.

Ya os diré algo.
Imágenes Adjuntas
Tipo de Archivo: jpg esquema.jpg (158,9 KB (Kilobytes), 23 visitas)
17/03/2014 #9


Entonces tendrías que haber dicho : optoacoplador, no fototransistor, porque se supone que el fototransistor es un componente del mismo. Y si, hay que ver que resistencia lleva el led para que encienda lo suficiente. Yo con 5 V uso 330 ohms.
17/03/2014 #10

Avatar de Daniel Meza

Según la hoja de datos del OPB660 la corriente IF del emisor común es de 10mA y su caida máxima en el diodo es de 1.6 volts. Con un poco de matemáticas:

R=(Vcc-Vd)/In=(5-1.6)/0.01=340 ohms, o bien como te dice el amigo aquileslor una R de 330 ohms garantizará la circulación de 10mA. Saludos
17/03/2014 #11


Ok, muchas gracias. Esto ya funciona.

Ahora entiendo un poco mejor algunos de los datos que vienen en la hoja de especificaciones.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.