Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

01/04/2010 #1


PIC16F877A no arranca
Hola, tengo un problema con el PIC16F877A, mi programa funciona perfectamente cuando lo simulo en proteus, sin embargo en el protoboard, no pasa absolutamente nada, todo está conectado y alimentado correctamente, uso un cristal de 4MHz. ¿Estoy omitiendo algun pin que deba conectarse MCLR, Vss algo?, ¿Debo agregar alguna etiqueta extra en mi programación en PICBasic?

cmcon=7
adcon1=6

Saludos
01/04/2010 #2

Avatar de garzon

Respuesta: PIC16F877A no arranca
Queria preguntar si sabes utilizar mplab para programar el pic16f877a
01/04/2010 #3


Respuesta: PIC16F877A no arranca
No, no se programar en mplab. Yo programo en MicroCode Studio
01/04/2010 #4

Avatar de garzon

Respuesta: PIC16F877A no arranca
Ahh ok gracias pues es quetengo que hacer algo en mplab y no se con ese pic
01/04/2010 #5

Avatar de pepechip

Respuesta: PIC16F877A no arranca
hola
revisa en las directivas del pic, y comprueba que realmente esta configurado para trabajar con oscilador a cristal, ya que en la simulacion este dato no se tiene encuenta.
02/04/2010 #6

Avatar de ByAxel

Respuesta: PIC16F877A no arranca
Si, es probable que necesites configurar los FUSES manualmente, creo que lo deja el LVP y el DEBUG activo cosa que no le deja arrancar bien al PIC.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.