Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

06/10/2008 #1


Problema al enviar datos con modulo tws 433 y pic
hola gente como estan?
yo aca me encuentro trabajando en el desarrollo de un control remoto con un modulo tws 433 y un rws 433 (módulos rf que trabajan a 433 Mhz) y me encontre con un problema al armar el control remoto, que paso a contarles ....

[/b]todo armado en protoboard, transmisor y receptor a una distancia de unos 20 cm me funciona de maravillas!! pero al montar el control remoto y alejar el transmisor del receptor comiensan los problemas[/b], hasta los dos o tres metros funciona bien pero... a mayor distancia no me funciona, lei que estos modulos (tws 433 y rws 433) trabajan muy bien con unos integrados HT12E y HT12D, los cuales estoy intentando reemplazar con el pic. estoy pensando en comprar estos integrados y medir el ancho de los pulsos del transmisor para copiarlos con el pic.

el pic con el que me encuentro trabajando es un 12f629 y con oscilador interno (no creo que sea necesario un oscilador externo) total si la variacion del pulso de salida se puede compensar por medio de codigo en el receptor.

aca les paso un fragmento del codigo que utilise para transmitir los pulsos y en el receptor recibo con pulsin:

high pin_rf ' envio un pulso alto
pauseus 1000 ' pausa de 1000 us
low pin_rf ' envio un pulso bajo para separar los pulsos que recibo con el comando pulsin
pauseus 50 ' pausa de 50 us
high pin_rf ' envio un pulso alto
pauseus 500 ' pausa de 500 us
low pin_rf
pauseus 50

en el receptor recibo con el comando pulsin (pulsin pin_receptor,1,B0) los pulsos altos y los decodifico si recibo un alto con una pausa de 1000 lo tomo como un 1 logico y si es de 500 lo tomo como un 0 logico, esto es en teoria, ya que los valores recibidos realmente a una distancia menor de 3 metros oscilan:
para el pulso enviado de 1000 se recibe eproximadamente entre 400 y 500
para el pulso enviado de 500 se recibe eproximadamente entre 200 y 300

y al alejarme los valores que recibe se reducen por ejemplo:
envio distancia recibo
1000 menos 3 mts entre 400 y 500
1000 5 mts entre 300 y 400
1000 7 mts entre 200 y 400


y si apunto para otro lado los valores se reducen sin importar tanto la distancia.

en el receptor coloque un cable de unos 15 cm para que trabaje de antena y en el transmisor coloque un cable de unos 15 cm tambien como antena y funciona bien, pero... un control remoto tipo llavero con un cable de 15 cm como antena no quedaria bien jajajaja . y aparte estos trasmisores no necesitarian antena alguna y tendrian que transmitir unos 100 mts.

bueno gente agradesco cualquier ayuda que me puedan dar. un abrazo ramon


09/10/2008 #2


Mira, no se bien cual puede ser tu problema, pero yo hice un control remoto de 24 teclas con esos modulos, los ht12 y un pic, y funcionan bien. ahora con antena nunca llegue mas alla de los 30 mts. y sin antena no pasa los 4mts. Y una cosa mala que tienen es que en determinada posicion de la antena del transmisor, el receptor no recibe ni a palos, es decir solo a un metro o dos, osea es bastante direccional por la frecuencia que trabaja. Solo escribi para decirte que funciona pero no esperes maravillas como los 100 mts.
Si queres tener mas alcance y transmitir sin antena, podes usar los circuitos de transmision de llaveros de alarma. eso si, trasmiten a cualquier frecuencia y a veces suelen irse de sintonia, pero llegan mas lejos (50 mts.) Tambien hay unos modulos de esa frecuencia pero que tranmiten a 500mw (los otros son de 80mw por norma), segun el fabricante llegan a 800 metros (ponele 100mts. si no miente mucho) si te interesan busca en la pagina de cika argentina, en el catalogo en pdf lo podes ver. Saludos y suerte
10/10/2008 #3


gracias por la pronta respuesta y entonces me esta funcionando de maravillas! es decir no tengo el resultado que esperaba pero... esta funcionando bien.

vos me decias que con una antena llegaste a los 30 mts que usaste una antena telescopica o una antena hecha con un alambre de cobre bañado y arrollada? de unos 16 cm que es el tamaño que tendria que tener dicha antena y probaste con un amplificador de rf? es decir algun transistor para darle mas power de salida?

gracias devuelta por la repuesta
10/10/2008 #4


Con respecto a la antena del control remoto, simplemente use use un cable de 16 cm sin ennrrollar,(probe ennrrollandola como espesifican pero fue lo mismo), haciendo una u en el control remoto, si queres podes probar con antenas para esa frecuencia que son las del tipo placa de red inalambrica. Muy vistosas pero salen 20 U$D, y no he probado su eficacia. No use amplificador porque para el uso que necesitaba me sobraba con 20 mts.Saludos y suerte
10/10/2008 #5


oka gracias por la información y vos que me recomendarias hacer?
te cuento es un control remoto para una alarma de auto lo que estoy desarrollando y el tamaño del control es reducido digamos de unos 3cm x 6cm que me recomendarias hacer? ya que es mi primer proyecto en lo que respecta a RF y se me esta complicando el asunto jajaja y ya llevo dos semanas de lucha con esto

con el cable de 16 cm probe y va bien ya que esa es la medida de antena para esa frecuencia y tambien probe con un alambre aislado de 16 cm con nucleo de aire de unos 6 mm y mejoro pero... en un control remoto de auto no se usan esas antenas jaja

te agradesco cualquier aporte que hagas

y si me recomiendas un amplificador osea un transistor te lo agradesco

saludos ramon
10/10/2008 #6


ok, si lo que queres hacer es una alarma para auto, usa un transmisor de alarma casero, hay muchos por internet, combinado con un um3750, con el cual le das una clave unica a la transmision (12 bit). si queres enviar mas de un codigo usa, el ht12 e/d, que tiene un direccionamineto de 8 bit (clave fija) y una palabra de 4 bit (codigo 0001,0011, etc) configurable con el teclado que hagas. los modulos rsw y tws son buenos, pero requieren antena. Saludos Mario. cualquier cosa consulta. Este fin de semana no estoy asi que te contesto el martes. suerte
15/10/2008 #7

Avatar de gzaloprgm

Seguramente ya habrás solucionado tu problema, pero ahora que lo veo creo que sé donde está el error:

Estos módulos que modulan en una frecuencia de 433MHZ mandan COMO MÁXIMO teórico 9600bps (en la práctica deben llegar a un poco menos)

Haciendo cálculos queda que para mandar a 9600bps se necesitan 0.10 ms / bit, por lo que si envias un pulso más angosto que 100 us lo más probable es que no se reciba.

Espero que te ayude,
Saludos,
Gonzalo
25/11/2008 #8


Problemas con Ht-12 E/F
Buenas amigo...

He trabajado con los modulos Rf (TLP 315a y RLP 315a) y los code y decoder Holtek HT-12E y HT-12F. Los estoy usando para manejar un tanquecito que he construido..

hice las pruebas de alcance y logre una distancia mayor a 150mts, use una bateria de 9v (de las cuadradas) para alimentar el modulo TX-RF y el code HT-12E, para el receptor use tambien una bateria de 9v pero con un regulador 7805 para alimentarlos con 5v para no dañar el modulo RX-RF. El alcance se logro a vista directa sin obstaculos, el transmisor y receptor tenian cables UTP (usado para redes RJ-45) de 16cm cada uno. creo que el alcance se puede superar con una bateria de 12v (las que usan los controles de alarmas para carro) colocada en el transmisor.

bien... estoy usando el HT-12F porque no consigo aca en Venezuela el HT-12D, lo cual estoy obligado a usar 4 integrados de estos para poder decodificar las cuatro señales para los cuatros movimientos..(marcha delantera, marcha trasera, giro hacia la derecha y giro hacia la izquierda)

Estoy usando un amplificador (el ULN2803) en las salida de los decodificadores para activar 4 relés doble de 6v, con esto logro "mover" dos motores pequeños DC alimentados con unas baterias independiente a toda la electronica.

EL PROBLEMA:
Cuando se activan los relés, dos relé por movimiento, estos se cierran y abren rapidamente haciendo que los motores giren pero a una velocidad de aprox. 10% de su velocidad máxima.

He detectado que el problema esta en los decodificadores HT-12F, ya que creo que su salida es una salida de dato con onda cuadrada y esto hace que los relé "taqueteen", "titilen" o "palpadeen". estoy convencido que el problema esta allí, pues logre poner en perfecto funcionamiento los relés activando el UNL2803 directamente o manualmente.

Espero que algunos de ustedes se hayan cruzado con este problema.....
O sino que solución podria aportar para tratar de convertir la salida de dato del HT-12F en un voltaje continuo.
-He probado con transistores
-He intentado con optoacopladores
y por supuesto todos siguen con una onda cuadrada...


Nota: si me lo piden, puedo mostrar un esquema y alguna foto.
25/11/2008 #9


hola Ritshuko por que no usas un pic?

o de ultima porque no tratas de prolongar ese tiempo con un capacitor y resistencia..

o podrias disparar un 555 por un tiempo, se que no es lo ideal pero... por lo visto no usas ningun pic asi que no se si sabras programar uno y esto seria lo mas facil...

volviendo al 555 con un pulso positivolo disparas y lo mantenes disparado... por ejemplo 1 seg, al pasar este tiempo espera el siguiente pulso o lo configuras para que cada ves que reciba el pulso se vuelva a disparar, habria que ver el ancho y el tiempo que dura cada pulso y el tiempo de cada valor vajo

otra cosa seria usar un capacitor si el tiempo de los pulsos es bajo es decir si los pulsos son muy rapidos colocando un capacitor se podria lograr que entre pulso y pulso se mantenga un positivo para mantener el pulso alto.

bueno espero te sirva de algo, se que no es lo ideal pero... es un posible solucion sin usar un pic...
04/12/2008 #10


Gracias Ramon..

Tomaré tu concejo, voy a programar con el 16F84A. ya compre el programador y el PIC 16F877A, pero voy a empezar con calma, empezare con el 16F84A.

Solamente tengo que ponerme a leer un poco sobre los códigos y a ver como me va....

Les prometo que ustedes van a ser los primeros en ver mi PRIMER proyecto cuando lo termine, voy a dedicar estas vacaciones de Diciembre a mi tanque TANK01 "Wall-E" jejejeje.

Thank you.. hasta pronto...
04/12/2008 #11


te recomiendo usar el programa micrcode studio y el compilador pbpro asi podras programar en basic y de esta manera se te simplificaran mucho las cosas!
como programador te recomiendo el Ic-prog que tiene una placa sencilla de montar

y otra cosa compra un pic16f628a o 627 que son mas economicos que el F84A tienen mas memoria, poseen oscilador interno y cuentan con unas cuantas cosas mas...

saludos

cualquier cosa preguntas
04/12/2008 #12


ok, perfecto..

me gustaria programar en C++, tengo conocimientos en ese lenguaje... aunque al parecer el lenguaje de Basic es mas parecido al nuestro.

los pic y el programador ya los compre, compre el 16f84a y el iP3B de Microchip
15/03/2009 #13


Problemas con los modulos de RF 433.9 Mhz
Hola a todos...

Estoy hace unos cuantos dias tratando de hacer funcionar un control remoto utilizando los modulos de RF del fabricante Wenshing... TWS BS3 ( http://información.hobbyengineering....ING-TWSBS3.pdf ) y el RWS 374, junto a los codificadores HT12E y HT12D...

En el diagrama del fabricante del transmisor, aparecen unas resistencias que se conectan entre Vcc y las patas del HT12E AD11 a AD8, sin valor...

Por favor, si alguno de ustedes ha podido hacer funcionar este circuito, hagame saber como, ya llevo gastado un monton de tiempo y dinero en el reemplazo de los modulos temiendo haberlos quemado con tantas pruebas...

Muchas gracias a todos y saludos

Lucas
15/03/2009 #14

Avatar de Meta

Ritshuko dijo:
ok, perfecto..

me gustaria programar en C++, tengo conocimientos en ese lenguaje... aunque al parecer el lenguaje de Basic es mas parecido al nuestro.

los pic y el programador ya los compre, compre el 16f84a y el iP3B de Microchip
Quizás te haga ideas con este manual en PDF.

http://www.abcdatos.com/tutoriales/tutorial/v12.html

Saludo.
17/03/2009 #15


Re: Problemas con Ht-12 E/F
Ritshuko dijo:
Buenas amigo...

He trabajado con los modulos Rf (TLP 315a y RLP 315a) y los code y decoder Holtek HT-12E y HT-12F. Los estoy usando para manejar un tanquecito que he construido..

hice las pruebas de alcance y logre una distancia mayor a 150mts, use una bateria de 9v (de las cuadradas) para alimentar el modulo TX-RF y el code HT-12E, para el receptor use tambien una bateria de 9v pero con un regulador 7805 para alimentarlos con 5v para no dañar el modulo RX-RF. El alcance se logro a vista directa sin obstaculos, el transmisor y receptor tenian cables UTP (usado para redes RJ-45) de 16cm cada uno. creo que el alcance se puede superar con una bateria de 12v (las que usan los controles de alarmas para carro) colocada en el transmisor.

bien... estoy usando el HT-12F porque no consigo aca en Venezuela el HT-12D, lo cual estoy obligado a usar 4 integrados de estos para poder decodificar las cuatro señales para los cuatros movimientos..(marcha delantera, marcha trasera, giro hacia la derecha y giro hacia la izquierda)

Estoy usando un amplificador (el ULN2803) en las salida de los decodificadores para activar 4 relés doble de 6v, con esto logro "mover" dos motores pequeños DC alimentados con unas baterias independiente a toda la electronica.

EL PROBLEMA:
Cuando se activan los relés, dos relé por movimiento, estos se cierran y abren rapidamente haciendo que los motores giren pero a una velocidad de aprox. 10% de su velocidad máxima.

He detectado que el problema esta en los decodificadores HT-12F, ya que creo que su salida es una salida de dato con onda cuadrada y esto hace que los relé "taqueteen", "titilen" o "palpadeen". estoy convencido que el problema esta allí, pues logre poner en perfecto funcionamiento los relés activando el UNL2803 directamente o manualmente.

Espero que algunos de ustedes se hayan cruzado con este problema.....
O sino que solución podria aportar para tratar de convertir la salida de dato del HT-12F en un voltaje continuo.
-He probado con transistores
-He intentado con optoacopladores
y por supuesto todos siguen con una onda cuadrada...


Nota: si me lo piden, puedo mostrar un esquema y alguna foto.
Hola mira tdos esos problemas se solucionan usando un pic enves de los codificadores HT, usas un pic que transmita con serout y uno que reciba con serin y listo podes mandar tantos comandos como quieras y sin que te titile el rele
10/04/2009 #16


Antena para los modulos tlp434 y rlp 434
por favor, que tipo de antena me recomiendan para usar el tlp y rlp 434
10/04/2009 #17


calculin60 dijo:
Mira, no se bien cual puede ser tu problema, pero yo hice un control remoto de 24 teclas con esos modulos, los ht12 y un pic, y funcionan bien. ahora con antena nunca llegue mas alla de los 30 mts. y sin antena no pasa los 4mts. Y una cosa mala que tienen es que en determinada posicion de la antena del transmisor, el receptor no recibe ni a palos, es decir solo a un metro o dos, osea es bastante direccional por la frecuencia que trabaja. Solo escribi para decirte que funciona pero no esperes maravillas como los 100 mts.
Si queres tener mas alcance y transmitir sin antena, podes usar los circuitos de transmision de llaveros de alarma. eso si, trasmiten a cualquier frecuencia y a veces suelen irse de sintonia, pero llegan mas lejos (50 mts.) Tambien hay unos modulos de esa frecuencia pero que tranmiten a 500mw (los otros son de 80mw por norma), segun el fabricante llegan a 800 metros (ponele 100mts. si no miente mucho) si te interesan busca en la pagina de cika argentina, en el catalogo en pdf lo podes ver. Saludos y suerte
Tenes toda la razon yo hice un circuito de prueba que enviaba un dato y cuando lo recibia bien cambiaba de estado un led y cuando recibia un dato erroneo cambiaba el estado de otro led. Lo que me di cuenta es que a 100m no llegas ni en pedo menos con antenitas de cable, que son bastante direccionales, te cruzas en medio y ya no recibe, por otro lado el control remoto de la alarma d ela moto llega unos 80mts re bien y tb lo probe desde un 8vo piso hasta la calle y llego, tienen muy buen alcanse habria que ver si se puede modificar el circuito para transmitir datos o recibir de esos controles.
12/04/2009 #18

Avatar de gzaloprgm

Sí, podrias agarrar el pulsador y conectarle un transistor y rezar para que el emisor y receptor estén preparado para datos a alta velocidad.

Otra sería agarrar la salida del emisor y en ves de pasarla a una antena, amplificarla con un transistor y hacer que disipe más potencia, conectándola a una resistencia más chica.
23/08/2009 #19


proyecto terminado! tanque a control remoto
proyecto terminado! lo prometido es deuda... tanque a control remoto con modulos de radio frecuencia..

vean el video en el siguiente link:

YouTube - Wall-E V-2.7 - Tanque controlado por RF
26/08/2009 #20


Hola bike2k3, yo tambien tengo este problema de que desde hace varios meses no llegan estos codec HT12, felismente logre obtenr un par y con eso arme mi circuito. Pero me gustarìa, de acuerdo a tus sugerencias, reemplazarlos por el pic 16f84. Por favor, podrìan indicarme y darme alguna pista de còmo conseguir hacer este codigo con los comandos serin y serout? Gracias por tu ayuda.
Palmas.

Hola remramon2007 , yo tambien tengo este problema de que desde hace varios meses no llegan estos codec HT12, felismente logre obtenr un par y con eso arme mi circuito. Pero me gustarìa, de acuerdo a tus sugerencias, reemplazarlos por el pic 16f84. Por favor, podrìan indicarme y darme alguna pista de còmo conseguir hacer este codigo con los comandos serin y serout? Gracias por tu ayuda.
Palmas.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.