Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

06/11/2010 #1


Problema al programar con MPLAB ICD2
Hola a todos! Llevo algun tiempo haciendo programitas con ccs c y simulandolos con proteus. Hasta ahora todo ha ido bastante bien. Ahora quiero dar el paso a meter los programas dentro de un pic, en concreto el pic 18l2620. Los materiales que me han dado en clase para ello son:

Un cable USB que conecta el portatil al programador. Es un aparato redondo y aplastado (como una galleta gigante). El Microchip MPLAB ICD 2. Y despues esto lo conecto a un zocalo donde engancho el pic para programarlo.

Por si no se nota, quiero especificar que es la primera vez que hago esto y no tengo muy claro si me estoy dejando algo por conectar.

En el ordenador tengo el MPLAB IDE. Por ahora mi intencion es simplemente programar el Pic para que, en un circuito que tengo a parte, dandole a un pulsador, se encienda/apague un led. Es decir, que no me importa lo que haga el rograma, simplemente intento progrmarlo y que consiga funcionar.

Bien, dicho esto:
Cuando abro el mplab ide, creo un proyecto y selecciono el archivo.c que ya habia compilado antes. Despues selecciono como programador el MPLAB ICD2. Hasta aqui todo bien.
Cuando le doy a conectar me empiezan a aparecer warnings. Despues le doy a make al archivo, y por ultimo a programar. Y me da avertencias y finalmente no consigue programarlo. Copio aqui lo que me va sanco el programa en estos 3 pasos. Agradezco desde ya cualquier tipo de ayuda, bien sea porque este haciendo algo mal o porque haya olvidado de hacer alguna cosa. Gracias.

Lo pongo en un txt adjunto para que os resulte mas comodo leerlo.
08/11/2010 #2


Hola, abre MPLAB IDE, entra Programmer/settings y toca la pestaña POWER y fijate si tiene habilitada la opcion
"power target circuit from MPLAB ICD2"
08/11/2010 #3


Lo consegui
Si, lo tenia tildado. Ya he comseguido solucionarlo. Desdeluego era justo ahi donde estaba el problema de todo. A pesar de que, tildando esta opcion y utilizando el cable usb,se supone que no necesitas una fuente de alimentacion a parte, por lo visto no le llegaba suficiente tension, y una vez añadida la fuente, ya he conseguido programar. Lo sigo viendo un poco extraño porque, compañeros mios, si que consiguieron programar con los mismos instrumentos que yo, y sin necesidad de la fuente.

De todos modos, queria darte las gracias, porque era ahi donde tenia el problema.

Y nada, decir al mundo que...¡¡¡Ya soy capaz de encender un led!! jajaja (Es un pequeño paso para la humanidad, pero un paso de gigante para mi aprendizaje sobre PIC's)
08/11/2010 #4


Me alegro, pero fijate bien porque yo puedo programar sin fuente externa.

Saludos
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.