Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

29/10/2011 #1


Problema comunicación RS232 con PIC 16F876
Hola,

Estoy desarrollando un proyecto con el pic 16f876, consiste en leer de un modem MTX65i por el puesto serie la trama que me llega de este modem.

La trama qu envía el modem tiene este formato:

MTX_terminal_conexion_establecida

3457872#23456789#0#1#0#0#0#0#0#0#0#0#0#0#234#MTX_E ND

Mi programa en el PIC (oscilador 4MHz) y todo configurado a 9600 baudios(modem y PIC). Lo que hace es con un getch leer uno por uno los caracteres y activar unas salidas para encender unos LEDs.

Explicado el proyecto por encima, cuento lo que me pasa.
Pruebo mi placa con el PIC directamente conectado al hyperterminal y mando la trama caracter por caracter y el PIC hace lo programa, cuando detecto que existe la trama "#1", me enciende el LED.

Pero el problema viene cuando conecto el modem(salida del modem configurado a 9600 baudios tambien) al PIC, el PIC no me activa los LED. verifico si el modem manda la trama #1, y si la manda, dado que estoy verificando la salida del modem por otro puerto serie.

Alguien me puede echar una mano.

Gracias y un saludo
02/11/2011 #2


Vuelvo a verificar todo el conexionado y es correcto.

Es mejor usar un getch o un gets para recoger toda la trama que me envía el modem MTX65.

Gracias y un saludo
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.