Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/04/2009 #1


Problema con Displays usando Shift register
Saludos.

Estoy realizando un termometro digital, y para eso estoy usando un par de shift registers conectados al PIC. Estoy usando el pic 12f675.

Al parecer ya me funciona bien pero tengo un problema. Algunos segmentos del display se encienden a baja intensidad mientras que los otros se encienden bien por lo que no se distingue bien el numero.

Si alguien me puede decir como solucionar eso se los agradeceria.

Gracias de antemano por su ayuda.
03/04/2009 #2


puedes postear el circuito?

todo indica que tienes un solo resistor para todos los segmentos, en lugar de tener uno para cada uno.

Salu2
03/04/2009 #3


Bueno en realidad si tengo un resistor para cada displays. Primero los tenia de 330 ohms despues le coloque unos de 100 ohms.
03/04/2009 #4
Moderador

Avatar de Chico3001

Verifica que tus transistores esten bien conectados, a mi una vez me sucedio que se encendian mal los segmentos por que habia polarizado mal el transistor de salida
03/04/2009 #5


Aqui les dejo el archivo con la imagen del termometro
Imágenes Adjuntas
Tipo de Archivo: jpg termometro12f675_201.jpg (50,4 KB (Kilobytes), 25 visitas)
16/11/2011 #6


pon transistores 2n3904 con colector a +5V, emisor a el segmento del display, y la base conectala a la resistencia del shift register
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.