Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

26/03/2008 #1


Problema DS1302
Tengo un serio problema, todo marchaba bien con este maravilloso integrado pero he notado un problema, como saben tienen una entrada para una bateria en caso de que la fuente principal falle, monte el circuito y en la entrada de la batería conecte dos pilas AA que tienen aprox 3 V, a veces sigue el avance normal y cuando restablezco la energía el reloj no se ha atrazado y a veces cuando restablezco la energía el reloj sigue en el punto donde se quedo como si se hubiera quedado pausado. No se si me puedan dar una idea de lo que pueda ser, cualquier aporte útil y constructivo se los agradecería.
26/03/2008 #2

Avatar de Meta

Porque en el momento que pierde la alimentación, en ese instante el reloj lo detecta. La conmutación debería ser más rápida.
26/03/2008 #3


No me queda muy claro, el encargado de la conmutación es el ds1302 porque la fuente auxiliar siempre esta conectada, dices entonces que es un problema del ds1302? gracias por tu aporte
26/03/2008 #4


Primero, lo obvio... Asegurate q cuando desconectas la alimentacion principal no se desconecten tambien (aunq sea una fraccion de segundo) las baterias.

Creo q el trickle charger no lo usas, verdad?. Mira en la datasheet si ese interviene en algo. Es bueno leer la datasheet .

Trata de aislar el problema, mira bajo q conjunto de circunstancias el reloj se mantiene andando y bajo q circunstancias no. Experimenta.

No se me ocurre q mas puedas hacer. Si alguien tiene alguna otra idea, o a trabajado antes con este chip, por favor ILUMINENOS con su sabiduria

Salu2
Diego
26/03/2008 #5

Avatar de Meta

Otra cosa, aunque el tiempo sea corto, en el cambio sumar dos tensión de la fuente de alimentación principal junto con la pila externa. Puedes dañar el dispositivo. ¿Tiene protección?

Aunque tu caso es pérdida de tensión al cambio. Estas cosas hay que tener cuidado. Al menos en autómatas o PLC que daba en clase controlando un motor trifásico, utilizamos cosas como contactores.

Busca en www.google.com la palabra contactor o contactor trifásico.

Lo del trifásico es sólo para informaciónrmarte y que sepas que existe, en tu caso no lo usarás.
26/03/2008 #6


Meta dijo:
Otra cosa, aunque el tiempo sea corto, en el cambio sumar dos tensión de la fuente de alimentación principal junto con la pila externa. Puedes dañar el dispositivo. ¿Tiene protección?

Aunque tu caso es pérdida de tensión al cambio. Estas cosas hay que tener cuidado. Al menos en autómatas o PLC que daba en clase controlando un motor trifásico, utilizamos cosas como contactores.

Busca en www.google.com la palabra contactor o contactor trifásico.

Lo del trifásico es sólo para informaciónrmarte y que sepas que existe, en tu caso no lo usarás.
Meta, el ds1302 es un rtc (real time clock) cmos con trickle charger, es decir cargador de baterias incorporado. Esta hecho para usar 2 fuentes (para mantener la hora exacta aun en el caso de que falle la alimentacion principal) . Aca te dejo la hoja de datos.

http://datasheets.maxim-ic.com/en/ds/DS1302.pdf

Salu2
26/03/2008 #7


Meta dijo:
Otra cosa, aunque el tiempo sea corto, en el cambio sumar dos tensión de la fuente de alimentación principal junto con la pila externa. Puedes dañar el dispositivo. ¿Tiene protección?
Meta, las entradas de alimentacion principal y de la bateria externa son independientes.


Bien el problema se esta generando al momento de conectar/desconectar la alimentacion principal, por lo tanto creo que es un transitorio que esta afectando la operacion del rtc.

Tienes capacitor de desacoplo -0.1uF- entre VCC1 y GND...?

Ya que no estas perdiendo la hora, por lo tanto descartamos que la alimentacion se este perdiendo.

Otro problema pudiera ser con el oscilador, esta en un protoboard, en una tarjeta impresa?

Seguiste el layout recomendado por Maxim para el ruteo de las pistas..?
26/03/2008 #8


eidtech dijo:

Bien el problema se esta generando al momento de conectar/desconectar la alimentacion principal, por lo tanto creo que es un transitorio que esta afectando la operacion del rtc.

Tienes capacitor de desacoplo -0.1uF- entre VCC1 y GND...?

Ya que no estas perdiendo la hora, por lo tanto descartamos que la alimentacion se este perdiendo.

Otro problema pudiera ser con el oscilador, esta en un protoboard, en una tarjeta impresa?

Seguiste el layout recomendado por Maxim para el ruteo de las pistas..?
Lo del capacitor, es una buena idea. Otra prueba mas de como uno da por sentado ciertas cosas y ni las piensa . Si esta en un protoboard casi seguro es un cable suelto.

Gracias, salu2.
26/03/2008 #9

Avatar de Meta

Ok, Aclarado.

Bueno. A ver si nuestro amigo nos manda fotitos y esquemas para verlo.
26/03/2008 #10


Muchas gracias a todos por los aportes, si habia pensado en el transistor de desacople, pero para mi eso no explica porque se pausa en vez de reiniciarse y empezar de nuevo, y en este momento esta en un PCB, voy a prestar una camara y esta semana pongo fotos
26/03/2008 #11

Avatar de Meta

ZOH dijo:
Muchas gracias a todos por los aportes, si habia pensado en el transistor de desacople, pero para mi eso no explica porque se pausa en vez de reiniciarse y empezar de nuevo, y en este momento esta en un PCB, voy a prestar una camara y esta semana pongo fotos
Ok, esperando fotazos.

A lo mejor esto te da ideas.

http://todoelectronica.com/conmutado...ia-p-3187.html
26/03/2008 #12


ZOH dijo:
Muchas gracias a todos por los aportes, si habia pensado en el transistor de desacople, pero para mi eso no explica porque se pausa en vez de reiniciarse y empezar de nuevo, y en este momento esta en un PCB, voy a prestar una camara y esta semana pongo fotos

Es Capacitor, y no transistor...

Y Si... si tiene mucho que ver... tu sabes que al conectar la alimentacion todos los componentes en un circuito comienzan a demandar corriente, al suceder esto en la alimentacion se crean perturbaciones en el voltaje tales como aumento/disminucion, picos los cuales afectan el funcionamiento de tu RTC. El RTC necesita alimentacion muy estable.

Prueba a ponerlo, soldandolo directo al PCB.

Otro asunto importante, es el ruteo de las pistas, en especial las del cristal, seguiste las recomendaciones de Maxim?
27/03/2008 #13

Avatar de eserock

Hola por lo que comentas la falla es aleatoria, esto podria generarse por ruido al momento de retirar la alimentacion del pic los condensadores se descargan a tiempos diferentes y puede llegar a enviar alguna señal en la comunicacion con el ds1302 y hacer que presente este tipo de funcionamiento (como si lo pusieras en pausa) verifica esto. espero te ayude.
27/03/2008 #14


estoy usando una bateria para alimentacion principal, y ya no se detiene el reloj, el problema si parece estar en los transitorios, seguire haciendo pruebas y les comento, gracias por los aportes
31/10/2008 #15


ZOH dijo:
Muchas gracias a todos por los aportes, si habia pensado en el transistor de desacople, pero para mi eso no explica porque se pausa en vez de reiniciarse y empezar de nuevo, y en este momento esta en un PCB, voy a prestar una camara y esta semana pongo fotos
Mira, a mi me pasaba exactamente lo mismo y fué solución simplemente agregando un capaciotor de .1uF de VCC2 y masa.
18/09/2010 #16


Respuesta: Problema DS1302
ZOH dijo: Ver Mensaje
Tengo un serio problema, todo marchaba bien con este maravilloso integrado pero he notado un problema, como saben tienen una entrada para una bateria en caso de que la fuente principal falle, monte el circuito y en la entrada de la batería conecte dos pilas AA que tienen aprox 3 V, a veces sigue el avance normal y cuando restablezco la energía el reloj no se ha atrazado y a veces cuando restablezco la energía el reloj sigue en el punto donde se quedo como si se hubiera quedado pausado. No se si me puedan dar una idea de lo que pueda ser, cualquier aporte útil y constructivo se los agradecería.
este rtc tiene una alimentacion auxiliar no deberia ser nesesaria la conmutacion utiliaza en esta alimentaciona auxiliar pilas... saludos
18/09/2010 #17

Avatar de ivan_mzr

Respuesta: Problema DS1302
yo utilize un capacitor de 1F a 5.5v no me dio ningun problema. Tienes deshabilitado el cargador?(pag 9 del Datasheet), creo que NO debes utilizarlo para baterias alkalinas.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.