Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

18/12/2009 #1


Problema con entrenador de pic16f84a
Hola, lo que pasa es que me hice un entrenador de pics, en especial el 16f84a, es el entrenador que sale en el libro de "microcontrolador pic16f84 desarroyo de proyectos" pero sin el display de 7 segmentos, solo lo hice con los leds, y el problema es simple, no funciona, al conectarlo no hace nada no prende ningun led, amenos que toque con el dedo la terminal 16 que es la entrada del oscilador, pero no empieza a funcionar bien, es como si el programa se iniciara pero nadamas, por ejemplo en el programa que debe prender y apagar un led, solo se prende y se queda asi, prendido y estoy utilizando un programa que probe anteriormente en una simulacion de proteus donde si funcionaba bien, ya probe cambiando el oscilador, tambien probe cambiando el pic, verifique que no ubiera cortos o conecciones donde no debe haber (con el multimetro), pues no se que es, pienso que pueda ser el programador que no este funcionando bien es un "pig-prog800" la fuente de alimentacion que uso es de un quemador de DVD's externo(el cual ya no existe) y saca 5v 1.2A, tambien saca 12v 1A pero claro que ese no lo uso para el pic, tal vez sea por la forma en la que hice la placa, o algun problema con el diseño en si, bueno pongo fotos de la placa y tambien el esquematico, de verdad espero que puedan ayudarme porque esto me ha estado atrazando mucho en un proyecto que estoy haciendo (que es solo como entretenimiento ), de antemano Gracias por haber leido todo esto, y les agradecere aun mas si me pueden ayudar.
18/12/2009 #2
Moderador

Avatar de Chico3001

Respuesta: Problema con entrenador de pic16f84a
Lo mismo que recomende ayer algunos cristales tienen incluidos los capacitores de desacoplo... intenta quitando los capacitores de 22p que le pusiste al cristal....
18/12/2009 #3


Respuesta: Problema con entrenador de pic16f84a
jajajaja urraaaa!!!! problema solucionado, si eran los capasitores, almenos el leed ya prende y apaga, ahora probare mis demas programas, muchisimas Gracias =D
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.