Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/10/2005 #1


Problema insoladora uControlada
Buenas, me presento porque es mi primer mensaje. Soy José Antonio y vengo a este foro a ver si me dan alguna luz sobre el problema que tengo

Estoy haciendo una insoladora microcontrolada con un pic 16f628, 4 tubos fluorescentes de 15w actinicos con dos reactancias de 36w y 4 cebadores fs22, accionados mediante un triac y un optotriac y un transformador de 12v ac.

El problema es que el pic se cuelga aleatoriamente cuando en el proceso de encendidos de los tubos... vienen a coincidir en tiempo al encendido de los cebadores.

falta la alimentación del pic pero no consigo que proteus me enseñe esas patillas. Pero lo he intentado de varias formas... intercalándole varios condensadores... con un 7805 (y condensadores de 330nf y 100nf como indica su datasheet) con bobinas de 100uf, zener de 5V1...

también se cuelga alimentándolo con una pila de 9 voltios así que en realidad igual la etapa de alimentación no traiga el problema...

Tengo todas las patillas no usadas encaminadas a masa y nada el pic se sigue colgando cada vez que le viene en gana... otras veces funciona perfectamente.

Por cierto cuando digo colgar solo se cuelga en el proceso de encendido de los tubos... nunca en otro momento

1 saludo y gracias de antemano por cualquier ayuda.

he aquí un esquema de la conexión ultima que tengo realizada:
27/10/2005 #2


Re: Problema insoladora uControlada
Podrías separar la alimentación de tu pic y la que alimenta a los triacs?

Hazlo y verifica de nuevo si ocurre el mismo problema.
27/10/2005 #3


Re: Problema insoladora uControlada
magio dijo:
Podrías separar la alimentación de tu pic y la que alimenta a los triacs?

Hazlo y verifica de nuevo si ocurre el mismo problema.
Como digo he alimentando el pic con una pila de 9v y sigue ocurriendo lo mismo
27/10/2005 #4


Si estas usando watchdog o timers (como creo que si), pudiera ser que se está reseteando el PIC por desbordamiento del contador. Lo que veo en tu circuito, que por cierto no es complicado como para pensar que el problema está alli, es que la pata RA5/MCLR la tienes al aire. Trata de llevar ese pin a +5V mediante una resistencia de 10K para evitar el autoreset.

Saludos.
Marcelo.
27/10/2005 #5


Marcelo dijo:
Si estas usando watchdog o timers (como creo que si), pudiera ser que se está reseteando el PIC por desbordamiento del contador. Lo que veo en tu circuito, que por cierto no es complicado como para creen que el problema está en él, es que la pata RA5/MCLR la tienes al aire. Trata de llevar ese pin a +5V mediante una resistencia de 10K para evitar el autoreset. Si no, pareciera que el problema está en el código del pic.

Saludos.
Marcelo.
De verdad descartad cualquier tipo de problema en el codigo porque el pic no se cuelga si desconecto la patilla que enciende el optotriac (osea sin llegar a encender los tubos). Se queda colgado cuando manda activar esa patilla se encienden los tubos y empieza la cuenta atrás de los segundos que se le han programado. OJO DIGO QUE SE QUEDA COLGADO 1 DE CADA 10 VECES. Vamos va por rachas... o le da por no colgarse en 10 veces o se cuelga 3 veces seguidas en el mismo punto.


El pic se cuelga unicamente y lo recalco cuando hacen los chasquidos los cebadores.

La patilla de mclr está al aire ahí pero la tengo a masa en el pic. Está desconectada por fuse por lo que es una simple patilla de e/s (es configurable en el 16f628)

Al igual también indico que el reloj que uso es el interno que tiene este pic de 4 mhz.

Yo creo que el problema viene porque debido a que lo tengo dentro de un escaner los tubos y cebadores están pegados a los circuitos y estos no aguantan los parpadeos de lso cebadores... Qué tipo de caja metalica podria ponerle al circuito del pic (que es independiente del de alimentación y del del triac) para que se viera protegido de estas interferencias???
27/10/2005 #6
Moderador general

Avatar de Andres Cuenca

Me parece que deberías probar colocando un filtro cerámico o de poliéster de 0.1uf en paralelo con la reactancia, para así evitar que el ruido generado por ella se induzca en el optoacoplador y genere interferencias en el micro.
27/10/2005 #7


Li-ion dijo:
Me parece que deberías probar colocando un filtro cerámico o de poliéster de 0.1uf en paralelo con la reactancia, para así evitar que el ruido generado por ella se induzca en el optoacoplador y genere interferencias en el micro.
Ok supongo que por filtro te refieres a un condensador verdad? defineme por favor cuando te refieres en paralelo con la reactancia... Porque tengo un cebador de poliester de .046uF para corregir el factor de potencia de las dos reactancias conectadas en su fase y neutro. ¿En esta posición te refieres? o puramente en paralelo a la reactancia que seria uno a fase y otro a uno de los terminales del tubo.

1 saludo y gracias por los aportes

PD: Con la alimentación por separado me he dado cuenta de una cosa... si cuando el pic se queda colgado (que se detecta porque la cuenta atrás se detiene y se mantineen los tubos encendidos por siempre) si en ese instante apago los tubos normalment el pic prosigue su cuenta atrás...

O incluso más raro... también se llega a colgar cuando apago los tubos... pues bien si enciendo los tubos nuevamente el pic resucita y sigue la cuenta atrás... pero la sigue sin problemas... descontando los segundos que ha pasado...

me tiene desesperado
27/10/2005 #8


Por qué no haces el circuito de carga del opto tal cual como te lo recomienda el datasheet para cargas altamente inductivas? que al fin y al cabo es más o menos lo que te dice Li-ion.
Imágenes Adjuntas
Tipo de Archivo: gif nuevo-1_179.gif (8,2 KB (Kilobytes), 125 visitas)
27/10/2005 #9


Marcelo dijo:
Por qué no haces el circuito de carga a la salida del opto tal cual como te lo recomienda el datasheet para cargas altamente inductivas? que al fin y al cabo es más o menos lo que te dice Li-ion.
Mañana lo probaré porque creo que tenia algo muy parecido en el primer montaje porque seguí este esquema



pero tiene mal las patillas mt1 y mt2 q están alrevés...

de todas formas mañana lo pruebo porque tengo que ir a trabajar

Gracias a todos de verdad
27/10/2005 #10
Moderador general

Avatar de Andres Cuenca

Marcelo dijo:
Por qué no haces el circuito de carga del opto tal cual como te lo recomienda el datasheet para cargas altamente inductivas? que al fin y al cabo es más o menos lo que te dice Li-ion.
Exacto Marcelo, a eso me referia.

Elmasvital, con ese filtro de linea estoy seguro que solucionaras tu problema.
27/10/2005 #11


Marcelo dijo:
Por qué no haces el circuito de carga del opto tal cual como te lo recomienda el datasheet para cargas altamente inductivas? que al fin y al cabo es más o menos lo que te dice Li-ion.
Otra cosa que sugiero es que pruebes con un shielding metálico en deredor de tu pic.

Me ha ocurrido que si el pic está en presencia de un campo magnético importante se resetea... esto es INEVITABLE si no le colocas un shielding metálico que haga de jaula de faraday y todo lo que hagas eléctricamente será en vano ya que el problema lo tendrás magnéticamente.
27/10/2005 #12


ahora que miro en mi esquema se excita el gate con la patilla 6 y en el que propones por la 4... mmm vamos a ver si puede ser que sea eso...

1 saludo
27/10/2005 #13


magio dijo:
Marcelo dijo:
Por qué no haces el circuito de carga del opto tal cual como te lo recomienda el datasheet para cargas altamente inductivas? que al fin y al cabo es más o menos lo que te dice Li-ion.
Otra cosa que sugiero es que pruebes con un shielding metálico en deredor de tu pic.

Me ha ocurrido que si el pic está en presencia de un campo magnético importante se resetea... esto es INEVITABLE si no le colocas un shielding metálico que haga de jaula de faraday y todo lo que hagas eléctricamente será en vano ya que el problema lo tendrás magnéticamente.
No se llega a resetear pero se para... voy a ver si pruebo con esto que dices y de paso lo que me dicen los compañeros... Pero creo que es precisamente esto lo que me está pasando... Fijaros que es que el circuito está a escasos milimetros de los cebadores y reactancias por falta de espacio...
28/10/2005 #14


Bueno he montado el esquema que viene en el datasheet del moc3031 para cargas altamente inductivas y que proponia marcelo.

El tema es que se sigue colgando pero pensando ya que el problema viene por interferencias electromagneticas ya bien filtrada la alimentación cuando el pic está a 30-40 centimetros de los cebadores y reactancias el pic funciona perfectamente el 100% de las veces...

Ahora bien el problema es que la insoladora no me va a permitir tener a 30-40 cms el pic. Así que necesito información a cerca de la jaula de faraday que menciona magio. De qué materiales deberia construir esa jaula... vale una simple caja de cartón forrada en su exterior de papel de aluminio o tendría que comprar una caja al uso...

Y otra cosa que necesito saber es si la masa del circuito del pic debe ir conectada con la caja.

1 saludo
28/10/2005 #15


Jeje, me alegro que hayas descubierto que este era tu problema.

Te pasaré a explicar un par de detalles.

Todo lo que mencionas podría funcionar. Lo que se suele hacer es una cajita con una chapa doblada de acero o de aluminio.

La cajita la armas en derredor al pic. También es bueno si puedes montarla por debajo del mismo. Es decir cubriendo TODO tu pic por arriba y por abajo.

Esta caja DEBE ir a Ground o MASA o 0V o como le llames.

Es algo muy común en la industria. Es una OBLIGACION. De hecho muchos equipos vienen ya directamente armados con una caja de aluminio. Hasta el conector, suele tener por detrás, una chapa de aluminio que cubra el ingreso del campo magnético por esa via.

Que sirve? Todo depende de la intensidad del campo magnético.

Si tiene poca intensidad entonces una pequeña lámina de aluminio podría ser suficiente. Si es muy intenso esto no lo detendrá, con lo cual debieras proveer un material mas grueso.

Lo más económico (al menos en mi pais) es una chapa. Espero que allí le llamen igual, asi nos entendemos de que estamos hablando, sino trataré de buscar un término químico más específico jejeej.

28/10/2005 #16


Bueno, ya diste con el problema.

Antes de ponerte a armar o comprar cajas, puedes hacer una prueba envolviento todo el circuito con plástico del que se usa en la cocina para guardar alimentos, a fin de que quede bien aislado. Luego envuelve todo eso con papel de aluminio conectado a tierra y sin apretar (la geometría es importante así que trata de simular una caja).

Fíjate que las soldaduras y partes metálicas de los componentes no te vayan a romper el plástico haciendo contacto con el aluminio. Trata de que la capa de plástico sea lo mas fina posible para que no influya su propiedad dieléctrica.

Si hablas de jaulas de Faraday, normalmente se diseñan dos caja, una lo más cercana al uP (normalmente de cobre conectada a masa y la otra cubriendo todo el circuito, buscando un efecto capacitivo. Similar a lo que ves en una etapa de RF de un radio o tv.

De todas formas, si quieres ir un poco más alla, aquí hay algo de teoría de diseño para realizar una jaula de Faraday con el encapsulado del cicuito y uP (de computadoras, pero es aplicable):

http://www.ce-mag.com/archive/01/Spring/Raza.html

http://www.hepl.harvard.edu/~ATLAS_B...n_updates.html

Saludos,
Marcelo.
25/03/2010 #17


Respuesta: Problema insoladora uControlada
Queria consultarles si los micros motorola, o los micros de microchip de alta gama(linea18F) se tildan de esa manera con los ruidos electromagneticos?

Saludos.
25/03/2010 #18
Moderador general

Avatar de Fogonazo

Respuesta: Problema insoladora uControlada
marianocuaranta dijo: Ver Mensaje
Queria consultarles si los micros motorola, o los micros de microchip de alta gama(linea18F) se tildan de esa manera con los ruidos electromagneticos?.....
Cualquier micro, de cualquier precio o tecnología se te puede "Tildar" si no tienes las precauciones necesarias de aislación de posibles interferencias (EMI)
29/03/2010 #19


Respuesta: Problema insoladora uControlada
Pero en mi experiencia, el pic 16f84 es muy suseptible. Si enchufo un soldador en el mismo conector que la fuente del micro, este se resetea....
No se que experiencia tienen ustedes....
29/03/2010 #20
Moderador

Avatar de Chico3001

Respuesta: Problema insoladora uControlada
Nop... a mi me ha tocado conectar PICs para conmutar cargas de 75KVA en lineas de 440V y no he tenido problema... el truco esta en lo que comenta Fogonazo... tomar las precauciones adecuadas... .
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.