Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

13/09/2007 #1

Avatar de FRYCK

problema con lcd
Buenas noches estoy algo confundido soy novato en trabajar con lcd y ya realice un par de librerias para tal fin
el probema que se me presenta es que estoy utilizando una lcd de 2x16 la referencia es
QY-162A le estoy dando la configuracion y los tiempos que creo necesarios. lo simule en proteus y me corrio lo mas de bien pero a la hora de montarlo en una protoboard no me reproduce los caracteres que quiero por ejemplo la c me despliega una d la s una r y las vocales ni se diga
creia que era un error el el programita pero realice de nuevo otro para provar y me da lo mismo

No se si el lcd esta defectuoso
a ustedes les ha pasado lo mismo o sera que tengo algo mal o estoy ignorando algo gracias por sus respuestas
si para su respuesta necesitan el codigo en c me dicen y lo posteo
14/09/2007 #2


No, revisa que no te falle un bits/cable, me inclino a pensar por 5 o 6... haz una cosa pasa las letras a binario no sea un bit siempre a cero.

si esto no es sube los retardos bastate no sea una lcd lenta
14/09/2007 #3

Avatar de FRYCK

buenos dias ya lo hice pase las letras en binario pase todo el abcdario pero me sucede que cuando pasaba los datos se me repetian las letras por ejemplo cuando pasaba el codigo en binario de la a meaparecia el de la letra anterior el de la e me aparecia la d asi fuera una por una o en cadena lo hice atraves de bus de 4 bits y me da lo mismo .
gracias por su respuesta
14/09/2007 #4

Avatar de FRYCK

probe la tabla de los binarios y si es un bit el 7 pero no se que pasa porque tiene continuidad y lo desconecto y el lcd no muestra sino una sola linea pero el mismo letrero

conversor adc
bnnvdrrnr `db
14/09/2007 #5

Avatar de FRYCK

Les agradezco la atensión prestada ya encontre el problema fue un pin del microcontrolador no se porque motivo se me daño era RB0 el que me hacia tener disgustos
gracias
18/09/2007 #6


Hola, sabes si es necesario inicializar el display LCD con Proteus, o biene inicializado por defecto ??

si es que hay que inicializarlo sabes cual es el codigo necesario en assembler ??

gracias adios
19/09/2007 #7


La lcd siempre debe ser reinicialiada y configurada antes de utilizarla enviando caracteres ascii

En proteus no tengo ni idea si es necesario algun comando internoi del proteus para indicarle que quieres utilizar una pantalla.
15/10/2007 #8

Avatar de FRYCK

hola NEPR
disculpa la demora aqui posteo el codigo en ensamblador mplab
Hasta luego
Archivos Adjuntos
Tipo de Archivo: pdf lcd_asm_354.pdf (34,3 KB (Kilobytes), 144 visitas)
Tipo de Archivo: zip lcd_8_bits_181.zip (17,7 KB (Kilobytes), 110 visitas)
10/03/2009 #9


yo tengo una display lcd y se ve muy tenue incluso nada de frente y al inclinarme lo puedo ver nitido que ocurre alguna idea?
10/03/2009 #10


yo tengo una display lcd y se ve muy tenue incluso nada de frente y al inclinarme lo puedo ver nitido que ocurre alguna idea?
que tipo de display es? postea un esquema de como lo tienes conectado
10/03/2009 #11


es un display de un identificador de llamadas... va sobre una goma rectangular que lo conecta con las pistas de la placa... lo presiono bien fuerte pero no pasa nada asi que no creo que es problema de presion... no entiendo por que
25/11/2009 #12


Respuesta: problema con lcd
buenas

soy nuevo en esto, necesito una ayuda con un lcd que esta conectado a un pic.

tengo problemas con un lcd QY-126A conectado al circuito solo me muestra la linea de arriba.

le agracesco su ayuda
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.