Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/11/2010 #1


problema con microcontrolador
Saludos compañeros, les excribia para pedirles ayuda acerca de un circuito que hice con un attiny 2313.

el problema basicamente es al alimentarlo, el microcntrolador trabaja perfectamente cuando lo alimento con 5v directamente hace su funciones bien(apaga unos led y enciende otros cuando hay un sonido), el problema es que tengo que alimentarlo desde una planta que me da 12v y lo regulo con un 7805 pero cuando lo alimento con 12v ya no trabaja bien, sino que enciende los otros led pero no apaga los anteiores, en resumen.

Con 5v voltios directamente

estan encendidos led azules, cuando se produce un sonido se apagan las azules y encienden rojas

este es el funcionamiento normal

con 12v y regularor 7805

estan encendidos led azules, cuando se produce un sonido se encienden las rojas pero las azules no se apagan

ayudenme a solucionar xfavor este problema
gracias
02/11/2010 #2

Avatar de jairosaw

Bueno hay ciertas cosas por las q hay q comensar:

1. Sube el diseño de la fuente q estas utilizando , o basicamente te sugiero colocar filtro antes y de spues del regulador LM7805,, a veces la falta de esto te coloca en aprietos cosas tan sencillas, la conclusion a lo anterior es eliminar en un porcentaje el risado de ese voltaje de entrada,
03/11/2010 #3


lo estoy alimentando con 12 v que me entrega un amplificador de audio la cual esta conectada a 12 v que viene directamente de la bateria del coche. EL 7805 lo tengo con 0.1uF entre 12 V y tierra y 0.1uF y tierra (esta configurcion si me sirvio con otro circuito)
03/11/2010 #4


eso te vale para el desacoplo. Ayudale con 100uf despues del 7805 y 470 uf antes.
04/11/2010 #5

Avatar de pepechip

Hola
¿de donde coges la alimentacion de los led?
Si el positivo de los led los coges de 12v y el microcontrolador manda negativo, entonces es normal que te ocurra devido a los diodos de proteccion que tienen todos los pines.
04/11/2010 #6


la alimentacion de los led es: 2 led en paralelo que sale de un pin del micro y ocupo 10 pines.

En relacion a los capacitores

el de 100 uF le pongo despues de 7805 entre 5 y tierra y el de 470 uF antes del 7805 entre 12 y tierra o 5 y tierra?
04/11/2010 #7


correcto. y no olvides poner condensadores de desacoplo a lo que va al lcd.
05/11/2010 #8


Espero que pongas resistencias en serie con los leds. Recuerda que los micros suelen tener límites en la corriente que pueden suministrar por cada pin.
05/11/2010 #9


para cada led les estoy poniendo resistencias en serie de 120ohmios.

Con los capacitores si mejoro bastante ya trabaja mucho mejor aunk solo falla un poco en tiempos ya que con 5 V es un poco mas lento pero programando el micro creo que soluciono ese problema.

Ahi otra preguntita, al micro le entra una señal que le indica cuando le da un 1 y cuando es 0 pero los 1 y 0 le da los bajos de una cancion pero son muy rapidos que apenas se aprecia el cambio de colores. como le podria solucionar este problema¿haciendo que se queden mas tiempo encendidos los led antes de que cambien pa que se note o hay alguna otra solucion?

ahh gracias compañero por lo de los capacitores practicamente esta sopluicionado
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.