Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

20/09/2006 #1


Problemas de corriente en un PIC16f873
Hola amigos,
Tengo una dificultad que ya me tiene podrido, y espero me puedan dar alguna luz
He estado armando un tarifador telefonico basado en un PIC16F873, sin ningun problema he detectado las señales de descolgado y llamada contestada (inversion de polaridad) con optoacopladores, y a la salida de estos la conecte al PORTC,0 y 1, ... k pasó??? pues que el voltaje cayó a zero, entonces es una baja corriente pense y las salidas de los optos las mande a un buffer 4010 y ke pasooooó? pues lo mismo, probe con unos comparadores LmM339 y paso lo mismo... Pero cuando a los pines de entrada del PIC(PORTC,0 y 1) les suministro 5V directo de la fuente, trabaja sin problemas....

poca corriente???? no lo se, pero como estoy dispuesto a terminar este proyecto, estaba pensando ser malo con los CIs y cambiarlos por un Rele, pero no keria llegar tan bajo, asi k intente la ultima, utilizar un transistor como switch para alimentar los dichosos pines del PIC, y funcionoooó, pero, peeeeeero... se engancha en 5V y aunke le kite el voltaje en la base se keda con 5 V en el emisor... k sucede? no lo entiendo

Puedo pensar que:...

- El PIC esta defectuoso
- La placa esta mala
- Existen errores en la programacion (el programa que le hice es algo extenso, y lei k es necesario realizar una paginacion para no reescribir y desconfigurar los FSR)

- Los electrones me tienen bronca.

Agradecido, espero su ayuda

PituKons.
20/09/2006 #2


Re: Problemas de corriente en un PIC16f873
pitukons dijo:
Hola amigos,
Tengo una dificultad que ya me tiene podrido, y espero me puedan dar alguna luz
He estado armando un tarifador telefonico basado en un PIC16F873, sin ningun problema he detectado las señales de descolgado y llamada contestada (inversion de polaridad) con optoacopladores, y a la salida de estos la conecte al PORTC,0 y 1, ... k pasó??? pues que el voltaje cayó a zero, entonces es una baja corriente pense y las salidas de los optos las mande a un buffer 4010 y ke pasooooó? pues lo mismo, probe con unos comparadores LmM339 y paso lo mismo... Pero cuando a los pines de entrada del PIC(PORTC,0 y 1) les suministro 5V directo de la fuente, trabaja sin problemas....

poca corriente???? no lo se, pero como estoy dispuesto a terminar este proyecto, estaba pensando ser malo con los CIs y cambiarlos por un Rele, pero no keria llegar tan bajo, asi k intente la ultima, utilizar un transistor como switch para alimentar los dichosos pines del PIC, y funcionoooó, pero, peeeeeero... se engancha en 5V y aunke le kite el voltaje en la base se keda con 5 V en el emisor... k sucede? no lo entiendo

Puedo pensar que:...

- El PIC esta defectuoso
- La placa esta mala
- Existen errores en la programacion (el programa que le hice es algo extenso, y lei k es necesario realizar una paginacion para no reescribir y desconfigurar los FSR)

- Los electrones me tienen bronca.

Agradecido, espero su ayuda

PituKons.
Amigo, pon un esquema de lo que has hecho porque con los "ke paso", "ke sucede" y "ke keda", no entiendo demasiado.

Ya ni queda claro si está como entrada , como salida, si es un diodo, un rele, un transitor o un operacional mezclado con un optoacoplador.

Tal vez tu entiendas lo que has puesto pero creeme que para alguien que no está en tu cabeza o que no conoce tu circuito es prácticamente indecifrable, y en electrónica con solo dar vuelta un diodo un circuito pasa de ser un bloqueador de tensión a ser un rectificador... por solo darte un ejemplo.

Espero poder ayudarte pero antes debieras exponer más claramente el tema.

Saludos
20/09/2006 #3


Re: Problemas de corriente en un PIC16f873
Muchos son los foros que tienen la agradable presencia de maunix.
el incansable maunix.

Por donde miro respondio maunix, aclaró maunix. por aqui pasó maunix.

eso es saber y tener espiritu de colavoracion; yo todavia no he pasado de preguntar.

saludos desde sucre.
20/09/2006 #4


Tienes razon amigo, dificil de entender sin imagen, aqui envio parte del ckto
Imágenes Adjuntas
Tipo de Archivo: jpg pic873_670.jpg (44,6 KB (Kilobytes), 136 visitas)
20/09/2006 #5


Re: Problemas de corriente en un PIC16f873
ben99 dijo:
Muchos son los foros que tienen la agradable presencia de maunix.
el incansable maunix.

Por donde miro respondio maunix, aclaró maunix. por aqui pasó maunix.

eso es saber y tener espiritu de colavoracion; yo todavia no he pasado de preguntar.

saludos desde sucre.
Se agradece
20/09/2006 #6


pitukons, prueba lo siguiente

Ponle a los pines del pic una tensión de fuente con una resistencia en serie.

Vcc -> Resistencia -> Pin RC0

Revisa la tensión en el Pin. Si la misma se mantiene en 5V entonces el PIC está de maravillas.

Revisa que en tu software el TRISC<0> y los demás para cada pin de entrada estén en 1 , que significa "input" o "entrada".

Si está en 0, entonces de seguro has dañado a tu pic con las pruebas que antes hiciste de ponerle tensión de fuente directa a dichos pines!.


Si todo esto está bien, bueno, yo revisaría tu circuito externo. Prueba separar el circuito del PIC y ponle el multímetro a la salida de los buffers. Un osciloscopio sería mejor pero debieras ver que la señal siga en 1 o en 0. SI está en 0 entonces es un problema de la lógica de tu circuito. Si sigue en 1, entonces es "otra" la señal que por alguna razón está reseteando a tu pic.


Luego comenta los resultados así seguimos por resolver el misterio
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.