Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

14/05/2013 #1


Problemas con multiplexado de 2 displays grandes
Hola Amigos del Foros de Electrónica, tengo un problema con la etapa de potencia de mi contador programable.Bueno mi contador es programable, con un pulsador entro a configuración, y con los otros dos , subo y bajo el conteo y con el mismo pulsador que entre a configuración, salgo de la programación y empieza a contar.
Bueno el proyecto me funciona genial en un prototipo que hice con displays normales a 5v.
Ahora eh construido dos displays grandes de 7 leds (verdes alta luminosidad) cada segmento en serie. El problema es que hay segmentos que encienden pero mínimo y distorsionan al numero real a visualizar, por ejemplo: aparece el numero 20 en mi display grande, entonces el cero aparece en el display de las decenas pero con baja intensidad y el dos ygual aparece en las unidades pero en baja intensidad y no deja que se visualice bien el numero y ese es mi problema, ahi adjunto mi esquema en jpg y eagle para que vean y me puedan ayudar . Quizás algún calculo de una resistencia me esta fallando o que....seera
Muchas Gracias AMIGOS.
14/05/2013 #2

Avatar de Scooter

Leds sin resistencia = leds quemados
Quizás por eso has puesto al archivo el nombre "es-quema..."


Además has puesto ya a masa los cátodos así que no multiplexas nada. Las "masas" de un display irán al colector "decenas" y las del otro al colector "unidades"
14/05/2013 #3


no hay respuesta.
cada segmento esta asociado con dos grupos de leds uno de 4 leds y el otro de tres leds, el grupo de 3 leds lleva una resistencia de 150 ohm que equivale a proteger tres leds de una fuente de 12v, el otro grupo de 4 leds esta así porque cada led es de 3 v por cuatro es igual a 12v. Ademas sí eh conectado a cada segmento a cada transistor, osea sí me funciona solo que hay leds que encienden cuando no deben.
14/05/2013 #4
Excluido


ahora decis que hay leds que encienden cuando no deben y al principio no decias eso, decias que prendian con baja intensidad (tipoco de falta de potencia.

decidite !!!

podes poner el esquema sin comprimir:
la fuente y la etapa de control con sus cosillas .


AHI LO PUDE VER !!!
mira, vos decis que anda todo bien en display chiquito, te digo lo que haria yo, es simple y no tiene contra indicaciones , ahacelo y despues conta:

prueba 1 :
puentea transistor bc 557 (alguno, el que quieras) : si al puentearlo esa barra prende bien es que por ahi anda el raquitico.

puentea el TIP (obvio colector - emisor ) si sube la intensidad , por ahi anda la cosa.

si fuese la fuente o el TIP entonces verias que cuando necesitas prender menos leds ( 11 ) prende mas fuerte y cuando queres encender mas leds ( 88 ) se cae todo al piso .
14/05/2013 #5
Moderador

Avatar de elaficionado

Hola.

Los LEDs siempre deben tener una resistencia limitadora de corriente (los LEDs se excitan por corriente y no por voltaje).
Los LEDs son diodos, si le aplicas voltaje directamente no hay manera de saber que corriente fluye por él. Ya que no cumple con la ley de Ohm.

Chao.
elaficionado.
15/05/2013 #6

Avatar de Scooter

No hay problema, cuando se quemen los cambias y les pones resistencias, o los cambias indefinidamente cada vez que se quemen, eso ya lo dejo a tu gusto.
Según el esquema no están bien los transistores de "decenas" y "unidades" como ya te indiqué. El display de la izquierda se encenderá siempre porque los cátodos están a GND y el de la derecha a saber porque están a AGND que no se a donde está conectado. Esos cátodos deberían de estar conectados a los transistores decenas y unidades.
15/05/2013 #7


perseverancia.
Hola Fernandob este es el problema de mi trabajo ahi adjunto la imagen, ah y los componentes son nuevos no creo que me haya venido alguno de los transistores dañados.
Hola elaficionado ya hice la experiencia con grupos de leds y resistencia pero igual mira. ahi adjunto la imagen, como se ve mi falla.
Hola Scooter mira asi le eh conectado como dices, solo que no explique bien al principio, osea mi trabajo funciona el conteo bien solo que parece que se infiltrara algo así como una corriente parásita y es por eso que encienden segmentos que no deben, ahí envío unas imágenes. Gracias por el interés que ponen a ayudarme.
Imágenes Adjuntas
Tipo de Archivo: jpg esquemita.jpg (56,0 KB (Kilobytes), 44 visitas)
Tipo de Archivo: jpg ILUSTRACION.jpg (69,9 KB (Kilobytes), 45 visitas)
15/05/2013 #8

Avatar de Gudino Roberto duberlin

Amigo hamito, el problema de tus displays reside en que, los transistores drivers, nunca alcanzan el estado de corte completo, el esquema electrico que expones, no puede interpretarse con facilidad por el tipo de fondo oscuro.
Que valor poseen las resistencias de base de los transistores PNP y NPN?.
Otra posible causa, la velocidad de multiplexacion es extremadamente alta.
No olvides, añadir la resistencia serie limitadora de corriente de Led, como comentaron los compañeros.
15/05/2013 #9


Hola amigo Gudino aquí posteo mi nuevo diagrama corregido por los amigos del Foro, lo digo por lo de las resistencias limitadoras, ahí también posteo mi esquema en archivo eagle y en pdf.
Me puse a pensar que podría ser el problema en lo que tu me aclaraste sobre la programación, osea la velocidad de multiplexado, Bueno mi programación esta en Proton, bueno ahi en los archivos ya se ven claros las resistencias de cada transistor, espero llegar a saber como calcular estas resistencias para alcanzar el corte completo.
Gracias.
Archivos Adjuntos
Tipo de Archivo: rar ARCHIVOS.rar (152,3 KB (Kilobytes), 41 visitas)
15/05/2013 #10
Moderador

Avatar de elaficionado

Hola.

Pon un diodo en serie con la resistencia de base, y mira que sucede.

Chao.
elaficionado.
15/05/2013 #11

Avatar de Gudino Roberto duberlin

Amigo, las resistencias de base de los transistores PNP de valor 2K7, reducelas a un valor no mayor que 1K.
15/05/2013 #12
Excluido


bueno, si eso no va (yo no le veo nada grosero a el circuito ) , no mire como es ese buffer (ci) pero no veo nda grosero. barra de las

lo que haria y seguro es que lo encontras es seguir la falla, tipico trabajo de electronico.
no es erratica ni nada, asi que se puede seguir, se va midiendo una barra de las que No deberian de prender y se va retrocediendo, hasta encontrar donde esta el problema.

ya vi ese ci que tiene adentro darlingtons , pero me parece que esos T . no tienen Rb , solo es una duda aparte
16/05/2013 #13

Avatar de Scooter

Puede que sea el programa, que cambies de columna y aún conserves los datos de la otra un momnto, prueba a apagar, cambiar columna y mostrar nuevos datos
17/05/2013 #14


sigo sin dar con elproblema
hola amigos del foro, sigo sin dar con mi problema, voy a revisar mi programa del micro quizas tenga que cambiar algún parámetro. Alguna ayuda por ahí sera bien recibida.
17/05/2013 #15
Moderador general

Avatar de DOSMETROS

Creo que se te superpone algún tiempo en el matrizado , quizas algun tema de las velocidades de IC2 o de los transistores de docenas respecto a los de segmentos
17/05/2013 #16

Avatar de Gudino Roberto duberlin

Amigo hamito, añade diodos tipo 1N4148, en serie con cada emisor de los transistores PNP, de esta manera logramos que alcancen con mas facilidad el estado de corte. Deberas calcular nuevamente la resistencia limitadora de cada array de Leds, pues porque ahora tienes una caida de tension de 0.7V. gracias al diodo añadido.
19/05/2013 #17


persiste
hola amigos del foro estoy aquí de nuevo para darles una noticia eh!. Nada con mi contador sigue el problema, empiezo a sospechar que es mi programación, bueno esta proton, espero me puedan ayudar, el programa esta para tres dígitos, pero yo le estoy haciendo solo dos display grandes, ahí adjunto la programación y la simulación en isis. atte
Hamito de Perú.
Archivos Adjuntos
Tipo de Archivo: rar contadorcito.rar (45,7 KB (Kilobytes), 17 visitas)
19/05/2013 #18

Avatar de Gudino Roberto duberlin

Amigo al menos comenta que modificaciones realizaste en el circuito.
19/05/2013 #19


hice todas la modificaciones que me recomendaron, con los diodos 1n4148 al cada emisor del circuito, minimize el ohmiaje a las resistencias de 2.7k por un valor no mayor de 1k. Pero nada y ahora? sigo con mi problema....gracias Gudino.
19/05/2013 #20

Avatar de Gudino Roberto duberlin

Veamos entonces, has lo sig. deten el barrido asi puedes chequear las tensiones. Luego mide el valor de tension en emisor y/o base de los transistores PNP o al menos en uno de ellos, cuando estén en estado de saturación y corte. A continuacion, has las mismas pruebas con los transistores NPN. Luego comenta.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.