Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

15/09/2007 #1


Problemas con ruido electrico
Hola como están.

Estoy construyendo un circuito para un automatismo con un PIC 16f877a el cual me va a recibir unas señales de 12vcd a una distancia de 20 metros por un flexible con 20 líneas de cables de #18 de calibre y por los mismos cables debo enviar un par de fases con voltaje de 220ac para unos motores de 3/4HP y contactores de potencia. Las señales las recibo por medio de unos fototransistores 4N25 y los filtros aterrizándolos con resistencias de 10 k y les pongo condensadores de .1uF.

Entre mayor es la distancia mas inestable se vuelve el PIC y deja de funcionar.

Si me pudieran ayudar a filtrar los ruidos que genera las líneas de 220ac.

Gracias por la atención y ayuda.
15/09/2007 #2


aumenta la intnesidad de la linea.
si trabajas con lo que chupa el led del opto es poco. recalcula colocando una R en paralelo a este para que amente el consumo.
15/09/2007 #3


Y coloca algún que otro condensador para amortiguar algún que otro armónico que se cuele en la detección de la señal
16/09/2007 #4


ponle una bonita ferrita en el cable eso de vez en cuando ayuda
16/09/2007 #5
Moderador general

Avatar de Fogonazo

Si cambiar cables puede ser opcion:
Usa cables blindados (Apantallados) para tus señales, cable tipo microfono.
26/09/2007 #6


El nombre dijo:
Y coloca algún que otro condensador para amortiguar algún que otro armónico que se cuele en la detección de la señal
Gracias por la ayuda, al colocar un condensador de 470uF a 16v en la entrada de la fuente mejoro el rendimiento.

Ahora tengo otro problema, Tengo que almacenar en memoria cuando se pulsan unos botones, en la mismo grupo de cables, en este caso el comun de los botones esta a tierra enviando 0v el cual lo recibe un inversor CMOS y luego le entrega 5v al pic, pero cuando preciono alguno de los botones, me aparece como si precionara ese y otro al azar. Tengo un promedial de 200ms de anti-rebote por software, si durante los 200ms si es mayor a 50% un 1 o un 0 lo almacena.

Gracias de nuevo por la ayuda.
26/09/2007 #7


sube el esquema ya que no es normal.
26/09/2007 #8


Para conexiones no hay nada como el cable de ethernet apantallado y jugando con los pares trenzados.

Parece que tiene un montaje un poco descuidado. tanto ruido.tantos retornos.
15/02/2011 #9


ola a todos,hablando de motos... les comento que implemente un pequeño sistema de seguridad para motos (en especial para esas de 3 llantas), lo realise de dos maneras, la 1ra con CI TTL y 555 y la 2da con un 16f84. Mi problema es el siguiente: al encender el motor de la moto el circuito se altera y enciende automáticamente la alarma. Mi idea es que por el cable el cual estoy conmutando para que apague la moto esta circulando demasiada corriente y esta induciendo en las bobinas del relay, hecho por el cual pienso sustituir el relay por un triac. O si no es eso, entonces podria ser a causa del ruido electrico del motor por el cual se activa solo el sistema. De que manera reduciria el ruido?...si es con condensadores como se de que capacitancia deben de ser?...un comentario mas, el circuito que probe y q se alteraba fue con los conformados por ttl y 555, con el 16f84 aun no lo he probado en la moto, pero cual me recomendarian que seria mejor? el que sta hecho de ttl y 555 o por un pic 16f84?...gracias por la ayuda

ola a todos... les comento que implemente un pequeño sistema de seguridad para motos (en especial para esas de 3 llantas), lo realise de dos maneras, la 1ra con CI TTL y 555 y la 2da con un 16f84. Mi problema es el siguiente: al encender el motor de la moto el circuito se altera y enciende automáticamente la alarma. Mi idea es que por el cable el cual estoy conmutando para que apague la moto esta circulando demasiada corriente y esta induciendo en las bobinas del relay, hecho por el cual pienso sustituir el relay por un triac. O si no es eso, entonces podria ser a causa del ruido electrico del motor por el cual se activa solo el sistema. De que manera reduciria el ruido?...si es con condensadores como se de que capacitancia deben de ser?...un comentario mas, el circuito que probe y q se alteraba fue con los conformados por ttl y 555, con el 16f84 aun no lo he probado en la moto, pero cual me recomendarian que seria mejor? el que sta hecho de ttl y 555 o por un pic 16f84?...gracias por la ayuda
15/02/2011 #10
Moderador general

Avatar de DOSMETROS

Probaste de ponerle capacitores de desacoplamiento a la alimentación cerquita de los integrados , digamos uno de 100 uF junto con 100 nF , también podrías poner dps díodos , uno en serie con el positivo y otro de protección de negativo a positivo.

¿ Le pusiste el díodo a la bobina del relé ?

Saludos !
15/02/2011 #11


gracias por la respuesta, no conecte condensar de acoplamiento pero si lo del diodo en las bobinas del relay, con respecto a los condensadores de acoplamiento, pienso q deberia de conectarlos en la parte de la fuente, y en la alimentacion de los CI, he visto q algunas fuentes usan en paralelo dos condensadores electroliticos en paralelo seguido de uno ceramico, como deberia conectar los condensadores para filtrar el ruido en la alimentacion delos CI? y como calcular que capacitancia deberia de tener?...gracias por su apoyo
16/02/2011 #12
Moderador general

Avatar de DOSMETROS

No se llaman de acoplamiento , esos son los que van en serie para acoplar , en audio por ejemplo.

Éstos son precisamente para desacoplar y se colocan directamente sobre el positivo y negativo del integrado , y en general se utiliza o 10 o 100 uF en paralelo con 0,1 uF.

A veces se coloca antes una resistencia en serie dependiendo del consumo , pero digamos unos 10 o 100 ohms , o el díodo serie desde la alimentación que te dije antes.

Saludos !
30/05/2011 #13


Hola amigos:
Aca donde trabajo tengo unos tornos computarizados los cuales funcionan con servomotores y aveses los driver que comandan a estos, presentan siertas alarmas las cuales son producidas por el famoso ruido electronico me pregunta es como puedo mejorar esto?
saludos amigos.
30/05/2011 #14
Moderador general

Avatar de DOSMETROS

¿ Y si lees arriba ?
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.