Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/05/2011 #61


seleccionaste tu microcontrolador,pulsaste el boton de reset?, comprobaste las conexiones?, debe ser el com1 o com2 no creo que sea otro sino sale con ninguno de esos dos revisa tu grabador, saludos.
28/05/2011 #62

Avatar de Scooter

ocm20 dijo: Ver Mensaje
Buenas, acabo de montar el circuito tal viene, y he probado en el programa los 19 com de puerto y ninguno me lo reconoce :S Que sera?
Que yo sepa va en el LPT y además puertos com de verdad tendrás entre ninguno y dos como mucho.
28/05/2011 #63

Avatar de cosmefulanito04

¿Programa que usaste para programarlo con el puerto paralelo? ¿Verificaste con el programa la memoria flash una vez programado?

¿Cual es el codigo de tu programa para usar el puerto serie?¿Como hiciste la conexion del max232? ¿Cruzaste el cable?.... en fin, da un poco mas informacion.
28/05/2011 #64


Mira, utilice la conexion en serie, con el programa AtmelWrite, y llebo todo el dia mirando el circuito, pero el Programa no me reconoce el circuito.
28/05/2011 #65

Avatar de cosmefulanito04

ocm20 dijo: Ver Mensaje
Mira, utilice la conexion en serie, con el programa AtmelWrite, y llebo todo el dia mirando el circuito, pero el Programa no me reconoce el circuito.
Pero.... ¿que uC estas usando? el AT89S52 solo puede programarse mediante el puerto paralelo.
28/05/2011 #66


No, utilice el AT89s51, por que el programa pone que si se puede programar en serie.
28/05/2011 #67

Avatar de cosmefulanito04

ocm20 dijo: Ver Mensaje
No, utilice el AT89s51, por que el programa pone que si se puede programar en serie.
Es el mismo uC, mas limitado. Leete la hoja de datos, solo se puede programar con el puerto paralelo, salvo que hagas algo en el medio.
28/05/2011 #68


Si, si toy programandolo en serie xD! Bueno intentado programarlo en serie

Estoy haciendo prueba con el polimetro y esta todo bien conectado, pero haciendo pruebas he llegado a la conclusión de que, cuando mando un orden con el PC, si se produce la variación de tensión, pero si el controlador no responde, es decir no cambia la tension de salida, entonces no hay comunicacioón. No se de que sera. ¿Que opinan?
28/05/2011 #69

Avatar de cosmefulanito04

Insisto.... el 89S51/52/53 se programas mediante el puerto paralelo en forma serie (tal como un SPI, pero usando el puerto paralelo), fijate en las hojas de datos.
28/05/2011 #70


No, pero en datsheep tambien pone una programacion en serie, mira de esta manera
http://www.forosdeelectronica.com/at...7&d=1305937633
28/05/2011 #71

Avatar de cosmefulanito04

ocm20 dijo: Ver Mensaje
No, pero en datsheep tambien pone una programacion en serie, mira de esta manera
http://www.forosdeelectronica.com/at...7&d=1305937633
Ahi si puede andar, pense que tenias el puerto serie conectado a Rx, Tx del uC. ¿Quien maneja el reset?¿De donde sacaste ese esquema?
28/05/2011 #72


De este foro, me lo paso otro forero. Pero ya te digo, deberia de ir bien, pero veo señal de salida del pc, pero no respuesta del micro. No se si es el software, el micro que lo haya roto sin querer, o ni idea xD
28/05/2011 #73

Avatar de cosmefulanito04

Ahi veo 2 problemas:

1- Nadie maneja el reset. Tenes que hacerlo vos manualmente, siguiendo las hojas de dato.

2- EA no esta conectado a Vcc, el uC no va a funcionar.
28/05/2011 #74


El reset se controla manualmente, lo toy teniendo en cuenta. LO de EA, entonces tengo que conectarlo a Vcc?
28/05/2011 #75

Avatar de cosmefulanito04

ocm20 dijo: Ver Mensaje
El reset se controla manualmente, lo toy teniendo en cuenta. LO de EA, entonces tengo que conectarlo a Vcc?
Si porque no estas trabajando con memoria externa, mandala a Vcc.
28/05/2011 #76


Nada, asi tampoco funciona xD!
28/05/2011 #77


Hola ocmc20, el grabador funciona tal como esta en el esquema ni mas ni menos conexiones, yo lo use con el AT89S52 sin ningun problema,

Selecciona el tipo de Microcontrolador en el menu chip/AT...
Debes Conectar el grabador y presionar el boton de reset.
Click en en el Boton "Read" (le pones un nombre al archivo y le das en Guardar, aqui se guardara el contenido que se lea del microcontrolador), el que esta junto a "Write" y "Compare"


En Caso de que en la esquina inferior izquierda aparezca :"Comunication Error"
vuelve a pulsar el Reset, si sigue sin funcionar revisa las conexiones,
¿Colocaste adecuadamente el DB9 del puerto serial (el pin 5 va a tierra), alimentaste correctamente el Microcontrolador (Tierra pin 20, Vcc pin 40) y el Max232 (Vcc pin16 Tierra pin 15)?, no son demasiadas conexiones asi que revisalos con paciencia, saludos.


28/05/2011 #78


Buenas, si revise todas las conexiones varias veces jeje, pero nada.
Por que el max y el micro se alimentan de la misma fuente no? a 5 V?
28/05/2011 #79


has diseñado un PCB, si es asi podrias subirlo para revisarlo?, que puerto Com tienes seleccionado?
28/05/2011 #80


No, estoy en la placa prototipos. Como digo, se observa las bajadas de orden, pero el micro no responde a nada xD
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.