Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

19/12/2011 #2361

Avatar de Rigeliano

Muchas gracias dinoelectro no hay problema con Protel yo tengo Altium.

---------- Actualizado después de 19 minutos ----------

Bueno solo modifique un poco el tamaño, aunque tengo que imprimirlo y ver si esta bien, este es el archivo para los que quieran.
20/12/2011 #2362


Dinoelectro, felicitaciones y muchas gracias por el aporte.

Un abrazo.
20/12/2011 #2363


J2C dijo: Ver Mensaje
Thunder2

Lo que tu tendrias que hacer es "Resucitar" tu AtMega, ahora no encuentro el thread justo y ando escaso de tiempo, pero Eclip-se habia realizado algo exacto a lo que necesitas y lo llamo Resux.

Te dejo los thread's:
A) AVR High Voltage Fuse Reset
B) Programador de AVRs (Solo Lazarux)

para que busques a ver si lo encuentras y si no de ultimo deberas solicitarle a Eclip-se mas info, pero ten en cuenta que el no esta continuamente en el foro y deberas ser paciente para esperar su respuesta.


Saludos, JuanKa.-


Yo resucite algunos, con el lazarux y colocandole un cristal de 8 Mghz. Habia cambiado los fuses a oscilador externo, y pense que bueno si le ponia dicho oscilador seguramente comunicara y así fue. ESque el Resux en protoboard te puedes aburrir haciendo puentes.
20/12/2011 #2364

Avatar de dinoelectro

Rigeliano dijo: Ver Mensaje
Muchas gracias dinoelectro no hay problema con Protel yo tengo Altium.

---------- Actualizado después de 19 minutos ----------

Bueno solo modifique un poco el tamaño, aunque tengo que imprimirlo y ver si esta bien, este es el archivo para los que quieran.
gracias rigeliano por tu aporte!!! (yo no podia modificarlo porque hace tiempo que no uso protel99 debido a sus problemas de compatibilidad con los nuevos sitemas operativos)

Nunainos dijo: Ver Mensaje
Dinoelectro, felicitaciones y muchas gracias por el aporte.

Un abrazo.
igualmente gracias numainos... cualquier consulta estare a las ordenes
22/12/2011 #2365


Muchas gracias por tu aporte Dinoelectro, me será de gran ayuda ahora que quiero aprender a programar PICs, si necesitas algo de programación de HC08 de freescale, estaré para ayudarte.

Muchas gracias.
23/12/2011 #2366

Avatar de L lawlied

ola amigos yo tengo mi quemador usb pickit pero cuando intento quemar el pic 16f877a me sale este error...hex file not loaded.... si alguien pudiera ayudarme gracias....
24/12/2011 #2367

Avatar de arrivaellobo

L lawlied, eso a mi me ocurre cuando cargo el .hex pero tengo el pic mal conectado. ¿Cómo lo estas conectando?
24/12/2011 #2368

Avatar de L lawlied

esta bien conectado ya q el pic 16f877 como ocupa todo el espacio para poner pics no creo q lo haya puesto mal y ya descarte el pic porq lo eh quemado en uno q es serial y agarra normal
24/12/2011 #2369

Avatar de arrivaellobo

Si con otro programador te graba bien, el problema es del pickit clone. ¿Es la primera vez que lo usas, o ya has grabado con él antes?
24/12/2011 #2370

Avatar de L lawlied

eso es lo raro sabes puedo quemar otros pics con el pickitnormalazoo.. pero la otra vz q necesitaba hacer un proyecto con el 16f877 me salio ese error...
24/12/2011 #2371

Avatar de dinoelectro

L lawlied dijo: Ver Mensaje
eso es lo raro sabes puedo quemar otros pics con el pickitnormalazoo.. pero la otra vz q necesitaba hacer un proyecto con el 16f877 me salio ese error...
Talvez haga falta calibrar a picKIT 2.. EL SOFTWARE te da esa opcion bajo el menu "TOOLS", utiliza un multimetro y sigue paso a paso las instrucciones que te van apareciendo

saludos!!
24/12/2011 #2372

Avatar de L lawlied

que si boy a intentarlo gracias amigo te pasate
25/12/2011 #2373

Avatar de Rigeliano

Hola dinoelectro queria hacerte una consulta arme el programador que hiciste pero tengo un problema me manda este mensaje de error:"PICKit 2 VPP voltage level error."
No se si debe de darme en el terminal VPP 12 Voltios, si es asi solo salen 500mV.
Como descarto de que sea alguno de los puertos del PIC que esta mal, pues tuve algunos problemas al programarlo y tal vez lo dañe.
Imágenes Adjuntas
Tipo de Archivo: jpg ERROR.JPG (70,7 KB (Kilobytes), 50 visitas)
26/12/2011 #2374

Avatar de dinoelectro

Rigeliano dijo: Ver Mensaje
Hola dinoelectro queria hacerte una consulta arme el programador que hiciste pero tengo un problema me manda este mensaje de error:"PICKit 2 VPP voltage level error."
No se si debe de darme en el terminal VPP 12 Voltios, si es asi solo salen 500mV.
Como descarto de que sea alguno de los puertos del PIC que esta mal, pues tuve algunos problemas al programarlo y tal vez lo dañe.
hola rigeliano, sabes que olvide anotar algo muy importante... todos los transistores 2n3904 y 2n3906 debes soldarlos al contrario de lo que muestra huella... mil disculpas por ese inconveniente; el pickit es completamente funcional... saludos!!!

VPP = 12Voltios estas en lo cierto
26/12/2011 #2375

Avatar de Rigeliano

Si ya me di cuenta de eso pero tarde , pero aun asi no deberia de darme un voltaje en el PIN 12 del PIC por que me da cero voltios que es el que controla el PWM para el VPP
26/12/2011 #2376

Avatar de Rigeliano

Ya funciona perfectamente cambie los transistores y el cristal que le puse de 4 MHZ solo tengo que conseguir los 680uH que no encuentro en ningun lado, para probarlo tuve que ponerle como 5 bobinas en serie por lo demas funciona bien probe con 16f628A y 16f877A. Con los cambios que dijiste y la pequeña modificacion de tamaño que le hice a tu diseño creo que ya no hay excusas para no tener un programador USB. Gracias dinoelectro
28/12/2011 #2377

Avatar de dinoelectro

Rigeliano dijo: Ver Mensaje
Ya funciona perfectamente cambie los transistores y el cristal que le puse de 4 MHZ solo tengo que conseguir los 680uH que no encuentro en ningun lado, para probarlo tuve que ponerle como 5 bobinas en serie por lo demas funciona bien probe con 16f628A y 16f877A. Con los cambios que dijiste y la pequeña modificacion de tamaño que le hice a tu diseño creo que ya no hay excusas para no tener un programador USB. Gracias dinoelectro
felicidades rigeliano, me alergro de que te haya servido respecto a la bobina puedes utilizar una desde 480 hasta 1000uH

nota: el crystal debe ser de 20MHZ talves tengas inconvenientes con ese 4MHZ

en este link encontraras un pickit muy completo incluso para grabar micros que trabajan con 3.3v
http://www.micros-designs.com.ar/pickit2-clone-5v3-3v/
28/12/2011 #2378

Avatar de Rigeliano

Por eso lo decia me equivoque poniendole de 4MHz por eso no funcionaba y si pude encontrar bobinas de 680uH pero funciona en la practica desde al rededor de 300uH pero con un voltaje bajo de salida, pero como tu dices con un minimo de 480 seria lo ideal.
11/01/2012 #2379


Hola a todos tengo una pregunta bueno arme el programado primero en proto lo reconocio , detecta el microcontrolador (en este caso probe 16f877a y el 18f4550) , los programe , borre , verifique ; bueno todo correcto en pocas palabras funciono muy bien . pero al hacer el diseño para pasarlo a placa me di cuenta que cometi un error el cual fue cambiar el pin 12 por el 13 que es VPP_PUM pero a la hora de corregir el error
en el proto resulta que ya no funciona ya no reconoce ningun pic . Regrese todo como estaba osea los pines equivocados y funciona en pocas palabras mal armado funciona y armado correctamente no a que se debe esto ?? que me recomiendan asi lo dejo tal como lo tengo con ese error y si lo dejase a asi que puede pasar ?
23/01/2012 #2380


dinoelectro dijo: Ver Mensaje
Talvez haga falta calibrar a picKIT 2.. EL SOFTWARE te da esa opcion bajo el menu "TOOLS", utiliza un multimetro y sigue paso a paso las instrucciones que te van apareciendo

saludos!!

Buenas. A mi me falla a veces al grabar y he intentado hacer eso que pones, pero cuando te pide que ingreses el valor que estas midiendo con el voltimetro (a mi me sale 5.15v), al darle a calibrar pone: "Could not fully calibrate the unit. The USB voltage may be too low to completely calibrate"

Gracias.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.