Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

26/07/2013 #2721

Avatar de Moyano Jonathan

470 uH espero me pueda servir XD bueno según algunos compañeros con una de 330 uH deberá funcionar también.
A partir de 470uhy tiene que andar bien.
28/07/2013 #2722


Justamente Jonathan hoy estaba realizando unas pruebas del pickit XD y todo va de lujo XD gracias por el aporte y mis buenos augurios a la distancia
30/07/2013 #2723


Estoy con un pequeño problema con un programador Pickit clone 2 que hice de acuerdo a los esquemas e instructivos de esta página:
http://sergiols.blogspot.com.ar/2009...-reloaded.html (el de felixls que muchos deben conocer)
Bueno el tema es que hoy acabo de terminarlo después de comprar una resistencia que me faltaba, y a la hora de conectarlo a la computadora no me lo reconoce. La computadora es una netbook de las del gobierno marca EXO.
Sin embargo probé conectarlo en la PC de escritorio (que pese a sus años y quiñes sigue andando la pobrecita XD) y lo detectó de inmediato, me instaló automáticamente los drivers y todo...
Asumo que puede deberse a una diferencia de capacidad de corriente de los puertos USB de una y de otra máquina.
¿Qué solución le ven al tema? ¿Puede ser cambiando el capacitor de filtro de la alimentación USB (uno electrolítico de 10uF) por otro más chico de modo que consuma menos corriente?
También había leído algo sobre conectar a dos puertos de la computadora, uniendo los cables de alimentación de los dos (para aumentar la corriente) y usando los de datos de uno sólo. ¿Esto puede funcionar?
También sospecho que el problema no sea de corriente, dudo que el pickit consuma tanto, pero me resulta muy extraño que ande en una computadora y en la otra no. Ambas tienen windows xp.
¿Qué me recomiendan?
Desde ya agradecido.
Saludos.
13/08/2013 #2724

Avatar de Marce

Buenas noches, termine de construir el mio, solo me falta el pic para configurar el programa, al conectar el usb me enciende el led verde, asi que cuando consiga el pic voy a ver si esta todo bien montado, dejo un par de fotos, muchas gracias por el aporte!

27/09/2013 #2725


Muy buenas a todo el mundo. A mi me pasa lo mismo que el compañero lapulga5. No hay manera de que me detecte el dispositivo el PC. Ni en MPLAB, ni en PICKIT2 consigo que lo detecte tampoco. Me sale:
Initializing PICkit 2 version 0.0.3.63
PK2Error0022: PICkit 2 not found
PICkit 2 Ready

Ya no se lo que hacer. Lo he montado sobre placa y sobre board, y siempre lo mismo. Es urgente y agradeceria enormemente algún aporte que me ayude a solucionar el problema
Muchas gracias
27/09/2013 #2726

Avatar de Nano24

moliarti dijo: Ver Mensaje
Muy buenas a todo el mundo. A mi me pasa lo mismo que el compañero lapulga5. No hay manera de que me detecte el dispositivo el PC. Ni en MPLAB, ni en PICKIT2 consigo que lo detecte tampoco. Me sale:
Initializing PICkit 2 version 0.0.3.63
PK2Error0022: PICkit 2 not found
PICkit 2 Ready

Ya no se lo que hacer. Lo he montado sobre placa y sobre board, y siempre lo mismo. Es urgente y agradeceria enormemente algún aporte que me ayude a solucionar el problema
Muchas gracias
Yo por eso me hice este sencillisimo programador por el puerto serial, lo hice para PICs de 8, 18, 28 y 40 pines.

http://oi54.tinypic.com/vov5u9.jpg
Imágenes Adjuntas
Tipo de Archivo: gif vov5u9.jpg.gif (23,9 KB (Kilobytes), 77 visitas)
27/09/2013 #2727


Nano24 dijo: Ver Mensaje
Yo por eso me hice este sencillisimo programador por el puerto serial, lo hice para PICs de 8, 18, 28 y 40 pines.

http://oi54.tinypic.com/vov5u9.jpg
Prueba el pic en un programador que sí funcione. Creo que ese es el problema, si es que el resto del circuito está bien. Como lo has probado en una protoboard, no creo que tengas problemas de corto, aunque es probable que sí pueda ser un falso contacto, es raro que eso pase. Puedes armar el programador JDM de Kemisa.es para probar y programar el PIC 18F2550, pero recuerda que el cable no debe superar la longitud de 60 cm. Te dejo el link para que lo armes:

http://www.kemisa.es/circuito_progra...ocesadores.php

Saludos y éxitos!!!
29/09/2013 #2728


Muchas gracias Nano24 y Arsenic por vuestra ayuda. Voy a probar ambas opciones y os comentare que tal a ido. Gracias de nuevo
29/09/2013 #2729

Avatar de yoelmicro

Hola.
Revisa el capacitor conectado al pin 14 del PIC, este capacitor almacena la energía relacionada al USB y si tiene rizos no te lo detectara Windows, mucho menos el software relacionado.

Espero lo hagas funcionar, es buen programador.
30/09/2013 #2730


hola yoelmicro. Como puedo comprobar si el capacitor del pin 14 esta bien?
30/09/2013 #2731

Avatar de Moyano Jonathan

hola yoelmicro. Como puedo comprobar si el capacitor del pin 14 esta bien?
1º - Fijate si hay contacto entre el pin 14 del microcontrolador y el capacitor.
2º - El capacitor tiene que estar conectado el pin + del capacitor al pin 14 del microcontrolador.
3º - El capacitor tiene que tener un valor de 470nF (capacitor multicapa) o 4.7uF electrolítico....como
premisa, si usas electrolítico tiene que ser mayor a 1uF.

Saludos !
04/10/2013 #2732


Hola , les hago una consulta a todos aquellos que hayan hecho el programador.
Porque hice la plaqueta , que publicò Moyano en la primero hoja...
Pero , al ejecutar el programa " Pickit 2" , me sale èsto...



Y leyendo el manual que tambièn publicò en la primera hoja.. , en administrador de dispositivos , me sale èsto:



Èste , es el diseño que utilicè:



Lo que me llamò la atenciòn , es que al conectarlo , no me aparece nada en la pantalla... , es decir , es como si no hubiese conectado nada a la pc
Debo aclarar , que por lo medido, no tengo cortocircuitos , ni nada.
Los componentes , los puse tal cual figuran en pcb wizzard, y con los valores que indican haciendo doble click en el componente.
05/10/2013 #2733


Holas dijo: Ver Mensaje
Hola , les hago una consulta a todos aquellos que hayan hecho el programador.
Porque hice la plaqueta , que publicò Moyano en la primero hoja...
Pero , al ejecutar el programa " Pickit 2" , me sale èsto...

http://www.dmtinc.cl/imagenes/TFyb2.png

Y leyendo el manual que tambièn publicò en la primera hoja.. , en administrador de dispositivos , me sale èsto:

http://www.dmtinc.cl/imagenes/Vf9L.png

Èste , es el diseño que utilicè:

http://www.dmtinc.cl/imagenes/RGKb.png

Lo que me llamò la atenciòn , es que al conectarlo , no me aparece nada en la pantalla... , es decir , es como si no hubiese conectado nada a la pc
Debo aclarar , que por lo medido, no tengo cortocircuitos , ni nada.
Los componentes , los puse tal cual figuran en pcb wizzard, y con los valores que indican haciendo doble click en el componente.
Probá grabar nuevamente el pic. Configura bien el oscilador a XT (Cristal de cuarzo) en 20MHz. Si el error persiste, comprobá la tensión del pic o probá en otro puerto trasero. Es posible que la fuente de la PC no llegue a alimentarlo correctamente. Podes verificar eso con una fuente de alimentación de 5V aparte y sólo el cable con el Rx-Tx a la pc. Otra cosa que pide, es soldar la carcaza del conector usb a la placa, pues es parte del circuito. Comprobá las tensiones en la salida. Verificá el cable antes que nada. Puede ser que el cable de entrada o salida de datos se haya cortado. Luego de haber comprobado todo eso, cambiá el pic y probá nuevamente. A mi me ha funcionado con un inductor de 680 y de 470 microHenrios.
05/10/2013 #2734


No entiendo lo de configurar el cristal. Si el cristal viene de 20mhz.
El conector hembra usb b , tambièn lo tengo soldado en la plaqueta....
Ahora subo fotos
05/10/2013 #2735


Acà , les dejo las que pude tomar
Imágenes Adjuntas
Tipo de Archivo: jpg DSCF3684.jpg (59,1 KB (Kilobytes), 69 visitas)
Tipo de Archivo: jpg DSCF3686.jpg (87,4 KB (Kilobytes), 52 visitas)
05/10/2013 #2736


Holas dijo: Ver Mensaje
No entiendo lo de configurar el cristal. Si el cristal viene de 20mhz.
El conector hembra usb b , tambièn lo tengo soldado en la plaqueta....
Ahora subo fotos
Configurar el programador que utilizas para grabar el pic en XT, a 20MHz. A eso me refería.

---------- Actualizado después de 2 minutos ----------

Holas dijo: Ver Mensaje
Acà , les dejo las que pude tomar
¿Estás usando un PIC16F876 o estoy viendo mal? El microcontrolador requerido es un PIC18F2550
05/10/2013 #2737


Saludos amigo, concuerdo con Arsenic, parece que estas usando el pic16f876, con ese pic nunca te va a funcionar. Suerte!
05/10/2013 #2738


Claro , estaba tratando de programar ese pic.
Creìa , que se ponìa el pic y listo...
Osea , que tengo que poner primero el PIC18F2550 , luego tendrìa que programarlo, y recièn despuès podrìa programar el pic 16F876?
06/10/2013 #2739


Holas dijo: Ver Mensaje
Claro , estaba tratando de programar ese pic.
Creìa , que se ponìa el pic y listo...
Osea , que tengo que poner primero el PIC18F2550 , luego tendrìa que programarlo, y recièn despuès podrìa programar el pic 16F876?
Asi es. El dispositivo es un clon del pickit2 (una copia del programador comercial de microchip) que lleva el pic18f2550. Su salida es el ICSP (In Circuit Serial Program) y se conecta en una protoboard para programar otros pic's. Para que el dispositivo funcione, el PIC18F2550 debe estar programado con el software que podrás encontrar en el sitio oficial de Microchip, al igual que el software que utiliza. Me refiero al pickit2. Logicamente, también se puede utilizar el proteus o el mplab para programarlo con ese dispositivo. Para programar el pic, se puede utilizar el JDM.
07/10/2013 #2740

Avatar de Nuyel

Holas dijo: Ver Mensaje
Claro , estaba tratando de programar ese pic.
Creìa , que se ponìa el pic y listo...
Osea , que tengo que poner primero el PIC18F2550 , luego tendrìa que programarlo, y recièn despuès podrìa programar el pic 16F876?
Para ser más claro
1.- Programas el PIC18F2550 usando otro programador
2.- Lo insertas en la base de este programador que acabas de hacer
3.- Lo conectas al USB y debería reconocerlo e instalarlo como un dispositivo HID
--Opcional si quieres programar usando los voltajes regulados (con los chips de 5V no importa)--
4.- Abres el programa PICkit 2
5.- Confirmado que se detecta abres el menú "Tools" y luego "Calibrate VDD & Set Unit ID..."
6.- Sigues las instrucciones para calibrar los voltajes de salida con la ayuda de un voltimetro (idealmente de 3 decimales a 5V) y nombrar tu programador.

Luego ya para programar otros chips
1.- Tomas las señales del ICSP de este programador y las conectas como sea necesario al pic que quieres programar
2.- Programas el PIC que quieres programar
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.