Haz una pregunta
  Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

13/11/2010 #1581


cristian_elect dijo: Ver Mensaje
Ya tengo probado el pickit2 el misma targeta selecciona voltaje cuando selecciona pic de 3.3v o 5v.
Ese regulador del pickit2 con opam y un mosfet canal p funciona bien.

asii y tienes ele diagramaa ahiia amigoo.. yo stoy necesitando un diagrama .. aver si me lo proporcionas ps.
13/11/2010 #1582


El esquema de Suky funciona bien hay mando el pdf.
El que yo ise trabaja con el mosfet mas cercano al original se autoseleciona el voltaje con software.
13/11/2010 #1583

Avatar de Moyano Jonathan

para poder autoseleccionar el voltaje de trabajo tenés que usar un operacional de bajo ruido como el MCP6001 de microchip es la única forma ....ahi podes usar el esquema original de microchip para hacer tu programador.
15/11/2010 #1584


Si funciona con el opam lm358n con irf9540 otro irf mas chico cuesta mas caro.
15/11/2010 #1585

Avatar de Moyano Jonathan

yo lo he probado con LM358 y su funcionamiento es herratico....tiene que ser si o si de alimentación simple y bajo ruido...ST semiconductores tiene muchos de estos OAMP pero hay que buscarlos...
16/11/2010 #1586


bueno funciona bien es para corrientes bajas no mas 150mA tambien el usb no da mas.
Buscare un opam con cmrr mas alto para probar.
El lm358 funciona bien con alimentacion simple segunsu haja de datos tambien lo use para pre amplificador con una bateria de 9v y funciona bien.
16/11/2010 #1587


mira este CA3140
16/11/2010 #1588


mis pruebas.
para pic de 3.3v:
Salida sin carga 3.45v, conectado el pic en grabacion 3.2v contando que la fuente del usb bajo 0.25..v con carga creo tambien se debe que el cable es delgado.
Para pic 5V:
Sin carga 4.85V.
Con pic en grabacion 4.6v.
Es aceptable esa cifras o que me recomiendan.
Si hay otro opam mejor que sea comun en el mercado seria bueno que recomienden para probar
16/11/2010 #1589


hola soy nuevo en esto de programar micros... y e mirado el gran blog de felix y he visto sus clones y arme una de ellos pero se daño... ademas las pistas son super delicadas "delgadas" y se dañaron en muchos de mis intentos, hoy pase por aki gracias a google pero tengo dudas... no me keda claro la lista... no se donde van los componentes, me podrian colaborar, gracias.
26/11/2010 #1590

Avatar de muessli

Hola, bueno tengo un clon armado de pickit 2 y funciona perfecto, ahora el problema:
una vez probe activarle a un 16f628a la dos protecciones que trae el soft de pickit2 (code y data protect) todo funciono a las mil maravillas, ahora a la hora de actualizar el codigo del pic , al querer escribirlo nuevamente me sale programming failed at program memory adress 0x000000
Aclaro que el pickit me reconoce el pic, me lo deja borrar, leer, pero al momento de escribir ERROR!.
Alguna idea de porque o como solucionarlo?
27/11/2010 #1591


muessli dijo: Ver Mensaje
Hola, bueno tengo un clon armado de pickit 2 y funciona perfecto, ahora el problema:
una vez probe activarle a un 16f628a la dos protecciones que trae el soft de pickit2 (code y data protect) todo funciono a las mil maravillas, ahora a la hora de actualizar el codigo del pic , al querer escribirlo nuevamente me sale programming failed at program memory adress 0x000000
Aclaro que el pickit me reconoce el pic, me lo deja borrar, leer, pero al momento de escribir ERROR!.
Alguna idea de porque o como solucionarlo?


Prueba desactivando la casilla de la escritura de la EEprom en la parte inferior de la pantalla inicial del programa del pickit2.

Eso me pasaba a mi con mi primer quemador.
27/11/2010 #1592

Avatar de muessli

Prueba desactivando la casilla de la escritura de la EEprom en la parte inferior de la pantalla inicial del programa del pickit2.

Eso me pasaba a mi con mi primer quemador.
Hola Juxn3, ya probe eso y me sigue dando el mismo error. que sera entonces?
27/11/2010 #1593


muessli dijo: Ver Mensaje
Hola Juxn3, ya probe eso y me sigue dando el mismo error. que sera entonces?
Ese error corresponde a una diferencia de programa entre el que cargaste para grabar y el que se grabo en el pic, posiblemente el pic tiene daños en la ram donde no se deja copiar.
27/11/2010 #1594

Avatar de J2C

Muessli

Prueba con "Control P" y/o "Control D" en cualquier pantalla del PicKit2 para desactivar las opciones de "Program Protect" y "Data Protect", fijate que al lado de Device, debajo de la Configuración no aparezca ningun texto en rojo.

Cuando proteges algo te quedara por Defecto (Default) la opción esa.

Saludos, JuanKa.-
27/11/2010 #1595

Avatar de muessli

Ese error corresponde a una diferencia de programa entre el que cargaste para grabar y el que se grabo en el pic, posiblemente el pic tiene daños en la ram donde no se deja copiar.
Juxn3, lo extraño es que no deberia haberse roto nada, era un codigo muy simple de prender unos leds.Ademas el pic nunca fue mas alla del protoboard, no se como se podria haber roto algo de la mamoria.

Prueba con "Control P" y/o "Control D" en cualquier pantalla del PicKit2 para desactivar las opciones de "Program Protect" y "Data Protect", fijate que al lado de Device, debajo de la Configuración no aparezca ningun texto en rojo.

Cuando proteges algo te quedara por Defecto (Default) la opción esa.
Hola JuanKa, tambien probe desactivar los protect (ambos), pero es lo mismo, sigue sin poder grabar nuevamente.
27/11/2010 #1596

Avatar de J2C

Muessli

El 16F628A tiene el pin #10 RB4/PGM que habilita la LVP (programacion con bajo voltaje) si esta a "1" (+5V), como tu dices que siempre lo has tenido en el Protoboard me imagine que con el circuito conectado y no estoy seguro si eso podria provocar problemas.

Por otro lado alguna vez he leido con otros Programas de Software y otros Programadores de Hardware que dicho PGM/RB4 (pin #10) debe estar a masa durante la programación que realizamos con VPP (+13V) en el pin #4 (MCLR).

Sino deberiamos pensar que ese Micro se malogro por ESD (Descargas Electro-Estaticas).

Espero ser de ayuda. Saludos, JuanKa.-

P.D.: Perdona mi demora en responderte.-
29/11/2010 #1597

Avatar de muessli

Hola J2C, bueno gracias por lo que me comentas, voy a ver si descubro que sucedio.
Saludos.
29/11/2010 #1598


Hola Moyano. Primera vez que escribo en este foro, disculpen cualquier ignorancia. El caso es que yo reparo TVs y en muchos caso hay que reprogramar las eeprom (24Cxx). Venía programandolas con el Ponyprog y su dispositivo de conexión serial, pero como se dañó mi PC y las PCs modernas no traen el conector serial (Com1, Com2) me veo en la necesidad de usar un programador USB. Y lo que quiero saber 1) Si este programador tuyo me sirve. 2) Y si sirve, la conexión de la eeprom es directa a la interface (dispositivo)???? y 3) Como es dicha conexión ( Osea que pines de la eeprom van conectados a la interface en J2) Bueno creo que me comprendes lo que te que te quiero decir. Disculpa la molestia y de antemano te agradezco Cualquier ayuda que me puedas brindar.
Espero tu respuesta.
Suerte y éxitos.....
29/11/2010 #1599

Avatar de Moyano Jonathan

Hola tecnels, te paso a responder:

1 - Si te sirve para las memorias eeprom de televisores, para ver cual programa buscá en la ayuda del pickit2 que trae la aplicación.
2 - La conexión no es directa. Luego pongo como van conectadas las memorias.
29/11/2010 #1600


Gracias amigo Moyano. Espero tu valiosas explicación de la conexión
De nuevo gracias.
Te dejo mi correo si deseas contactar conmigo personalmente por el messenger (políticas@delforo.com)
Bueno amigo te deseo muchos éxitos....


¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Foros de Electrónica » Diseño digital » Microcontroladores y sistemas embebidos

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.